source: projects/specs/trunk/p/perl-SQL-Statement/perl-SQL-Statement-vl.spec @ 12120

Revision 12120, 2.7 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define perl_vendorlib  %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2Summary: SQL-Statement module for perl
3Name: perl-SQL-Statement
4Version: 1.412
5Release: 1%{?_dist_release}
6License: Artistic or GPL
7Group: Development/Libraries
8URL: http://search.cpan.org/~jzucker/SQL-Statement/
9Source0: http://www.cpan.org/authors/id/J/JZ/JZUCKER/SQL-Statement-%{version}.tar.gz
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14BuildArch: noarch
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(Clone)
18#BuildRequires:  perl(Math::Base::Convert)
19BuildRequires:  perl(Module::Runtime)
20BuildRequires:  perl(Params::Util)
21BuildRequires:  perl(Test::Deep)
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24%description
25SQL-Statement module for perl
26
27%prep
28%setup -q -n SQL-Statement-%{version}
29find -type f -exec chmod a-x {} +
30sed -i -e 's/\r//' README
31
32%build
33export SQL_STATEMENT_WARN_UPDATE=sure
34CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor" NO_PACKLIST=1
35
36%check
37make test
38
39%clean
40rm -rf $RPM_BUILD_ROOT
41
42%install
43rm -rf $RPM_BUILD_ROOT
44make DESTDIR=$RPM_BUILD_ROOT pure_install
45chmod -R u+w %{buildroot}/*
46
47find $RPM_BUILD_ROOT%{_prefix} -type f -print |
48        sed "s@^$RPM_BUILD_ROOT@@g" |
49        grep -v ^%{_mandir} |
50        grep -v perllocal.pod |
51        grep -v "\.packlist" > %{name}.files
52if [ "$(cat %{name}.files)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56
57%files -f %{name}.files
58%defattr(-,root,root)
59%license ARTISTIC-1.0 GPL-1 GPL-2.0 LICENSE
60%doc Changes README README.md
61%dir %{perl_vendorlib}/SQL
62%dir %{perl_vendorlib}/SQL/Dialects
63%dir %{perl_vendorlib}/SQL/Statement
64%{_mandir}/*/*
65
66%changelog
67* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> -1.412-1
68- new upstream release.
69- rebuilt with perl-5.26.
70
71* Fri Dec  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.405-1
72- updated to 1.405
73
74* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.33-3
75- build with Perl 5.16
76
77* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.33-2
78- rebuild
79
80* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.33-1
81- updated to 1.33
82
83* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.15-2
84- rebuild with perl-5.12.3
85
86* Mon May 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15-1
87- applied new versioning policy
88
89* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15-0vl1
90- updated to 1.15
91- changed Group to Development/Libraries
92- s/Copyright/License/
93
94* Wed Sep  7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14-0vl1
95- updated to 1.14, build for perl 5.8.x
96- updated URL
97- use vendor_perl
98
99* Sat Apr 13 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.004-0vl1
100- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.