source: projects/specs/trunk/p/perl-Ref-Util/perl-Ref-Util-vl.spec @ 12120

Revision 12120, 5.5 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# Run optional test
2%bcond_without perl_Ref_Util_enables_optional_test
3
4Name:           perl-Ref-Util
5Version:        0.204
6Release:        5%{?_dist_release}
7Summary:        Utility functions for checking references
8License:        MIT
9URL:            https://metacpan.org/release/Ref-Util
10Source0:        https://cpan.metacpan.org/authors/id/A/AR/ARC/Ref-Util-%{version}.tar.gz
11
12Vendor:        Project Vine
13Distribution:  Vine Linux
14
15BuildArch:      noarch
16# Build
17BuildRequires:  coreutils
18BuildRequires:  findutils
19BuildRequires:  make
20BuildRequires:  perl >= 2:5.26.2
21BuildRequires:  perl(ExtUtils::MakeMaker)
22BuildRequires:  perl(lib)
23BuildRequires:  perl(Text::ParseWords)
24# Dependencies of bundled ExtUtils::HasCompiler
25BuildRequires:  gcc
26BuildRequires:  perl(base)
27BuildRequires:  perl(Config)
28BuildRequires:  perl(DynaLoader)
29BuildRequires:  perl(File::Basename)
30BuildRequires:  perl(File::Spec::Functions)
31BuildRequires:  perl(File::Temp)
32# Module
33BuildRequires:  perl(Carp)
34BuildRequires:  perl(constant)
35BuildRequires:  perl(Exporter)
36BuildRequires:  perl(Scalar::Util)
37BuildRequires:  perl(strict)
38BuildRequires:  perl(warnings)
39# Test Suite
40BuildRequires:  perl(File::Find)
41BuildRequires:  perl(File::Spec)
42BuildRequires:  perl(IPC::Open2)
43BuildRequires:  perl(Ref::Util::XS)
44BuildRequires:  perl(Test::More)
45%if %{with perl_Ref_Util_enables_optional_test}
46# Optional Tests
47BuildRequires:  perl(B::Concise)
48BuildRequires:  perl(CPAN::Meta)
49BuildRequires:  perl(Readonly)
50%endif
51# Runtime
52Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
53Requires:       perl(Ref::Util::XS)
54
55%description
56Ref::Util introduces several functions to help identify references in a faster
57and smarter way.
58
59%prep
60%setup -q -n Ref-Util-%{version}
61
62%build
63perl Makefile.PL INSTALLDIRS=vendor
64make %{?_smp_mflags}
65
66%install
67make pure_install DESTDIR=%{buildroot}
68find %{buildroot} -type f -name .packlist -delete
69%{_fixperms} -c %{buildroot}
70
71%check
72make test
73
74%files
75%if 0%{?_licensedir:1}
76%license LICENSE
77%else
78%doc LICENSE
79%endif
80%doc Changes README
81%{perl_vendorlib}/Ref/
82%{_mandir}/man3/Ref::Util.3*
83%{_mandir}/man3/Ref::Util::PP.3*
84
85%changelog
86* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.0204-5
87- initial build for Vine Linux.
88
89* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.204-4
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
91
92* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.204-3
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
94
95* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.204-2
96- Perl 5.28 rebuild
97
98* Thu Apr 19 2018 Paul Howarth <paul@city-fan.org> - 0.204-1
99- Update to 0.204
100  - Fix Makefile.PL so that the 'install' sub is patched before WriteMakefile()
101    is called (GH#41)
102
103* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.203-4
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
105
106* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.203-3
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
108
109* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.203-2
110- Perl 5.26 rebuild
111
112* Mon May 15 2017 Paul Howarth <paul@city-fan.org> - 0.203-1
113- Update to 0.203
114  - Fix space/tab issue in Makefile
115  - Don't use DynamicPrereqs for unrelated Makefile.PL snippet
116  - Use of the Pure-Perl implementation can now be forced at runtime by setting
117    either $Ref::Util::IMPLEMENTATION or $ENV{PERL_REF_UTIL_IMPLEMENTATION} to
118    "XS"
119  - Fix is_*_formatref() error messages (GH#38)
120  - Speed enhancements for is_*_formatref() on 5.8+
121  - Restore 5.6 and 5.8 compatibility
122  - PP behaviour now matches XS for \v1.2.3 and \sub {}
123  - Updated documentation to reflect the PP/XS split
124
125* Fri May 12 2017 Paul Howarth <paul@city-fan.org> - 0.200-1
126- Update to 0.200
127  - Reimplement in pure Perl, with a dynamic dependency on a new Ref::Util::XS
128    module that contains the fast XS implementation
129- This release by ARC → update source URL
130- Package is now noarch
131
132* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.113-2
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
134
135* Tue Jan 17 2017 Paul Howarth <paul@city-fan.org> - 0.113-1
136- Update to 0.113
137  - Fix bugtracker link
138
139* Sun Jan 15 2017 Paul Howarth <paul@city-fan.org> - 0.112-1
140- Update to 0.112
141  - Fix compilation on Sun (Oracle) and some MSVC compilers (GH#35)
142
143* Fri Dec 30 2016 Paul Howarth <paul@city-fan.org> - 0.111-1
144- Update to 0.111
145  - Fix test failure on 5.8.5 and under
146  - Moved to Dist::Zilla
147
148* Thu Dec 29 2016 Paul Howarth <paul@city-fan.org> - 0.110-1
149- Update to 0.110
150  - Fix support of 5.8 (GH#29, GH#34)
151  - Additional optimizations
152  - More extensive test suite
153
154* Mon Aug 29 2016 Paul Howarth <paul@city-fan.org> - 0.101-1
155- Update to 0.101
156  - A test accidentally added a dependency on Readonly.pm - fixed! (GH#30)
157  - Update README
158
159* Sat Aug 27 2016 Paul Howarth <paul@city-fan.org> - 0.100-1
160- Update to 0.100
161  - Support situations in op-code implementation where the parameters do not
162    come as a list
163  - Fix memory leak in dangling op
164  - Support magic (tied variables)
165  - Rework op implementation
166  - Speed up by changing the top of the stack instead of POPing and PUSHing
167  - Update ppport.h file from Devel::PPPort and remove the copy of SVRXOK since
168    it's now available
169  - Add license in Pod
170  - Specify minimum version of perl (5.6.2)
171
172* Thu Jul 28 2016 Paul Howarth <paul@city-fan.org> - 0.020-2
173- Sanitize for Fedora submission
174
175* Thu Jul 28 2016 Paul Howarth <paul@city-fan.org> - 0.020-1
176- Initial RPM version
Note: See TracBrowser for help on using the repository browser.