source: projects/specs/trunk/p/perl-Ref-Util-XS/perl-Ref-Util-XS-vl.spec @ 12120

Revision 12120, 5.0 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# Run optional tests
2%if ! (0%{?rhel})
3%bcond_without perl_Ref_Util_XS_enables_optional_test
4%else
5%bcond_with perl_Ref_Util_XS_enables_optional_test
6%endif
7
8Name:           perl-Ref-Util-XS
9Version:        0.117
10Release:        6%{?_dist_release}
11Summary:        Utility functions for checking references
12License:        MIT
13URL:            https://metacpan.org/release/Ref-Util-XS
14Source0:        https://cpan.metacpan.org/authors/id/X/XS/XSAWYERX/Ref-Util-XS-%{version}.tar.gz
15
16Vendor:        Project Vine
17Distribution:  Vine Linux
18
19# Build
20BuildRequires:  coreutils
21BuildRequires:  findutils
22BuildRequires:  gcc
23BuildRequires:  make
24BuildRequires:  perl >= 2:5.26.2
25BuildRequires:  perl(ExtUtils::MakeMaker)
26# Module
27BuildRequires:  perl(Exporter)
28BuildRequires:  perl(strict)
29BuildRequires:  perl(warnings)
30BuildRequires:  perl(XSLoader)
31# Test Suite
32BuildRequires:  perl(constant)
33BuildRequires:  perl(File::Spec)
34BuildRequires:  perl(Test::More)
35%if %{with perl_Ref_Util_XS_enables_optional_test}
36# Optional Tests
37BuildRequires:  perl(B::Concise)
38BuildRequires:  perl(CPAN::Meta)
39BuildRequires:  perl(Readonly)
40%endif
41# Runtime
42Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
43
44# Avoid provides for private objects
45%{?perl_default_filter}
46
47%description
48Ref::Util::XS introduces several functions to help identify references in a
49faster and smarter way.
50
51%prep
52%setup -q -n Ref-Util-XS-%{version}
53
54%build
55perl Makefile.PL INSTALLDIRS=vendor
56make %{?_smp_mflags}
57
58%install
59make pure_install DESTDIR=%{buildroot}
60find %{buildroot} -type f -name .packlist -delete
61find %{buildroot} -type f -name '*.bs' -empty -delete
62%{_fixperms} -c %{buildroot}
63
64%check
65make test
66
67%files
68%license LICENSE
69%doc Changes README
70%{perl_vendorarch}/auto/Ref/
71%{perl_vendorarch}/Ref/
72%{_mandir}/man3/Ref::Util::XS.3*
73
74%changelog
75* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.117-6
76- initial build for Vine Linux.
77
78* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.117-5
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
80
81* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.117-4
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
83
84* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.117-3
85- Perl 5.28 rebuild
86
87* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.117-2
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
89
90* Wed Jan 31 2018 Paul Howarth <paul@city-fan.org> - 0.117-1
91- Update to 0.117
92  - Allow the custom OPs to be deparsed with B::Deparse
93  - Optimize the shared object size by moving common call checker logic into a
94    function
95
96* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.116-5
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
98
99* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.116-4
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
101
102* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.116-3
103- Perl 5.26 rebuild
104
105* Tue May 30 2017 Paul Howarth <paul@city-fan.org> - 0.116-2
106- Incorporate package review feedback (#1450440)
107  - Drop EL6-isms as we need Test::More 0.94, which EL-6 will never have
108
109* Mon May 15 2017 Paul Howarth <paul@city-fan.org> - 0.116-1
110- Update to 0.116
111  - Changes rephrasing
112  - Restore 5.6 compatibility
113  - Replace docs with a link to Ref::Util
114
115* Fri May 12 2017 Paul Howarth <paul@city-fan.org> - 0.115-1
116- Package renamed Ref-Util-XS to make room for Ref-Util's new pure-Perl
117  implementation
118
119* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.113-2
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
121
122* Tue Jan 17 2017 Paul Howarth <paul@city-fan.org> - 0.113-1
123- Update to 0.113
124  - Fix bugtracker link
125
126* Sun Jan 15 2017 Paul Howarth <paul@city-fan.org> - 0.112-1
127- Update to 0.112
128  - Fix compilation on Sun (Oracle) and some MSVC compilers (GH#35)
129
130* Fri Dec 30 2016 Paul Howarth <paul@city-fan.org> - 0.111-1
131- Update to 0.111
132  - Fix test failure on 5.8.5 and under
133  - Moved to Dist::Zilla
134
135* Thu Dec 29 2016 Paul Howarth <paul@city-fan.org> - 0.110-1
136- Update to 0.110
137  - Fix support of 5.8 (GH#29, GH#34)
138  - Additional optimizations
139  - More extensive test suite
140
141* Mon Aug 29 2016 Paul Howarth <paul@city-fan.org> - 0.101-1
142- Update to 0.101
143  - A test accidentally added a dependency on Readonly.pm - fixed! (GH#30)
144  - Update README
145
146* Sat Aug 27 2016 Paul Howarth <paul@city-fan.org> - 0.100-1
147- Update to 0.100
148  - Support situations in op-code implementation where the parameters do not
149    come as a list
150  - Fix memory leak in dangling op
151  - Support magic (tied variables)
152  - Rework op implementation
153  - Speed up by changing the top of the stack instead of POPing and PUSHing
154  - Update ppport.h file from Devel::PPPort and remove the copy of SVRXOK since
155    it's now available
156  - Add license in Pod
157  - Specify minimum version of perl (5.6.2)
158
159* Thu Jul 28 2016 Paul Howarth <paul@city-fan.org> - 0.020-2
160- Sanitize for Fedora submission
161
162* Thu Jul 28 2016 Paul Howarth <paul@city-fan.org> - 0.020-1
163- Initial RPM version
Note: See TracBrowser for help on using the repository browser.