source: projects/specs/trunk/p/perl-Readonly/perl-Readonly-vl.spec @ 5794

Revision 5794, 4.4 KB checked in by shaolin, 12 years ago (diff)
  • rebuild
Line 
1Name:           perl-Readonly
2Version:        1.03
3Release:        2%{?_dist_release}
4Summary:        Facility for creating read-only scalars, arrays, hashes
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Readonly/
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RO/ROODE/Readonly-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
11BuildArch:      noarch
12
13BuildRequires:  perl(ExtUtils::MakeMaker)
14BuildRequires:  perl(Test::More)
15
16# perl-Readonly-XS builds for all current fedora architectures, so let's
17# require it.
18Requires:       perl(Readonly::XS)
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       shaolin
23
24%{?perl_default_filter}
25%{?perl_default_subpackage_tests}
26
27%description
28Readonly provides a facility for creating non-modifiable scalars,
29arrays, and hashes.  Any attempt to modify a Readonly variable throws
30an exception.
31
32Readonly:
33* Creates scalars, arrays (not lists), and hashes.
34* Creates variables that look and work like native perl variables.
35* Creates global or lexical variables.
36* Works at runtime or compile time.
37* Works with deep or shallow data structures.
38* Prevents reassignment of Readonly variables.
39
40%prep
41%setup -q -n Readonly-%{version}
42
43
44%build
45%{__perl} Makefile.PL INSTALLDIRS=vendor
46make %{?_smp_mflags}
47
48
49%install
50rm -rf %{buildroot}
51
52make pure_install DESTDIR=%{buildroot}
53find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
54find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
55
56%{_fixperms} %{buildroot}/*
57
58# make sure this goes where it should to be...
59mv %{buildroot}%{perl_vendorlib}/benchmark.pl .
60
61
62%check
63make test
64
65
66%clean
67rm -rf %{buildroot}
68
69
70%files
71%defattr(-,root,root,-)
72%doc Changes README benchmark.pl
73%{perl_vendorlib}/Readonly.pm
74%{_mandir}/man3/*
75
76
77%changelog
78* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.03-2
79- rebuild
80
81* Tue Feb 21 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.03-1
82- initial package for Vine Linux
83
84* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.03-17
85- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
86
87* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.03-16
88- Perl mass rebuild
89
90* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.03-15
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
92
93* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.03-14
94- 661697 rebuild for fixing problems with vendorach/lib
95
96* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.03-13
97- Mass rebuild with perl-5.12.0
98
99* Sun Feb 21 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.03-12
100- add perl_default_filter, etc
101- minor spec updates
102
103* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.03-11
104- rebuild against perl 5.10.1
105
106* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.03-10
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
108
109* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.03-9
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
111
112* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.03-8
113- Rebuild for perl 5.10 (again)
114
115* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.03-7
116- rebuild for new perl
117
118* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.03-6.2
119- add BR: perl(Test::More)
120
121* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.03-6.1
122- correct license tag
123- add BR: perl(ExtUtils::MakeMaker)
124
125* Wed Oct 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.03-6
126- add explict requires on perl(Readonly::XS).  perl(Readonly::XS) is available
127  for all architectures fedora supports, so there's no good reason to not
128  require it.
129- spec file rework
130
131* Tue Sep 19 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.03-5
132- bump for mass rebuild
133
134* Thu Dec 08 2005 Michael A. Peters <mpeters@mac.com> - 1.03-3
135- Remove requires on perl-Readonly-XS
136
137* Thu Dec 08 2005 Michael A. Peters <mpeters@mac.com> - 1.03-3
138- Fix license and BuildRequires, use %%{?_smp_mflags} with make,
139
140* Sat Nov 12 2005 Michael A. Peters <mpeters@mac.com> - 1.03-2
141- separate out perl-Readonly-XS into its own package
142- package benchmark.pl as a doc
143
144* Mon Nov 7 2005 Michael A. Peters <mpeters@mac.com> - 1.03-1
145- Initial spec file
Note: See TracBrowser for help on using the repository browser.