source: projects/specs/trunk/p/perl-Readonly/perl-Readonly-vl.spec @ 12120

Revision 12120, 4.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Readonly
2Version:        2.05
3Release:        1%{?_dist_release}
4Summary:        Facility for creating read-only scalars, arrays, hashes
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Readonly/
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RO/ROODE/Readonly-%{version}.tar.gz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11BuildArch:      noarch
12BuildRequires:  perl(ExtUtils::MakeMaker)
13BuildRequires:  perl(Module::Build::Tiny)
14BuildRequires:  perl(Test::More)
15Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
16# perl-Readonly-XS builds for all current fedora architectures, so let's
17# require it.
18Requires:       perl(Readonly::XS)
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       shaolin
23
24%{?perl_default_filter}
25%{?perl_default_subpackage_tests}
26
27%description
28Readonly provides a facility for creating non-modifiable scalars,
29arrays, and hashes.  Any attempt to modify a Readonly variable throws
30an exception.
31
32Readonly:
33* Creates scalars, arrays (not lists), and hashes.
34* Creates variables that look and work like native perl variables.
35* Creates global or lexical variables.
36* Works at runtime or compile time.
37* Works with deep or shallow data structures.
38* Prevents reassignment of Readonly variables.
39
40%prep
41%setup -q -n Readonly-%{version}
42
43%build
44%{__perl} Build.PL --installdirs=vendor
45./Build
46
47%install
48rm -rf %{buildroot}
49
50./Build install --destdir=%{buildroot} --create_packlist=0
51find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
52find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
53
54%{_fixperms} %{buildroot}/*
55
56
57%check
58./Build test
59
60%clean
61rm -rf %{buildroot}
62
63
64%files
65%defattr(-,root,root,-)
66%license LICENSE
67%doc Changes README.md
68%{perl_vendorlib}/Readonly.pm
69%{_mandir}/man3/*
70
71
72%changelog
73* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.05-1
74- new upstream release.
75- rebuilt with perl-5.26.
76
77* Sat Nov  8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.00-1
78- updated to 2.00
79- make -> ./Build
80- built with perl 5.16.3
81
82* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.03-2
83- rebuild
84
85* Tue Feb 21 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.03-1
86- initial package for Vine Linux
87
88* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.03-17
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
90
91* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.03-16
92- Perl mass rebuild
93
94* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.03-15
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
96
97* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.03-14
98- 661697 rebuild for fixing problems with vendorach/lib
99
100* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.03-13
101- Mass rebuild with perl-5.12.0
102
103* Sun Feb 21 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.03-12
104- add perl_default_filter, etc
105- minor spec updates
106
107* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.03-11
108- rebuild against perl 5.10.1
109
110* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.03-10
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
112
113* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.03-9
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
115
116* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.03-8
117- Rebuild for perl 5.10 (again)
118
119* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.03-7
120- rebuild for new perl
121
122* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.03-6.2
123- add BR: perl(Test::More)
124
125* Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> 1.03-6.1
126- correct license tag
127- add BR: perl(ExtUtils::MakeMaker)
128
129* Wed Oct 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.03-6
130- add explict requires on perl(Readonly::XS).  perl(Readonly::XS) is available
131  for all architectures fedora supports, so there's no good reason to not
132  require it.
133- spec file rework
134
135* Tue Sep 19 2006 Chris Weyl <cweyl@alumni.drew.edu> 1.03-5
136- bump for mass rebuild
137
138* Thu Dec 08 2005 Michael A. Peters <mpeters@mac.com> - 1.03-3
139- Remove requires on perl-Readonly-XS
140
141* Thu Dec 08 2005 Michael A. Peters <mpeters@mac.com> - 1.03-3
142- Fix license and BuildRequires, use %%{?_smp_mflags} with make,
143
144* Sat Nov 12 2005 Michael A. Peters <mpeters@mac.com> - 1.03-2
145- separate out perl-Readonly-XS into its own package
146- package benchmark.pl as a doc
147
148* Mon Nov 7 2005 Michael A. Peters <mpeters@mac.com> - 1.03-1
149- Initial spec file
Note: See TracBrowser for help on using the repository browser.