source: projects/specs/trunk/p/perl-Pod-PerldocJp/perl-Pod-PerldocJp-vl.spec @ 6516

Revision 6516, 2.3 KB checked in by yasumichi, 12 years ago (diff)
Line 
1%define pkgname Pod-PerldocJp
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.14
6Release:        2%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Tools
9Source0:        http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        perldoc that also checks perldoc.jp
18Summary(ja):    日本語対応の perldoc
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25BuildRequires:  perl-Path-Extended
26BuildRequires:  perl-Term-Encoding
27BuildRequires:  perl-Test-Pod
28BuildRequires:  perl-Test-Pod-Coverage
29BuildRequires:  perl-Test-UseAllModules
30
31%description
32This is a drop-in-replacement for perldoc for Japanese people. Usage is the
33same, except it can look for a translation at http://perldoc.jp with -J
34option.
35
36%description -l ja
37perldocjp は、日本人のために perldoc を置き換えます。使い方は、-J オプション
38を利用して http://perldoc.jp にある翻訳を探すことができる以外は、perldoc と
39同様です。
40
41%prep
42%setup -q -n Pod-PerldocJp-0.14
43
44%build
45%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
46%{__make} %{?_smp_mflags}
47
48%install
49%{__rm} -rf ${RPM_BUILD_ROOT}
50%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
51
52# remove unnecessary files.
53find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
54find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
55find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
56find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
57
58# generate file list
59find $RPM_BUILD_ROOT%{_prefix} -type f -print |
60        sed "s@^$RPM_BUILD_ROOT@@g"  > %{name}.files
61
62if [ "$(cat %{name}.files)X" = "X" ] ; then
63        echo "ERROR: EMPTY FILE LIST"
64        exit -1
65fi
66
67%clean
68%{__rm} -rf ${RPM_BUILD_ROOT}
69
70%check
71make test
72
73%files -f %{name}.files
74%defattr(-,root,root)
75%doc Changes README
76%dir %{perl_vendorlib}/Pod/PerldocJp
77
78%changelog
79* Wed Jul 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.14-2
80- apply wiki:Development/PerlModulePackaging
81- exclude man pages
82
83* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.14-1
84- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.