source: projects/specs/trunk/p/perl-Pod-Eventual/perl-Pod-Eventual-vl.spec @ 5844

Revision 5844, 3.2 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Pod-Eventual
2Version:        0.093330
3Release:        1%{?_dist_release}
4Summary:        Read a POD document as a series of trivial events
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Pod-Eventual/
8Source0:        http://www.cpan.org/authors/id/R/RJ/RJBS/Pod-Eventual-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
10BuildArch:      noarch
11BuildRequires:  perl(ExtUtils::MakeMaker)
12BuildRequires:  perl(Mixin::Linewise::Readers) >= 0.001
13BuildRequires:  perl(Test::Deep)
14BuildRequires:  perl(Test::More)
15BuildRequires:  perl(Test::Pod)
16#BuildRequires:  perl(Test::Pod::Coverage)
17# causes circular builddeps
18#BuildRequires:  perl(Pod::Coverage::TrustPod)
19
20Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
21
22%{?perl_default_filter}
23
24%description
25POD is a pretty simple format to write, but it can be a big pain to deal
26with reading it and doing anything useful with it. Most existing POD
27parsers care about semantics, like whether a =item occurred after an
28=over but before a back, figuring out how to link a L<>, and other things
29like that.
30
31Pod::Eventual is much less ambitious and much more stupid. Fortunately, stupid
32is often better. (That's what I keep telling myself, anyway.)
33
34Pod::Eventual reads line-based input and produces events describing each POD
35paragraph or directive it finds. Once complete events are immediately passed to
36the handle_event method. This method should be implemented by Pod::Eventual
37subclasses. If it isn't, Pod::Eventual's own handle_event will be called, and
38will raise an exception.
39
40%prep
41%setup -q -n Pod-Eventual-%{version}
42
43%build
44%{__perl} Makefile.PL INSTALLDIRS=vendor
45make %{?_smp_mflags}
46
47%install
48rm -rf %{buildroot}
49
50make pure_install PERL_INSTALL_ROOT=%{buildroot}
51
52find %{buildroot} -type f -name .packlist -exec rm -f {} \;
53find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
54
55%{_fixperms} %{buildroot}/*
56
57%check
58make test
59
60%clean
61rm -rf %{buildroot}
62
63%files
64%defattr(-,root,root,-)
65%doc Changes LICENSE META.json README
66%{perl_vendorlib}/*
67%{_mandir}/man3/*
68
69%changelog
70* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.093330-1
71- initial build for Vine Linux
72
73* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.093330-8
74- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
75
76* Mon Jul 18 2011 Petr Sabata <contyk@redhat.com> - 0.093330-7
77- Perl mass rebuild
78
79* Wed Jul 13 2011 Iain Arnell <iarnell@gmail.com> 0.093330-6
80- drop circular Pod::Coverage::TrustPod buildreq
81- don't run "release" tests
82
83* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.093330-5
84- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
85
86* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.093330-4
87- 661697 rebuild for fixing problems with vendorach/lib
88
89* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.093330-3
90- Mass rebuild with perl-5.12.0
91
92* Sat Feb 27 2010 Iain Arnell <iarnell@gmail.com> 0.093330-2
93- BR perl(Pod::Coverage::TrustPod)
94
95* Thu Jan 14 2010 Iain Arnell 0.093330-1
96- Specfile autogenerated by cpanspec 1.78.
Note: See TracBrowser for help on using the repository browser.