source: projects/specs/trunk/p/perl-Pod-Eventual/perl-Pod-Eventual-vl.spec @ 12120

Revision 12120, 3.5 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Pod-Eventual
2Version:        0.094001
3Release:        2%{?_dist_release}
4Summary:        Read a POD document as a series of trivial events
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Pod-Eventual/
8Source0:        http://www.cpan.org/authors/id/R/RJ/RJBS/Pod-Eventual-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
10BuildArch:      noarch
11BuildRequires:  perl(ExtUtils::MakeMaker)
12BuildRequires:  perl(Mixin::Linewise::Readers)
13BuildRequires:  perl(Test::Deep)
14BuildRequires:  perl(Test::More)
15BuildRequires:  perl(Test::Pod)
16#BuildRequires:  perl(Test::Pod::Coverage)
17# causes circular builddeps
18#BuildRequires:  perl(Pod::Coverage::TrustPod)
19
20Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24
25%{?perl_default_filter}
26
27%description
28POD is a pretty simple format to write, but it can be a big pain to deal
29with reading it and doing anything useful with it. Most existing POD
30parsers care about semantics, like whether a =item occurred after an
31=over but before a back, figuring out how to link a L<>, and other things
32like that.
33
34Pod::Eventual is much less ambitious and much more stupid. Fortunately, stupid
35is often better. (That's what I keep telling myself, anyway.)
36
37Pod::Eventual reads line-based input and produces events describing each POD
38paragraph or directive it finds. Once complete events are immediately passed to
39the handle_event method. This method should be implemented by Pod::Eventual
40subclasses. If it isn't, Pod::Eventual's own handle_event will be called, and
41will raise an exception.
42
43%prep
44%setup -q -n Pod-Eventual-%{version}
45
46%build
47%{__perl} Makefile.PL INSTALLDIRS=vendor
48make %{?_smp_mflags}
49
50%install
51rm -rf %{buildroot}
52
53make pure_install PERL_INSTALL_ROOT=%{buildroot}
54
55find %{buildroot} -type f -name .packlist -exec rm -f {} \;
56find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
57
58%{_fixperms} %{buildroot}/*
59
60%check
61make test
62
63%clean
64rm -rf %{buildroot}
65
66%files
67%defattr(-,root,root,-)
68%license LICENSE
69%doc Changes META.json README
70%{perl_vendorlib}/*
71%{_mandir}/man3/*
72
73%changelog
74* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.094001-2
75- new upstream release.
76- rebuilt with perl-5.26.
77
78* Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.094001-1
79- updated to 0.094001
80- built with perl 5.16.3
81
82* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.093330-1
83- initial build for Vine Linux
84
85* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.093330-8
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
87
88* Mon Jul 18 2011 Petr Sabata <contyk@redhat.com> - 0.093330-7
89- Perl mass rebuild
90
91* Wed Jul 13 2011 Iain Arnell <iarnell@gmail.com> 0.093330-6
92- drop circular Pod::Coverage::TrustPod buildreq
93- don't run "release" tests
94
95* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.093330-5
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
97
98* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.093330-4
99- 661697 rebuild for fixing problems with vendorach/lib
100
101* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.093330-3
102- Mass rebuild with perl-5.12.0
103
104* Sat Feb 27 2010 Iain Arnell <iarnell@gmail.com> 0.093330-2
105- BR perl(Pod::Coverage::TrustPod)
106
107* Thu Jan 14 2010 Iain Arnell 0.093330-1
108- Specfile autogenerated by cpanspec 1.78.
Note: See TracBrowser for help on using the repository browser.