source: projects/specs/trunk/p/perl-Perl-Critic/perl-Perl-Critic-vl.spec @ 12120

Revision 12120, 16.4 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# define bootstrap for initial build
2%define perl_bootstrap 1
3
4Name:           perl-Perl-Critic
5Version:        1.132
6Release:        1%{?_dist_release}
7Summary:        Critique Perl source code for best-practices
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/Perl-Critic/
11Source0:        http://search.cpan.org/CPAN/authors/id/T/TH/THALJEF/Perl-Critic-%{version}.tar.gz
12Patch0:         PPI-1.248.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
16
17# Build process
18BuildRequires:  perl(Module::Build)
19BuildRequires:  perl(Task::Weaken)
20
21# Module requirements
22BuildRequires:  aspell-en
23Requires:       aspell
24BuildRequires:  perl(B::Keywords)
25BuildRequires:  perl(Carp)
26BuildRequires:  perl(charnames)
27BuildRequires:  perl(Config::Tiny)
28BuildRequires:  perl(Email::Address)
29BuildRequires:  perl(English)
30BuildRequires:  perl(Exception::Class)
31BuildRequires:  perl(Exporter)
32BuildRequires:  perl(File::Basename)
33BuildRequires:  perl(File::Find)
34BuildRequires:  perl(File::Path)
35BuildRequires:  perl(File::ShareDir)
36BuildRequires:  perl(File::Spec)
37BuildRequires:  perl(File::Spec::Unix)
38BuildRequires:  perl(File::Temp)
39BuildRequires:  perl(Getopt::Long)
40BuildRequires:  perl(IO::String)
41BuildRequires:  perl(List::MoreUtils)
42BuildRequires:  perl(List::Util)
43BuildRequires:  perl-Module-Pluggable
44Requires:       perl-Module-Pluggable
45BuildRequires:  perl(overload)
46BuildRequires:  perl(Perl::Tidy)
47BuildRequires:  perl(Pod::Parser)
48Requires:       perl(Pod::Parser)
49BuildRequires:  perl(Pod::PlainText)
50BuildRequires:  perl(Pod::Select)
51BuildRequires:  perl(Pod::Spell)
52BuildRequires:  perl(Pod::Usage)
53BuildRequires:  perl(PPI)
54Requires:       perl(PPI)
55BuildRequires:  perl(PPIx::Regexp)
56BuildRequires:  perl(PPIx::Utilities::Statement)
57BuildRequires:  perl(Readonly)
58BuildRequires:  perl(Scalar::Util)
59BuildRequires:  perl(strict)
60BuildRequires:  perl(String::Format)
61BuildRequires:  perl(Text::ParseWords)
62BuildRequires:  perl(version)
63BuildRequires:  perl(warnings)
64
65# Optional module requirements
66BuildRequires:  perl(File::HomeDir)
67Requires:       perl(File::HomeDir)
68BuildRequires:  perl(File::Which)
69Requires:       perl(File::Which)
70BuildRequires:  perl(Readonly::XS)
71Requires:       perl(Readonly::XS)
72BuildRequires:  perl(Term::ANSIColor)
73Requires:       perl(Term::ANSIColor)
74
75# Main test suite
76BuildRequires:  perl(Test::Deep)
77BuildRequires:  perl(Test::Memory::Cycle)
78BuildRequires:  perl(Test::More)
79
80# Author tests: not run if we're bootstrapping
81%if 0%{!?perl_bootstrap:1}
82BuildRequires:  perl(Devel::EnforceEncapsulation)
83BuildRequires:  perl(Perl::Critic::Policy::Editor::RequireEmacsFileVariables)
84BuildRequires:  perl(Perl::Critic::Policy::ErrorHandling::RequireUseOfExceptions)
85BuildRequires:  perl(Test::Kwalitee)
86BuildRequires:  perl(Test::Perl::Critic)
87BuildRequires:  perl(Test::Pod)
88BuildRequires:  perl(Test::Pod::Coverage)
89BuildRequires:  perl(Test::Without::Module)
90%endif
91
92# don't "provide" private Perl libs
93%{?perl_default_filter}
94
95Vendor:         Project Vine
96Distribution:   Vine Linux
97Packager:       shaolin
98
99%description
100Perl::Critic is an extensible framework for creating and applying coding
101standards to Perl source code. Essentially, it is a static source code
102analysis engine. Perl::Critic is distributed with a number of
103Perl::Critic::Policy modules that attempt to enforce various coding
104guidelines. Most Policy modules are based on Damian Conway's book Perl
105Best Practices. However, Perl::Critic is not limited to PBP and will
106even support Policies that contradict Conway. You can enable, disable,
107and customize those Polices through the Perl::Critic interface. You can
108also create new Policy modules that suit your own tastes.
109
110%package -n perl-Test-Perl-Critic-Policy
111Summary:        A framework for testing your custom Policies
112Group:          Development/Libraries
113License:        GPL+ or Artistic
114
115%description -n perl-Test-Perl-Critic-Policy
116This module provides a framework for function-testing your custom
117Perl::Critic::Policy modules. Policy testing usually involves feeding it a
118string of Perl code and checking its behavior. In the old days, those strings
119of Perl code were mixed directly in the test script. That sucked.
120
121%prep
122%setup -q -n Perl-Critic-%{version}
123find . -type f -exec chmod -c -x {} ';'
124
125%patch0 -p1
126
127%build
128perl Build.PL installdirs=vendor
129./Build
130
131%install
132./Build install destdir=%{buildroot} create_packlist=0
133%{_fixperms} %{buildroot}
134
135%check
136LC_ALL=en_US ./Build %{!?perl_bootstrap:author}test
137
138%files
139%license LICENSE
140%doc Changes README TODO.pod examples/ extras/ tools/
141%{_bindir}/perlcritic
142%{perl_vendorlib}/Perl/
143%{_mandir}/man1/perlcritic.1*
144%{_mandir}/man3/Perl::Critic*.3pm*
145
146%files -n perl-Test-Perl-Critic-Policy
147%{perl_vendorlib}/Test/
148%{_mandir}/man3/Test::Perl::Critic::Policy.3pm*
149
150%changelog
151* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.132-1
152- new upstream release.
153- rebuilt with perl-5.26.
154
155* Fri Nov 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.120-1
156- updated to 1.120
157- built with perl 5.16.3
158
159* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-2
160- rebuild
161
162* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-1
163- initial build for Vine Linux
164
165* Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 1.117-2
166- drop %%defattr, no longer needed
167
168* Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 1.117-1
169- update to 1.117
170  New Policies:
171  - Variables::ProhibitAugmentedAssignmentInDeclaration reports constructs like
172    'my $x += 1'
173  Policy Changes:
174  - BuiltinFunctions::ProhibitLvalueSubstr: add explicit 'use version'
175    (CPAN RT#68498)
176  - CodeLayout::ProhibitHardTabs: add 'pbp' to the default_themes list
177    (CPAN RT#71093)
178  - ControlStructures::ProhibitMutatingListFunctions now understands that
179    tr///r (introduced in 5.13.7) does not change its operand
180  - ControlStructures::ProhibitMutatingListFunctions now understands that
181    '//=', '<<=', and '>>=' are assignment operators (CPAN RT#70901)
182  - ErrorHandling::RequireCheckingReturnValueOfEval now allows things
183    like grep { eval $_ } (CPAN RT#69489)
184  - Modules::RequireExplicitPackage now has configuraion option
185    allow_import_of, to allow the import of specified modules before the
186    package statement (CPAN RT#72660)
187  - RegularExpressions::ProhibitEnumeratedClasses no longer thinks
188    that [A-Za-z_] matches \w. RT #69322.
189  - RegularExpressions::ProhibitUnusedCaptures now skips the first block of
190    an 'if' or 'elsif' if the regular expression is bound to its operand with
191    the '!~' operator (CPAN RT#69867)
192  - RegularExpressions::ProhibitUnusedCaptures now looks into lists and blocks
193    in the replacement portion of the regular expression if /e is asserted
194    (CPAN RT#72086)
195  - RegularExpressions::RequireDotMatchAnything,
196    RegularExpressions::RequireExtendedFormatting and
197    RegularExpressions::RequireLineBoundaryMatching now honor defaults set with
198    'use re "/modifiers"' (CPAN RT#72151)
199  - Subroutines::ProhibitManyArgs now recognizes '+' as a prototype character
200  - Variables::ProhibitPunctuationVars now recognizes bracketed variables
201    embedded in interpolated strings (e.g. "${$}"); for the purpose of the
202    'allow' configuration, these are considered equivalent to the unbracketed
203    form (CPAN RT#72910)
204  Other Changes:
205  - corrected POD in Perl::Critic::PPI::Utils (CPAN RT#68898)
206  - Perl::Critic::Violation source() method now returns the line containing
207    the violation (not the first line) when the statement containing the
208    violation spans multiple lines
209- this release by THALJEF -> update source URL
210- drop stopwords patch, now included upstream
211
212* Fri Jul 22 2011 Paul Howarth <paul@city-fan.org> - 1.116-6
213- reinstate author tests: META.yml creation issue fixed in perl-5.14.1-182
214
215* Fri Jul 22 2011 Petr Sabata <contyk@redhat.com> - 1.116-5
216- completely disable author tests to avoid Kwalitee META complaints
217
218* Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 1.116-4
219- Perl mass rebuild
220
221* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.116-3
222- Perl mass rebuild
223
224* Wed Jun 29 2011 Paul Howarth <paul@city-fan.org> - 1.116-2
225- move BR: perl(Test::Perl::Critic) to author test section where it belongs
226- run the author tests if we're not bootstrapping
227
228* Mon May 16 2011 Paul Howarth <paul@city-fan.org> - 1.116-1
229- update to 1.116
230  - BuiltInFunctions::ProhibitLvalueSubstr does not report violations if the
231    document contains an explicit 'use n.nnn;' where the version is before
232    5.005 (CPAN RT#59112)
233  - Documentation::RequirePodSections no longer blows up on code having POD but
234    no =head1 (CPAN RT#67231)
235  - RegularExpressions::ProhibitUnusedCapture should more reliably find things
236    like s/(a)/${1}2/ (CPAN RT#67273)
237  - ValuesAndExpressions::ProhibitMagicNumbers and Module::RequireVersionVar
238    now treat versions passed as the second argument of a 'package' statement
239    the same as versions declared as 'our $VERSION ...' (CPAN RT#67159)
240  - Variables::RequireLexicalLoopIterators does not report violations if the
241    document contains an explicit 'use n.nnn;' where the version is before
242    5.004 (CPAN RT#67760)
243
244* Fri Apr  1 2011 Paul Howarth <paul@city-fan.org> - 1.115-1
245- update to 1.115
246  - fatal error in RegularExpressions::ProhibitUnusedCapture here document
247    check (CPAN RT#67116)
248  - internal POD error in Documentation::RequirePodLinksIncludeText
249    (CPAN RT#67012)
250
251* Tue Mar 29 2011 Paul Howarth <paul@city-fan.org> 1.114-1
252- update to 1.114
253  - Documentation::RequirePodLinksIncludeText now handles nested POD formatting
254    (CPAN RT#65569)
255  - clarified relation of severity numbers to names in Perl::Critic POD
256    (CPAN RT#66017)
257  - removed caveats from Variables::RequireLocalizedPunctuationVars, no longer
258    necessary with PPI 1.208 (CPAN RT#65514)
259  - have InputOutput::RequireBriefOpen attempt to expand scope as necessary to
260    deal with the case where the open() and the corresponding close() are not
261    in the same scope (CPAN RT#64437)
262  - RegularExpressions::ProhibitUnusedCapture now looks inside double-quotish
263    things (CPAN RT#38942)
264  - RegularExpressions::ProhibitUnusedCapture now takes logical alternation
265    into account, so that (e.g.)
266        if ( /(a)/ || /(b)/ ) {
267                say $1;
268        }
269    is not a violation (CPAN RT#38942)
270  - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
271    'return { foo => 1, bar => 2 }' as containing a hash constructor, not a
272    block; this was fixed by PPI 1.215 (CPAN RT#61301)
273  - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
274    'bless { foo => 1, bar => 2 }' as containing a hash constructor, not a
275    block; this was fixed by PPI 1.215 (CPAN RT#64132)
276- bump PPI version requirement to 1.215
277- BR/R: perl(Pod::Parser)
278- BR/R: optional modules perl(Readonly::XS), perl(Term::ANSIColor) >= 2.02
279- BR: perl(Pod::Spell) >= 1
280- BR: perl(Text::ParseWords) >= 3
281- add runtime deps for optional modules perl(File::HomeDir), perl(File::Which)
282- drop redundant (for modern rpm) BuildRoot tag and buildroot cleaning
283- split Test::Perl::Critic::Policy off into its own package
284- add dependency on aspell for Perl::Critic::Policy::Documentation::PodSpelling
285- add version 1.889 requirement for perl(Email::Address)
286- add version 0.19 requirement for perl(List::MoreUtils)
287- add version 0.010 requirement for perl(PPIx::Regexp)
288- add version 1.001 requirement for perl(PPIx::Utilities::Statement)
289- add version 0.77 requirement for perl(version)
290- drop unused buildreq perl(Test::Spelling)
291- drop bogus buildreqs perl(lib) and perl(base)
292- add option for building with author tests enabled (--with authortests)
293- add patch with words not in Fedora dictionaries for spell check tests
294- split buildreqs into separate sections for build process, the module, the
295  main test suite and the author tests
296
297* Mon Mar  7 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.113-1
298- update to 1.113
299
300* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.111-2
301- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
302
303* Mon Jan  3 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.111-1
304- update
305
306* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-2
307- rebuild to fix problems with vendorarch/lib (#661697)
308
309* Fri Aug  6 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-1
310- update
311
312* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.105-4
313- mass rebuild with perl-5.12.0
314
315* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-3
316- rebuild against perl 5.10.1
317
318* Wed Nov 25 2009 Stepan Kasal <skasal@redhat.com> - 1.105-2
319- use the new filtering macros (verified that the resulting provides
320  and requires are the same)
321- add version to perl(PPI) require (#541020)
322
323* Wed Oct  7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-1
324- new upstream version
325- update build requires
326
327* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.098-3
328- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
329
330* Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.098-1
331- "neaten" filtering
332- auto-update to 1.098 (by cpan-spec-update 0.01)
333- added a new br on perl(strict) (version 0)
334- added a new br on perl(Scalar::Util) (version 0)
335- added a new br on perl(File::Temp) (version 0)
336- added a new br on perl(Pod::Usage) (version 0)
337- added a new br on perl(File::Find) (version 0)
338- added a new br on perl(PPI::Token::Whitespace) (version 1.203)
339- added a new br on perl(charnames) (version 0)
340- added a new br on perl(PPI::Document::File) (version 1.203)
341- added a new br on perl(File::Spec::Unix) (version 0)
342- added a new br on perl(List::Util) (version 0)
343- added a new br on perl(lib) (version 0)
344- added a new br on perl(Getopt::Long) (version 0)
345- added a new br on perl(Exporter) (version 0)
346- added a new br on perl(Test::More) (version 0)
347- added a new br on perl(overload) (version 0)
348- added a new br on perl(base) (version 0)
349- added a new br on perl(version) (version 0)
350- added a new br on perl(Carp) (version 0)
351- added a new br on perl(warnings) (version 0)
352- added a new br on perl(PPI::Document) (version 1.203)
353- added a new br on perl(File::Basename) (version 0)
354- added a new br on perl(PPI::Token::Quote::Single) (version 1.203)
355- added a new br on perl(File::Spec) (version 0)
356- added a new br on perl(File::Path) (version 0)
357- added a new br on perl(Pod::PlainText) (version 0)
358- added a new br on perl(Pod::Select) (version 0)
359- added a new br on perl(PPI::Node) (version 1.203)
360- added a new br on perl(English) (version 0)
361
362* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.092-2
363- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
364
365* Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.092-1
366- update to 1.092
367
368* Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.082-1
369- update to 1.082
370- resolve BZ#431577
371- add t/ examples/ extras/ tools/, and filter
372
373* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-3
374- Rebuild for perl 5.10 (again)
375
376* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-2
377- add missing BR: perl-Exception-Class
378
379* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-1
380- bump to 1.080
381
382* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.053-2
383- rebuild for new perl
384
385* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.053-1
386- Update to 1.053.
387
388* Tue Mar 20 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
389- Update to 1.05.
390
391* Thu Feb 15 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
392- Update to 1.03.
393
394* Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-2
395- Bumping release (forgot to commit sources and .cvsignore changes).
396
397* Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-1
398- Update to 1.01.
399- New build requirement: perl(Test::Memory::Cycle).
400
401* Thu Jan 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-2
402- perl(Set::Scalar) is no longer required.
403
404* Wed Jan 24 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-1
405- Update to 0.23.
406- New requirement: perl(B::Keywords).
407- Author tests coverage improved.
408
409* Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-2
410- Enabled author tests.
411- BR perl(HomeDir).
412
413* Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-1
414- Update to 0.22.
415
416* Sat Nov 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.21-1
417- Update to 0.21.
418- New BR: perl(Set::Scalar).
419
420* Sat Sep 16 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.2-1
421- First build.
Note: See TracBrowser for help on using the repository browser.