source: projects/specs/trunk/p/perl-Path-Extended/perl-Path-Extended-vl.spec @ 4921

Revision 4921, 2.0 KB checked in by yasumichi, 12 years ago (diff)

Import spec file.

Line 
1%define pkgname Path-Extended
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.19
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        yet another Path class
17#Summary(ja):   ここに日本語で概要を記述してください
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26This is yet another file/directory handler that does a bit more than
27Path::Class for some parts, and a bit less for other parts. One of the main
28difference is Path::Extended always tries to use forward slashes when
29possible, ie. even when you're on the MS Windows, so that you don't need to
30care about escaping paths that annoys you from time to time when you want to
31apply regexen to a path, especially in file tests that use 'like' or
32'compare'.
33
34#%%description -l ja
35#ここに日本語で詳細を記述してください。
36
37%prep
38%setup -q -n Path-Extended-0.19
39
40%build
41perl Makefile.PL
42%{__make}
43
44%install
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%{__make} install DESTDIR=${RPM_BUILD_ROOT}
47
48find $RPM_BUILD_ROOT%{_prefix} -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v ^%{_mandir} |
51        grep -v perllocal.pod |
52        grep -v "\.packlist" > %{name}.files
53if [ "$(cat %{name}.files)X" = "X" ] ; then
54        echo "ERROR: EMPTY FILE LIST"
55        exit -1
56fi
57
58# remove unnecessary files.
59%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
60%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Path/Extended/.packlist
61
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66
67%files -f %{name}.files
68%defattr(-,root,root)
69%doc Changes README
70%dir %{perl_sitelib}/Path/Extended
71%dir %{perl_sitelib}/Path/Extended/Class
72%{_mandir}/*/*
73
74
75%changelog
76* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.19-1
77- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.