source: projects/specs/trunk/p/perl-Path-Class/perl-Path-Class-vl.spec @ 5859

Revision 5859, 4.6 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Path-Class
2Version:        0.25
3Release:        1%{?_dist_release}
4Summary:        Cross-platform path specification manipulation
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Path-Class/
8Source0:        http://search.cpan.org/CPAN/authors/id/K/KW/KWILLIAMS/Path-Class-%{version}.tar.gz
9Patch0:         Path-Class-0.25-old-M::B.patch
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
11BuildArch:      noarch
12BuildRequires:  perl(base)
13BuildRequires:  perl(Carp)
14BuildRequires:  perl(Cwd)
15BuildRequires:  perl(Exporter)
16BuildRequires:  perl(File::Path)
17BuildRequires:  perl(File::Spec) >= 0.87
18BuildRequires:  perl(File::stat)
19BuildRequires:  perl(File::Temp)
20BuildRequires:  perl(IO::Dir)
21BuildRequires:  perl(IO::File)
22BuildRequires:  perl(Module::Build)
23BuildRequires:  perl(strict)
24BuildRequires:  perl(Test::More)
25# We need Perl::Perl::Critic ≥ 1.080 for a fix to
26# Variables::ProhibitConditionalDeclarations, and the EPEL-5 version is too old
27%if "%{?rhel}" != "4" && "%{?rhel}" != "5"
28BuildRequires:  perl(Test::Perl::Critic)
29%endif
30Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
31
32%description
33Path::Class is a module for manipulation of file and directory specifications
34(strings describing their locations, like '/home/ken/foo.txt' or
35'C:\Windows\Foo.txt') in a cross-platform manner. It supports pretty much every
36platform Perl runs on, including Unix, Windows, Mac, VMS, Epoc, Cygwin, OS/2,
37and NetWare.
38
39%prep
40%setup -q -n Path-Class-%{version}
41
42# Don't really need Module::Build ≥ 0.3601
43%patch0 -p1
44
45%build
46perl Build.PL installdirs=vendor
47./Build
48
49%install
50rm -rf %{buildroot}
51./Build install destdir=%{buildroot} create_packlist=0
52%{_fixperms} %{buildroot}
53
54%check
55AUTHOR_TESTING=1 ./Build test
56
57%clean
58rm -rf %{buildroot}
59
60%files
61%defattr(-,root,root,-)
62%doc Changes README
63%{perl_vendorlib}/Path/
64%{_mandir}/man3/Path::Class.3pm*
65%{_mandir}/man3/Path::Class::Dir.3pm*
66%{_mandir}/man3/Path::Class::Entity.3pm*
67%{_mandir}/man3/Path::Class::File.3pm*
68
69%changelog
70* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.25-1
71- initial build for Vine Linux
72
73* Thu Feb 16 2012 Paul Howarth <paul@city-fan.org> - 0.25-1
74- Update to 0.25:
75  - resolve() now croak()s instead of die()s on non-existent file
76  - Added a traverse() method for directories, based on the fmap_cont() method
77    of Forest::Tree::Pure; it's an alternative to ->recurse, which allows for
78    more control over how the recursion happens
79  - Fixed a grammar error in the docs
80  - Added a tempfile() method for Dir objects, which provides an interface to
81    File::Temp (CPAN RT#60485)
82  - Fixed a non-helpful fatal error message when calling resolve() on a path
83    that doesn't exist; now dies with the proper "No such file or directory"
84    message and exit status
85- BR: perl(Test::Perl::Critic) and run author tests where possible
86- Add patch to support building with Module::Build < 0.3601
87
88* Thu Feb 16 2012 Paul Howarth <paul@city-fan.org> - 0.23-4
89- Spec clean-up:
90  - Add buildreqs for Perl core modules that might be dual-lived
91  - Tidy %%description
92  - Make %%files list more explicit
93  - Don't use macros for commands
94  - Use search.cpan.org source URL
95  - BR: at least version 0.87 of File::Spec
96
97* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.23-3
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
99
100* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.23-2
101- Perl mass rebuild
102
103* Thu Apr 14 2011 Ian Burrell <ianburrell@gmail.com> - 0.23-1
104- Update to 0.23
105
106* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18-4
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
108
109* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.18-3
110- Rebuild to fix problems with vendorarch/lib (#661697)
111
112* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.18-2
113- Mass rebuild with perl-5.12.0
114
115* Mon Feb 22 2010 Chris Weyl <cweyl@alumni.drew.edu> - 0.18-1
116- Update to 0.18 (for latest DBIx::Class)
117
118* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.16-6
119- Rebuild against perl 5.10.1
120
121* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16-5
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
123
124* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16-4
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.16-3
128- Rebuild for new perl
129
130* Thu Aug 16 2007 Ian Burrell <ianburrell@gmail.com> - 0.16-2
131- Fix BuildRequires
132
133* Mon Jan 29 2007 Ian Burrell <ianburrell@gmail.com> - 0.16-1
134- Specfile autogenerated by cpanspec 1.69.1
Note: See TracBrowser for help on using the repository browser.