source: projects/specs/trunk/p/perl-Params-ValidationCompiler/perl-Params-ValidationCompiler-vl.spec @ 12120

Revision 12120, 8.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# Run optional test
2%bcond_with perl_Params_ValidationCompiler_enables_optional_test
3
4Name:           perl-Params-ValidationCompiler
5Version:        0.30
6Release:        3%{?_dist_release}
7Summary:        Build an optimized subroutine parameter validator once, use it forever
8License:        Artistic 2.0
9URL:            https://metacpan.org/release/Params-ValidationCompiler
10Source0:        https://cpan.metacpan.org/modules/by-module/Params/Params-ValidationCompiler-%{version}.tar.gz
11
12Vendor:        Project Vine
13Distribution:  Vine Linux
14
15BuildArch:      noarch
16# Build
17BuildRequires:  coreutils
18BuildRequires:  make
19BuildRequires:  perl >= 2:5.26.2
20BuildRequires:  perl(ExtUtils::MakeMaker)
21# Module
22BuildRequires:  perl(B)
23BuildRequires:  perl(Carp)
24#BuildRequires: perl(Class::XSAccessor)
25BuildRequires:  perl(Eval::Closure)
26BuildRequires:  perl(Exception::Class)
27BuildRequires:  perl(Exporter)
28BuildRequires:  perl(List::Util)
29BuildRequires:  perl(overload)
30BuildRequires:  perl(Scalar::Util)
31BuildRequires:  perl(strict)
32BuildRequires:  perl(warnings)
33# Optional Functionality
34BuildRequires:  perl(Sub::Util)
35# Test Suite
36BuildRequires:  perl(File::Spec)
37BuildRequires:  perl(Specio)
38BuildRequires:  perl(Specio::Declare)
39BuildRequires:  perl(Specio::Library::Builtins)
40BuildRequires:  perl(Test2::Plugin::NoWarnings)
41BuildRequires:  perl(Test2::Require::Module)
42BuildRequires:  perl(Test2::V0)
43BuildRequires:  perl(Test::More)
44BuildRequires:  perl(Test::Without::Module)
45%if %{with perl_Params_ValidationCompiler_enables_optional_test}
46# Optional Tests
47BuildRequires:  perl(Const::Fast)
48BuildRequires:  perl(CPAN::Meta)
49BuildRequires:  perl(CPAN::Meta::Prereqs)
50BuildRequires:  perl(Hash::Util)
51%if !%{defined perl_bootstrap}
52# Avoid build dependency cycles via Moose and DateTime
53BuildRequires:  perl(Moose::Util::TypeConstraints)
54BuildRequires:  perl(Types::Standard)
55%endif
56%endif
57# Dependencies
58Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
59Recommends:     perl(Class::XSAccessor)
60Recommends:     perl(Sub::Util)
61
62%description
63Create a customized, optimized, non-lobotomized, uncompromised, and thoroughly
64specialized parameter checking subroutine.
65
66%prep
67%setup -q -n Params-ValidationCompiler-%{version}
68
69%build
70perl Makefile.PL INSTALLDIRS=vendor NO_PERLLOCAL=1 NO_PACKLIST=1
71make %{?_smp_mflags}
72
73%install
74make install DESTDIR=%{buildroot}
75%{_fixperms} -c %{buildroot}
76
77%check
78make test
79
80%files
81%license LICENSE
82%doc Changes CODE_OF_CONDUCT.md CONTRIBUTING.md eg/ README.md
83%{perl_vendorlib}/Params/
84%{_mandir}/man3/Params::ValidationCompiler.3*
85%{_mandir}/man3/Params::ValidationCompiler::Compiler.3*
86%{_mandir}/man3/Params::ValidationCompiler::Exceptions.3*
87
88%changelog
89* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.30-3
90- initial build for Vine Linux.
91
92* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.30-2
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
94
95* Wed Aug  1 2018 Paul Howarth <paul@city-fan.org> - 0.30-1
96- Update to 0.30
97  - Added a new option for named params, "return_object", which causes the
98    validation sub to return an object with methods for each param rather than
99    a hashref; this is a great way to avoid typos in hash keys (idea
100    shamelessly stolen from Toby Inkster's Type::Params module)
101  - Tweaked the POD formatting so that the table of contents generated by
102    MetaCPAN is more useful
103  - Optionally use Class::XSAccessor
104
105* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-4
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
107
108* Sun Jul 01 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.27-3
109- Perl 5.28 re-rebuild of bootstrapped packages
110
111* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.27-2
112- Perl 5.28 rebuild
113
114* Mon Feb 12 2018 Paul Howarth <paul@city-fan.org> - 0.27-1
115- Update to 0.27
116  - Fixed a bug with inlining Moose types: if a type's parent needed
117    environment variables, those would not get closed over (GH#22)
118  - Added a debug option to dump the source of the subroutine before it is
119    eval'd
120
121* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.26-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
123
124* Tue Nov 28 2017 Paul Howarth <paul@city-fan.org> - 0.26-1
125- Update to 0.26
126  - The exceptions.t test would fail if Sub::Util was not installed (GH#19)
127  - Fix test failures on Windows (GH#20)
128
129* Fri Nov 24 2017 Paul Howarth <paul@city-fan.org> - 0.25-1
130- Update to 0.25
131  - All exceptions now include a stack trace by default when treated as a
132    string; this makes finding where validation failed a lot easier (GH#18)
133  - The name for a subroutine is now used in some exception messages, even if
134    Sub::Util cannot be installed
135
136* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.24-4
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
138
139* Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.24-3
140- Perl 5.26 re-rebuild of bootstrapped packages
141
142* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.24-2
143- Perl 5.26 rebuild
144
145* Sun Apr  9 2017 Paul Howarth <paul@city-fan.org> - 0.24-1
146- Update to 0.24
147  - The source_for() exported by Params::ValidationCompiler did not work at all
148    (GH#16)
149
150* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.23-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
152
153* Mon Jan 23 2017 Paul Howarth <paul@city-fan.org> - 0.23-1
154- Update to 0.23
155  - Trying to create a validator for positional parameters where a required
156    param came after one with a default did not throw an exception
157  - A positional params validator with a slurpy type that had coercions did not
158    return the coerced values; it returned the original values instead
159
160* Sat Dec 31 2016 Paul Howarth <paul@city-fan.org> - 0.22-1
161- Update to 0.22
162  - Explicitly load the B module; previously, the code relied on this already
163    being loaded by something else (GH#11)
164  - Removed the alpha warning from the docs
165
166* Wed Dec  7 2016 Paul Howarth <paul@city-fan.org> - 0.21-1
167- Update to 0.21
168  - Switched to using GitHub issues
169
170* Tue Dec  6 2016 Paul Howarth <paul@city-fan.org> - 0.20-1
171- Update to 0.20
172  - The keys for parameter specifications are now validated, and if an unknown
173    key is seen then an exception will be thrown; this will help you catch
174    typos in your parameter specification (GH#8)
175
176* Tue Nov 22 2016 Paul Howarth <paul@city-fan.org> - 0.19-1
177- Update to 0.19
178  - Non-inlinable Specio types caused a syntax error when used with positional
179    params
180  - Positional params with coercions and defaults did not work properly; the
181    coerced value and the default would simply not be returned in any case
182
183* Mon Nov 14 2016 Paul Howarth <paul@city-fan.org> - 0.18-1
184- Update to 0.18
185  - Using coercions with positional parameters could cause a "Modification of a
186    read-only value attempted" exception when the generated code tried to
187    assign to elements of @_; this is now fixed by making a copy if any of the
188    types have a coercion
189  - Using Moose types with coercions in a positional params check would cause
190    invalid code to be generated; this could also happen with Type::Tiny if
191    either the type or a coercion could not be inlined
192
193* Mon Nov  7 2016 Paul Howarth <paul@city-fan.org> - 0.17-1
194- Update to 0.17
195  - When using positional parameters, parameters with a default are now
196    optional; for named parameters, this was already the case
197
198* Fri Nov  4 2016 Paul Howarth <paul@city-fan.org> - 0.16-1
199- Update to 0.16
200  - Previously, using a default with a positional parameter would result in an
201    error when compiling the validator subroutine; defaults now work with
202    positional parameters (GH#5)
203  - Moose and Specio types (and coercions) that provide variables to close over
204    when being inlined did not always compile properly; most notably, this was
205    not being handled at all for Moose types, and not completely handled for
206    Specio coercions
207
208* Thu Nov  3 2016 Paul Howarth <paul@city-fan.org> - 0.14-1
209- Update to 0.14
210  - Added a "named_to_list" option to support returning only the parameter
211    values from a named parameter validator rather than the key-value pairs
212    (GH#4)
213  - Errors from calls to validation_for() now use croak so as to show up at the
214    call site, rather than in the internals
215
216* Wed Oct 26 2016 Petr Pisar <ppisar@redhat.com> - 0.13-4
217- Break build cycle: perl-Moose → perl-DateTime → perl-Params-ValidationCompiler
218
219* Mon Sep 19 2016 Paul Howarth <paul@city-fan.org> - 0.13-3
220- Drop unused BR: findutils (#1377252)
221
222* Mon Sep 19 2016 Paul Howarth <paul@city-fan.org> - 0.13-2
223- Sanitize for Fedora submission
224
225* Sun Sep 18 2016 Paul Howarth <paul@city-fan.org> - 0.13-1
226- Initial RPM version
Note: See TracBrowser for help on using the repository browser.