source: projects/specs/trunk/p/perl-Params-Validate/perl-Params-Validate-vl.spec @ 8703

Revision 8703, 2.1 KB checked in by tomop, 10 years ago (diff)

updated perl modules.

RevLine 
[5661]1%define pkgname Params-Validate
2
3# Basic Information
4Name:           perl-%{pkgname}
[8703]5Version:        1.13
[5661]6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Params::Validate - Validate method/function parameters
17Summary(ja):    Params::Validate - メソッド/関数のパラメーターを検証する
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26The Params::Validate module allows you to validate method or function call
27parameters to an arbitrary level of specificity. At the simplest level, it
28is capable of validating the required parameters were given and that no
29unspecified additional parameters were passed in.
30
31It is also capable of determining that a parameter is of a specific type,
32that it is an object of a certain class hierarchy, that it possesses certain
33methods, or applying validation callbacks to arguments.
34
35#%%description -l ja
36#Params::Validate モジュールを使えば、
37
38%prep
39%setup -q -n %{pkgname}-%{version}
40
41%build
[8703]42%{__perl} Build.PL installdirs="vendor"
[5661]43./Build
44
45%install
46%{__rm} -rf ${RPM_BUILD_ROOT}
47PERL_INSTALL_ROOT=${RPM_BUILD_ROOT} ./Build install
48
49find $RPM_BUILD_ROOT%{_prefix} -type f -print |
50        sed "s@^$RPM_BUILD_ROOT@@g" |
51        grep -v ^%{_mandir} |
52        grep -v perllocal.pod |
53        grep -v "\.packlist" > %{name}.files
54
55if [ "$(cat %{name}.files)X" = "X" ] ; then
56        echo "ERROR: EMPTY FILE LIST"
57        exit -1
58fi
59
60# remove unnecessary files.
61find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
62find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
63
64
65%clean
66%{__rm} -rf ${RPM_BUILD_ROOT}
67
68
69%files -f %{name}.files
70%defattr(-,root,root)
71%doc Changes LICENSE README
72
73%changelog
[8703]74* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13-1
75- new upstream release.
76
[5661]77* Thu Jan 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.00-1
78- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.