source: projects/specs/trunk/p/perl-Package-Stash/perl-Package-Stash-vl.spec @ 5844

Revision 5844, 7.6 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Package-Stash
2Version:        0.33
3Release:        1%{?_dist_release}
4Summary:        Routines for manipulating stashes
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Package-Stash/
8Source0:        http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Package-Stash-%{version}.tar.gz
9Patch0:         Package-Stash-0.32-EU::MM-version.patch
10Patch1:         Package-Stash-0.32-old-Test::More.patch
11Patch2:         Package-Stash-0.31-no-Test::Requires.patch
12Patch3:         Package-Stash-0.32-no-Test::LeakTrace.patch
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
14BuildArch:      noarch
15BuildRequires:  perl(Carp)
16BuildRequires:  perl(Dist::CheckConflicts) >= 0.02
17BuildRequires:  perl(ExtUtils::MakeMaker)
18BuildRequires:  perl(Scalar::Util)
19BuildRequires:  perl(Package::DeprecationManager)
20BuildRequires:  perl(Package::Stash::XS) >= 0.24
21BuildRequires:  perl(Pod::Coverage::TrustPod)
22BuildRequires:  perl(Test::EOL)
23BuildRequires:  perl(Test::Fatal)
24BuildRequires:  perl(Test::More)
25BuildRequires:  perl(Test::NoTabs)
26BuildRequires:  perl(Test::Pod)
27BuildRequires:  perl(Test::Pod::Coverage)
28BuildRequires:  perl(Test::Requires)
29BuildRequires:  perl(Test::LeakTrace)
30BuildRequires:  perl(Test::Script)
31Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
32# For performance and consistency
33Requires:       perl(Package::Stash::XS) >= 0.24
34# Not found by rpm auto-provides
35Provides:       perl(Package::Stash::Conflicts) = 0
36
37%description
38Manipulating stashes (Perl's symbol tables) is occasionally necessary, but
39incredibly messy, and easy to get wrong. This module hides all of that behind
40a simple API.
41
42%prep
43%setup -q -n Package-Stash-%{version}
44
45%build
46perl Makefile.PL INSTALLDIRS=vendor
47make %{?_smp_mflags}
48
49%install
50rm -rf %{buildroot}
51make pure_install DESTDIR=%{buildroot}
52find %{buildroot} -type f -name .packlist -exec rm -f {} \;
53find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
54%{_fixperms} %{buildroot}
55
56%check
57make test AUTHOR_TESTING=1 RELEASE_TESTING=1
58
59%clean
60rm -rf %{buildroot}
61
62%files
63%defattr(-,root,root,-)
64%doc Changes LICENSE README
65%{_bindir}/package-stash-conflicts
66%{perl_vendorlib}/Package/
67%{_mandir}/man3/Package::Stash.3pm*
68%{_mandir}/man3/Package::Stash::PP.3pm*
69
70%changelog
71* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.33-1
72- initial build for Vine Linux
73
74* Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.33-2
75- Fedora 17 mass rebuild
76
77* Thu Sep 29 2011 Paul Howarth <paul@city-fan.org> - 0.33-1
78- Update to 0.33
79  - Add conflict on MooseX::Method::Signatures 0.36
80- BR: perl(Carp)
81
82* Tue Sep  6 2011 Paul Howarth <paul@city-fan.org> - 0.32-1
83- Update to 0.32
84  - Bring the behavior of has_symbol for nonexistant scalars into line with the
85    XS version
86  - Invalid package names (for instance, Foo:Bar) are not allowed
87  - Invalid stash entry names (anything containing ::) are not allowed
88- Update patches to apply cleanly
89- Bump perl(Package::Stash::XS) version requirement to 0.24
90
91* Tue Aug  9 2011 Paul Howarth <paul@city-fan.org> - 0.31-1
92- Update to 0.31
93  - Fix ->add_symbol('$foo', qr/sdlfk/) on 5.12+
94  - Fix ->add_symbol('$foo', \v1.2.3) on 5.10+
95- Update patch for old Test::More versions
96- Update patch for no Test::Requires
97
98* Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 0.30-2
99- Perl mass rebuild
100
101* Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 0.30-1
102- Update to 0.30
103  - Fix compiler detection in Makefile.PL
104- Update patch for old ExtUtils::MakeMaker versions
105- Drop usage of macros for commands
106- Drop redundant %%{?perl_default_filter}
107- perl(Pod::Coverage::TrustPod) now available everywhere
108
109* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.29-2
110- Perl mass rebuild
111
112* Wed Apr  6 2011 Paul Howarth <paul@city-fan.org> - 0.29-1
113- Update to 0.29
114  - Really skip the package-stash-conflict script in the compile test
115
116* Wed Mar 30 2011 Paul Howarth <paul@city-fan.org> - 0.28-1
117- Update to 0.28
118  - META.json fixes
119- Update patch for old ExtUtils::MakeMaker versions to apply cleanly
120
121* Mon Mar 28 2011 Paul Howarth <paul@city-fan.org> - 0.27-1
122- Update to 0.27
123  - Skip the package-stash-conflicts script in the compile test
124
125* Sat Mar  5 2011 Paul Howarth <paul@city-fan.org> - 0.26-1
126- Update to 0.26
127  - Make the namespace cache lazy and weak, in case the stash is deleted
128  - However, this doesn't work on 5.8, so disable the namespace caching
129    entirely there
130- Update patches to apply cleanly
131- Bump perl(Package::Stash::XS) version requirement to 0.22
132- Bump perl(Dist::CheckConflicts) version requirement to 0.02
133
134* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
136
137* Tue Jan 25 2011 Paul Howarth <paul@city-fan.org> - 0.25-1
138- Update to 0.25 (make the leak tests author-only, since some smokers run
139  release tests)
140- Update patches to apply cleanly
141- Bump perl(Package::Stash::XS) version requirement to 0.21
142- Drop buildreq perl(Test::Exception), no longer needed
143
144* Tue Jan 18 2011 Paul Howarth <paul@city-fan.org> - 0.24-1
145- Update to 0.24 (reinstate Test::Requires dependency)
146
147* Wed Jan 12 2011 Paul Howarth <paul@city-fan.org> - 0.23-1
148- Update to 0.23
149  - Lower perl prereq to 5.8.1
150  - Make the leak tests release-only
151- Update patches to apply cleanly
152- Add patch to skip memory leak tests if we don't have Test::LeakTrace
153
154* Thu Jan  6 2011 Paul Howarth <paul@city-fan.org> - 0.22-1
155- Update to 0.22 (bump Package::Stash::XS version requirement since a bug was
156  fixed there)
157- Update patches for old ExtUtils::MakeMaker and Test::More versions
158- BR/R perl(Package::Stash::XS) >= 0.19
159- Content-free manpages for package-stash-conflicts and
160  Package::Stash::Conflicts dropped upstream
161
162* Tue Jan  4 2011 Paul Howarth <paul@city-fan.org> - 0.20-1
163- Update to 0.20
164  - Methods were renamed for brevity: s/_package//
165  - Convert Package::Stash into a module which loads either the XS or pure perl
166    implementation, depending on what's available
167  - Use Test::Fatal instead of Test::Exception
168  - Use Dist::CheckConflicts
169  - Silence deprecation warnings for the method renaming for now
170- New script and manpage: package-stash-conflicts
171- New modules and manpages: Package::Stash::Conflicts and Package::Stash::PP
172- New build requirements:
173  - perl(Dist::CheckConflicts)
174  - perl(Package::DeprecationManager)
175  - perl(Package::Stash::XS)
176  - perl(Test::LeakTrace)
177  - perl(Test::Requires)
178  - perl(Test::Script)
179- Update patches for old ExtUtils::MakeMaker and Test::More versions
180- Add new patch to work around absence of Test::Requires in EPEL-4
181- Require perl(Package::Stash::XS) for performance and consistency
182- Manually provide perl(Package::Stash::Conflicts), hidden from auto-provides
183
184* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-2
185- Rebuild to fix problems with vendorarch/lib (#661697)
186
187* Mon Sep 20 2010 Paul Howarth <paul@city-fan.org> - 0.08-1
188- Update to 0.08 (re-enable the caching of the stash)
189- Update patch for old ExtUtils::MakeMaker and Test::More versions
190
191* Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> - 0.05-1
192- Update to 0.05
193  - Bump Test::More requirement for done_testing
194  - Update packaging stuff
195- BR: perl(Test::EOL) and perl(Test::NoTabs)
196- Unify spec for all active branches, adding patches for back-compatibility
197
198* Mon Jun 14 2010 Paul Howarth <paul@city-fan.org> - 0.04-1
199- Update to 0.04 (get_package_symbol now doesn't autovivify stash entries; a
200  new method get_or_add_package_symbol can now be used for that behavior)
201
202* Mon Jun 14 2010 Paul Howarth <paul@city-fan.org> - 0.03-2
203- Incorporate package review suggestions (#602597)
204  - Use %%{?perl_default_filter}
205  - Use DESTDIR instead of PERL_INSTALL_ROOT
206
207* Mon Jun  7 2010 Paul Howarth <paul@city-fan.org> - 0.03-1
208- Initial RPM version
Note: See TracBrowser for help on using the repository browser.