source: projects/specs/trunk/p/perl-Package-Generator/perl-Package-Generator-vl.spec @ 12120

Revision 12120, 4.2 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Package-Generator
2Version:        1.106
3Release:        2%{?_dist_release}
4Summary:        Generate new packages quickly and easily
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Package-Generator/
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Package-Generator-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
10BuildArch:      noarch
11BuildRequires:  perl(Carp)
12BuildRequires:  perl(ExtUtils::MakeMaker)
13BuildRequires:  perl(Params::Util)
14BuildRequires:  perl(Scalar::Util)
15BuildRequires:  perl(Symbol)
16BuildRequires:  perl(Test::More)
17# Test::Perl::Critic -> Perl::Critic -> Exception::Class -> Test::EOL ->
18#   Pod::Coverage::TrustPod -> Pod::Eventual -> Mixin::Linewise ->
19#   Sub::Exporter -> Package::Generator
20%if 0%{!?perl_bootstrap:1}
21#BuildRequires: perl(Test::Perl::Critic)
22%endif
23BuildRequires:  perl(Test::Pod)
24BuildRequires:  perl(Test::Pod::Coverage)
25Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
26
27Vendor:         Project Vine
28Distribution:   Vine Linux
29
30%description
31This module lets you quickly and easily construct new packages. It gives
32them unused names and sets up their package data, if provided.
33
34%prep
35%setup -q -n Package-Generator-%{version}
36
37%build
38perl Makefile.PL INSTALLDIRS=vendor
39make %{?_smp_mflags}
40
41%install
42rm -rf %{buildroot}
43make pure_install DESTDIR=%{buildroot}
44find %{buildroot} -type f -name .packlist -exec rm -f {} \;
45find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
46%{_fixperms} %{buildroot}
47
48%check
49make test %{!?perl_bootstrap:PERL_TEST_CRITIC=1}
50
51%clean
52rm -rf %{buildroot}
53
54%files
55%defattr(-,root,root,-)
56%doc Changes README
57%{perl_vendorlib}/Package/
58%{_mandir}/man3/Package::Generator.3pm*
59%{_mandir}/man3/Package::Reaper.3pm*
60
61%changelog
62* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.106-2
63- rebuilt with perl-5.26.
64
65* Sat Nov 22 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.106-1
66- updated to 1.106
67- built with perl 5.16.3
68
69* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.103-1
70- initial build for Vine Linux
71
72* Tue Feb  7 2012 Paul Howarth <paul@city-fan.org> - 0.103-9
73- Don't BR: perl(Test::Perl::Critic) if we're bootstrapping
74
75* Wed Feb  1 2012 Paul Howarth <paul@city-fan.org> - 0.103-8
76- Run Perl::Critic test in %%check too
77- BR: perl(Test::Perl::Critic)
78- BR: perl(Carp) and perl(Symbol), which might be dual-lived
79- Use DESTDIR rather than PERL_INSTALL_ROOT
80- Drop version requirement for perl(ExtUtils::MakeMaker); older versions work
81  without problems, e.g. version 6.17 on EL-4
82- Make %%files list more explicit
83- Don't use macros for commands
84- Use tabs
85
86* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.103-7
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
88
89* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.103-6
90- Perl mass rebuild
91
92* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.103-5
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
94
95* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.103-4
96- Rebuild to fix problems with vendorarch/lib (#661697)
97
98* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.103-3
99- Mass rebuild with perl-5.12.0
100
101* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.103-2
102- Rebuild against perl 5.10.1
103
104* Tue Aug 11 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.103-1
105- Auto-update to 0.103 (by cpan-spec-update 0.01)
106- Added a new br on perl(ExtUtils::MakeMaker) (version 6.42)
107
108* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-4
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
110
111* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-3
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
113
114* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.102-2
115- Rebuild for perl 5.10 (again)
116
117* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.102-1
118- Rebuild for new perl
119- Update to 0.102
120- Fix license tag
121
122* Wed Sep 06 2006 Chris Weyl <cweyl@alumni.drew.edu> - 0.100-2
123- Bump
124
125* Tue Sep 05 2006 Chris Weyl <cweyl@alumni.drew.edu> - 0.100-1
126- Specfile autogenerated by cpanspec 1.69.1
Note: See TracBrowser for help on using the repository browser.