source: projects/specs/trunk/p/perl-PPI/perl-PPI-vl.spec @ 5796

Revision 5796, 8.7 KB checked in by shaolin, 12 years ago (diff)
  • rebuild
Line 
1# define bootstrap for initial build
2%define perl_bootstrap 1
3
4Name:           perl-PPI
5Version:        1.215
6Release:        2%{?_dist_release}
7Summary:        Parse, Analyze and Manipulate Perl
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/PPI/
11Source0:        http://www.cpan.org/authors/id/A/AD/ADAMK/PPI-%{version}.tar.gz
12Patch0:         PPI-1.215-UTF8.patch
13BuildArch:      noarch
14BuildRequires:  perl(ExtUtils::MakeMaker)
15BuildRequires:  perl(List::Util) >= 1.20
16BuildRequires:  perl(Storable) >= 2.17
17BuildRequires:  perl(Clone) >= 0.30
18BuildRequires:  perl(Digest::MD5) >= 2.35
19BuildRequires:  perl(File::Remove) >= 1.42
20BuildRequires:  perl(IO::String) >= 1.07
21BuildRequires:  perl(List::MoreUtils) >= 0.16
22BuildRequires:  perl(Params::Util) >= 1.00
23BuildRequires:  perl(Task::Weaken)
24BuildRequires:  perl(Test::More) >= 0.86
25BuildRequires:  perl(Test::NoWarnings) >= 0.084
26BuildRequires:  perl(Test::Object) >= 0.07
27BuildRequires:  perl(Test::SubCalls) >= 1.07
28BuildRequires:  perl(Class::Inspector) >= 1.25
29# Circular dependencies in release tests, so don't do them when bootstrapping:
30# Perl::MinimumVersion -> PPI
31%if 0%{!?perl_bootstrap:1}
32BuildRequires:  perl(File::Find::Rule) >= 0.32
33BuildRequires:  perl(File::Find::Rule::Perl) >= 1.09
34BuildRequires:  perl(Perl::MinimumVersion) >= 1.20
35BuildRequires:  perl(Test::ClassAPI) >= 1.03
36BuildRequires:  perl(Test::CPAN::Meta)
37BuildRequires:  perl(Test::MinimumVersion) >= 0.101080
38BuildRequires:  perl(Test::Pod) >= 1.00
39%endif
40Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
41
42Vendor:         Project Vine
43Distribution:   Vine Linux
44Packager:       shaolin
45
46%description
47Parse, analyze and manipulate Perl (without perl).
48
49
50%prep
51%setup -q -n PPI-%{version}
52
53# Re-code docs as UTF-8
54%patch0 -p1
55
56# Filter out redundant unversioned provides
57%if %{_dist_release} > "vl6"
58%global __provides_exclude ^perl\\(PPI::.+\\)$
59%else
60cat << \EOF > %{name}-prov
61#!/bin/sh
62%{__perl_provides} $* |\
63sed -e '/^perl(PPI::.\+)$/d'
64EOF
65
66%global __perl_provides %{_builddir}/PPI-%{version}/%{name}-prov
67chmod +x %{__perl_provides}
68%endif
69
70
71%build
72perl Makefile.PL INSTALLDIRS=vendor
73make %{?_smp_mflags}
74
75
76%install
77make pure_install DESTDIR=%{buildroot}
78find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
79find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
80%{_fixperms} %{buildroot}
81
82
83%check
84make test
85%if 0%{!?perl_bootstrap:1}
86make test TEST_FILES="xt/*.t" RELEASE_TESTING=1
87%endif
88
89
90%files
91%doc Changes LICENSE README inline2test.conf inline2test.tpl
92%{perl_vendorlib}/PPI/
93%{perl_vendorlib}/PPI.pm
94%{_mandir}/man3/PPI*.3pm*
95
96
97%changelog
98* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-2
99- rebuild
100
101* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-1
102- initial build for Vine Linux
103
104* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.215-4
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
106
107* Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 1.215-3
108- always run test suite but don't run release tests when bootstrapping
109- nobody else likes macros for commands
110- clean up for modern rpm:
111  - drop explicit buildroot tag
112  - drop buildroot cleaning
113  - drop %%defattr
114  - use native provides filtering
115- use a patch rather than scripting iconv to fix character encoding
116- upstream file permissions no longer need fixing
117
118* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.215-2
119- rebuild with Perl 5.14.1
120- use perl_bootstrap macro
121
122* Sun Mar 27 2011 Paul Howarth <paul@city-fan.org> - 1.215-1
123- update to 1.215 (general fix release):
124  - index_locations on an empty document no longer warns
125  - Corrected a bug in line-spanning attribute support
126  - Regression test for line-spanning attribute support
127  - return { foo => 1 } should parse curlys as hash constructor, not block
128    (CPAN RT#61305)
129  - Fixed bug with map and regexp confusing PPI (CPAN RT#63943)
130  - Updated copyright year to 2011
131  - Fix bless {} probably contains a hash constructor (CPAN RT#64247)
132  - Backed out glob fix
133  - Fix cast can trump braces in PPI::Token::Symbol->symbol (CPAN RT#65199)
134
135* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.213-3
136- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
137
138* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.213-2
139- rebuild to fix problems with vendorarch/lib (#661697)
140
141* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.213-1
142- update to 1.213 (targeted bug fix, no changes to parsing or normal usage)
143  - Updated to Module::Install 1.00
144  - Updated module dependencies in xt author tests
145  - Fixed extremely broken PPI::Token::Pod::merge and added test case
146- bump perl(Perl::MinimumVersion) requirement to 1.25
147- bump perl(Test::CPAN::Meta) requirement to 0.17
148- bump perl(Test::Pod) requirement to 1.44
149
150* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.212-1
151- update to 1.212 (experimental/development support and bugfixes)
152  - Fixed bug in ForLoop back-compatibility warning (CPAN RT#48819)
153  - Added support for $ENV{X_TOKENIZER} --> $PPI::Lexer::X_TOKENIZER
154  - Upgraded to Module::Install 0.93
155  - Added support for $PPI::Lexer::X_TOKENIZER, for alternate tokenizers
156  - Added an extra test case to validate we handle byte order marks properly
157  - Moved author tests from t to xt
158  - Fixed CPAN RT#26082: scalar { %%x } is misparsed
159  - Fixed CPAN RT#26591: VMS patch for PPI 1.118
160  - Fixed CPAN RT#44862: PPI cannot parse "package Foo::100;" correctly
161  - Fixed CPAN RT#54208: PPI::Token::Quote::Literal::literal missing
162- run release tests as well as regular test suite
163- BR: perl(File::Find::Rule) >= 0.32, perl(File::Find::Rule::Perl) >= 1.09,
164  perl(Perl::MinimumVersion) >= 1.24 and perl(Test::MinimumVersion) >= 0.101080
165  for release tests
166
167* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.210-1
168- update to 1.210 (packaging fixes)
169- use RELEASE_TESTING rather than AUTOMATED_TESTING for better test coverage
170
171* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.209-1
172- update to 1.209 (small optimisation release, no functional changes)
173
174* Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.208-1
175- update to 1.208
176  - don't assign '' to $^W, it generates a warning on Gentoo
177  - added missing PPI::Token::Regexp fix to Changes file
178  - updating Copyright to the new year
179  - fixed #50309: literal() wrong result on "qw (a b c)"
180  - PPI::Dumper no longer causes Elements to flush location data
181  - PPI::Dumper no longer disables location information for non-Documents
182  - +{ package => 1 } doesn't create a PPI::Statement::Package
183  - extra methods in PPI::Token::Regexp and PPI::Token::QuoteLike::Regexp
184- use %%{_fixperms} macro instead of our own chmod incantation
185
186* Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.206-6
187- BR: perl(Task::Weaken) and perl(Test::CPAN::Meta) for improved test coverage
188- enable AUTOMATED_TESTING
189- use DESTDIR rather than PERL_INSTALL_ROOT
190
191* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.206-5
192- Mass rebuild with perl-5.12.0
193
194* Thu Feb 11 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-4
195- fix filtering, provide versioned provides
196
197* Wed Feb 10 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-3
198- make rpmlint happy
199
200* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-2
201- rebuild against perl 5.10.1
202
203* Wed Oct  7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-1
204- new upstream version
205- update build requires
206
207* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-3
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
209
210* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-2
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
212
213* Tue Sep  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.203-1
214- update to 1.203
215
216* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-3
217- Rebuild for perl 5.10 (again)
218
219* Sun Jan 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-2
220- rebuild for new perl
221
222* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-1
223- bump to 1.201
224
225* Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.118-1
226- Update to 1.118.
227
228* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.117-1
229- Update to 1.117.
230
231* Sun Jun  4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-2
232- Removed the perl(IO::Scalar) build requirement.
233
234* Sun Jun  4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-1
235- Update to 1.115.
236
237* Wed May 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.113-1
238- Update to 1.113.
239
240* Tue Apr 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.112-1
241- Update to 1.112.
242
243* Sat Apr 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.111-1
244- First build.
Note: See TracBrowser for help on using the repository browser.