source: projects/specs/trunk/p/perl-PPI/perl-PPI-vl.spec @ 12120

Revision 12120, 8.9 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# define bootstrap for initial build
2%define perl_bootstrap 1
3
4Name:           perl-PPI
5Version:        1.269
6Release:        1%{?_dist_release}
7Summary:        Parse, Analyze and Manipulate Perl
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/PPI/
11Source0:        http://www.cpan.org/authors/id/A/AD/ADAMK/PPI-%{version}.tar.gz
12#Patch0:         PPI-1.215-UTF8.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(List::Util)
18BuildRequires:  perl(Storable)
19BuildRequires:  perl(Clone)
20BuildRequires:  perl(Digest::MD5)
21BuildRequires:  perl(File::Remove)
22BuildRequires:  perl(IO::String)
23BuildRequires:  perl(List::MoreUtils)
24BuildRequires:  perl(Params::Util)
25BuildRequires:  perl(Test::Deep)
26BuildRequires:  perl(Task::Weaken)
27BuildRequires:  perl(Test::More)
28BuildRequires:  perl(Test::NoWarnings)
29BuildRequires:  perl(Test::Object)
30BuildRequires:  perl(Test::SubCalls)
31BuildRequires:  perl(Class::Inspector)
32# Circular dependencies in release tests, so don't do them when bootstrapping:
33# Perl::MinimumVersion -> PPI
34%if 0%{!?perl_bootstrap:1}
35BuildRequires:  perl(File::Find::Rule)
36BuildRequires:  perl(File::Find::Rule::Perl)
37BuildRequires:  perl(Perl::MinimumVersion)
38BuildRequires:  perl(Test::ClassAPI)
39BuildRequires:  perl(Test::CPAN::Meta)
40BuildRequires:  perl(Test::MinimumVersion)
41BuildRequires:  perl(Test::Pod)
42%endif
43Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
44
45Vendor:         Project Vine
46Distribution:   Vine Linux
47Packager:       shaolin
48
49%description
50Parse, analyze and manipulate Perl (without perl).
51
52
53%prep
54%setup -q -n PPI-%{version}
55
56# Re-code docs as UTF-8
57#%patch0 -p1
58
59# Filter out redundant unversioned provides
60%if %{_dist_release} > "vl6"
61%global __provides_exclude ^perl\\(PPI::.+\\)$
62%else
63cat << \EOF > %{name}-prov
64#!/bin/sh
65%{__perl_provides} $* |\
66sed -e '/^perl(PPI::.\+)$/d'
67EOF
68
69%global __perl_provides %{_builddir}/PPI-%{version}/%{name}-prov
70chmod +x %{__perl_provides}
71%endif
72
73
74%build
75perl Makefile.PL INSTALLDIRS=vendor
76make %{?_smp_mflags}
77
78
79%install
80make pure_install DESTDIR=%{buildroot}
81find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
82find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
83%{_fixperms} %{buildroot}
84
85
86%check
87make test
88%if 0%{!?perl_bootstrap:1}
89make test TEST_FILES="xt/*.t" RELEASE_TESTING=1
90%endif
91
92
93%files
94%license LICENSE
95%doc Changes README inline2test.conf inline2test.tpl
96%{perl_vendorlib}/PPI/
97%{perl_vendorlib}/PPI.pm
98%{_mandir}/man3/PPI*.3pm*
99
100
101%changelog
102* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.269-1
103- new upstream release.
104- rebuilt with perl-5.26.
105
106* Sat Nov 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.215-3
107- rebuilt with perl 5.16.3
108
109* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-2
110- rebuild
111
112* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-1
113- initial build for Vine Linux
114
115* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.215-4
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
117
118* Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 1.215-3
119- always run test suite but don't run release tests when bootstrapping
120- nobody else likes macros for commands
121- clean up for modern rpm:
122  - drop explicit buildroot tag
123  - drop buildroot cleaning
124  - drop %%defattr
125  - use native provides filtering
126- use a patch rather than scripting iconv to fix character encoding
127- upstream file permissions no longer need fixing
128
129* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.215-2
130- rebuild with Perl 5.14.1
131- use perl_bootstrap macro
132
133* Sun Mar 27 2011 Paul Howarth <paul@city-fan.org> - 1.215-1
134- update to 1.215 (general fix release):
135  - index_locations on an empty document no longer warns
136  - Corrected a bug in line-spanning attribute support
137  - Regression test for line-spanning attribute support
138  - return { foo => 1 } should parse curlys as hash constructor, not block
139    (CPAN RT#61305)
140  - Fixed bug with map and regexp confusing PPI (CPAN RT#63943)
141  - Updated copyright year to 2011
142  - Fix bless {} probably contains a hash constructor (CPAN RT#64247)
143  - Backed out glob fix
144  - Fix cast can trump braces in PPI::Token::Symbol->symbol (CPAN RT#65199)
145
146* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.213-3
147- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
148
149* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.213-2
150- rebuild to fix problems with vendorarch/lib (#661697)
151
152* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.213-1
153- update to 1.213 (targeted bug fix, no changes to parsing or normal usage)
154  - Updated to Module::Install 1.00
155  - Updated module dependencies in xt author tests
156  - Fixed extremely broken PPI::Token::Pod::merge and added test case
157- bump perl(Perl::MinimumVersion) requirement to 1.25
158- bump perl(Test::CPAN::Meta) requirement to 0.17
159- bump perl(Test::Pod) requirement to 1.44
160
161* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.212-1
162- update to 1.212 (experimental/development support and bugfixes)
163  - Fixed bug in ForLoop back-compatibility warning (CPAN RT#48819)
164  - Added support for $ENV{X_TOKENIZER} --> $PPI::Lexer::X_TOKENIZER
165  - Upgraded to Module::Install 0.93
166  - Added support for $PPI::Lexer::X_TOKENIZER, for alternate tokenizers
167  - Added an extra test case to validate we handle byte order marks properly
168  - Moved author tests from t to xt
169  - Fixed CPAN RT#26082: scalar { %%x } is misparsed
170  - Fixed CPAN RT#26591: VMS patch for PPI 1.118
171  - Fixed CPAN RT#44862: PPI cannot parse "package Foo::100;" correctly
172  - Fixed CPAN RT#54208: PPI::Token::Quote::Literal::literal missing
173- run release tests as well as regular test suite
174- BR: perl(File::Find::Rule) >= 0.32, perl(File::Find::Rule::Perl) >= 1.09,
175  perl(Perl::MinimumVersion) >= 1.24 and perl(Test::MinimumVersion) >= 0.101080
176  for release tests
177
178* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.210-1
179- update to 1.210 (packaging fixes)
180- use RELEASE_TESTING rather than AUTOMATED_TESTING for better test coverage
181
182* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.209-1
183- update to 1.209 (small optimisation release, no functional changes)
184
185* Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.208-1
186- update to 1.208
187  - don't assign '' to $^W, it generates a warning on Gentoo
188  - added missing PPI::Token::Regexp fix to Changes file
189  - updating Copyright to the new year
190  - fixed #50309: literal() wrong result on "qw (a b c)"
191  - PPI::Dumper no longer causes Elements to flush location data
192  - PPI::Dumper no longer disables location information for non-Documents
193  - +{ package => 1 } doesn't create a PPI::Statement::Package
194  - extra methods in PPI::Token::Regexp and PPI::Token::QuoteLike::Regexp
195- use %%{_fixperms} macro instead of our own chmod incantation
196
197* Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.206-6
198- BR: perl(Task::Weaken) and perl(Test::CPAN::Meta) for improved test coverage
199- enable AUTOMATED_TESTING
200- use DESTDIR rather than PERL_INSTALL_ROOT
201
202* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.206-5
203- Mass rebuild with perl-5.12.0
204
205* Thu Feb 11 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-4
206- fix filtering, provide versioned provides
207
208* Wed Feb 10 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-3
209- make rpmlint happy
210
211* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-2
212- rebuild against perl 5.10.1
213
214* Wed Oct  7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-1
215- new upstream version
216- update build requires
217
218* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-3
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
220
221* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-2
222- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
223
224* Tue Sep  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.203-1
225- update to 1.203
226
227* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-3
228- Rebuild for perl 5.10 (again)
229
230* Sun Jan 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-2
231- rebuild for new perl
232
233* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-1
234- bump to 1.201
235
236* Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.118-1
237- Update to 1.118.
238
239* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.117-1
240- Update to 1.117.
241
242* Sun Jun  4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-2
243- Removed the perl(IO::Scalar) build requirement.
244
245* Sun Jun  4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-1
246- Update to 1.115.
247
248* Wed May 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.113-1
249- Update to 1.113.
250
251* Tue Apr 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.112-1
252- Update to 1.112.
253
254* Sat Apr 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.111-1
255- First build.
Note: See TracBrowser for help on using the repository browser.