source: projects/specs/trunk/p/perl-PPI/perl-PPI-vl.spec @ 9089

Revision 9089, 8.9 KB checked in by inagaki, 9 years ago (diff)

2014-11-15 Ryoichi INAGAKI <ryo1@…>

  • perl-Algorithm-C3, perl-Class-Inspector, perl-Hook-LexWrap?, perl-Tie-IxHash?: updated
  • perl-Algorithm-Diff, perl-JSON-XS, perl-PPI, perl-Test-SubCalls?, perl-Text-Diff: rebuilt


Line 
1# define bootstrap for initial build
2%define perl_bootstrap 1
3
4Name:           perl-PPI
5Version:        1.215
6Release:        3%{?_dist_release}
7Summary:        Parse, Analyze and Manipulate Perl
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/PPI/
11Source0:        http://www.cpan.org/authors/id/A/AD/ADAMK/PPI-%{version}.tar.gz
12Patch0:         PPI-1.215-UTF8.patch
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(List::Util) >= 1.20
18BuildRequires:  perl(Storable) >= 2.17
19BuildRequires:  perl(Clone) >= 0.30
20BuildRequires:  perl(Digest::MD5) >= 2.35
21BuildRequires:  perl(File::Remove) >= 1.42
22BuildRequires:  perl(IO::String) >= 1.07
23BuildRequires:  perl(List::MoreUtils) >= 0.16
24BuildRequires:  perl(Params::Util) >= 1.00
25BuildRequires:  perl(Task::Weaken)
26BuildRequires:  perl(Test::More) >= 0.86
27BuildRequires:  perl(Test::NoWarnings) >= 0.084
28BuildRequires:  perl(Test::Object) >= 0.07
29BuildRequires:  perl(Test::SubCalls) >= 1.07
30BuildRequires:  perl(Class::Inspector) >= 1.25
31# Circular dependencies in release tests, so don't do them when bootstrapping:
32# Perl::MinimumVersion -> PPI
33%if 0%{!?perl_bootstrap:1}
34BuildRequires:  perl(File::Find::Rule) >= 0.32
35BuildRequires:  perl(File::Find::Rule::Perl) >= 1.09
36BuildRequires:  perl(Perl::MinimumVersion) >= 1.20
37BuildRequires:  perl(Test::ClassAPI) >= 1.03
38BuildRequires:  perl(Test::CPAN::Meta)
39BuildRequires:  perl(Test::MinimumVersion) >= 0.101080
40BuildRequires:  perl(Test::Pod) >= 1.00
41%endif
42Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46Packager:       shaolin
47
48%description
49Parse, analyze and manipulate Perl (without perl).
50
51
52%prep
53%setup -q -n PPI-%{version}
54
55# Re-code docs as UTF-8
56%patch0 -p1
57
58# Filter out redundant unversioned provides
59%if %{_dist_release} > "vl6"
60%global __provides_exclude ^perl\\(PPI::.+\\)$
61%else
62cat << \EOF > %{name}-prov
63#!/bin/sh
64%{__perl_provides} $* |\
65sed -e '/^perl(PPI::.\+)$/d'
66EOF
67
68%global __perl_provides %{_builddir}/PPI-%{version}/%{name}-prov
69chmod +x %{__perl_provides}
70%endif
71
72
73%build
74perl Makefile.PL INSTALLDIRS=vendor
75make %{?_smp_mflags}
76
77
78%install
79make pure_install DESTDIR=%{buildroot}
80find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
81find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
82%{_fixperms} %{buildroot}
83
84
85%check
86make test
87%if 0%{!?perl_bootstrap:1}
88make test TEST_FILES="xt/*.t" RELEASE_TESTING=1
89%endif
90
91
92%files
93%doc Changes LICENSE README inline2test.conf inline2test.tpl
94%{perl_vendorlib}/PPI/
95%{perl_vendorlib}/PPI.pm
96%{_mandir}/man3/PPI*.3pm*
97
98
99%changelog
100* Sat Nov 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.215-3
101- rebuilt with perl 5.16.3
102
103* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-2
104- rebuild
105
106* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.215-1
107- initial build for Vine Linux
108
109* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.215-4
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
111
112* Thu Jul 21 2011 Paul Howarth <paul@city-fan.org> - 1.215-3
113- always run test suite but don't run release tests when bootstrapping
114- nobody else likes macros for commands
115- clean up for modern rpm:
116  - drop explicit buildroot tag
117  - drop buildroot cleaning
118  - drop %%defattr
119  - use native provides filtering
120- use a patch rather than scripting iconv to fix character encoding
121- upstream file permissions no longer need fixing
122
123* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.215-2
124- rebuild with Perl 5.14.1
125- use perl_bootstrap macro
126
127* Sun Mar 27 2011 Paul Howarth <paul@city-fan.org> - 1.215-1
128- update to 1.215 (general fix release):
129  - index_locations on an empty document no longer warns
130  - Corrected a bug in line-spanning attribute support
131  - Regression test for line-spanning attribute support
132  - return { foo => 1 } should parse curlys as hash constructor, not block
133    (CPAN RT#61305)
134  - Fixed bug with map and regexp confusing PPI (CPAN RT#63943)
135  - Updated copyright year to 2011
136  - Fix bless {} probably contains a hash constructor (CPAN RT#64247)
137  - Backed out glob fix
138  - Fix cast can trump braces in PPI::Token::Symbol->symbol (CPAN RT#65199)
139
140* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.213-3
141- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
142
143* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.213-2
144- rebuild to fix problems with vendorarch/lib (#661697)
145
146* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.213-1
147- update to 1.213 (targeted bug fix, no changes to parsing or normal usage)
148  - Updated to Module::Install 1.00
149  - Updated module dependencies in xt author tests
150  - Fixed extremely broken PPI::Token::Pod::merge and added test case
151- bump perl(Perl::MinimumVersion) requirement to 1.25
152- bump perl(Test::CPAN::Meta) requirement to 0.17
153- bump perl(Test::Pod) requirement to 1.44
154
155* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.212-1
156- update to 1.212 (experimental/development support and bugfixes)
157  - Fixed bug in ForLoop back-compatibility warning (CPAN RT#48819)
158  - Added support for $ENV{X_TOKENIZER} --> $PPI::Lexer::X_TOKENIZER
159  - Upgraded to Module::Install 0.93
160  - Added support for $PPI::Lexer::X_TOKENIZER, for alternate tokenizers
161  - Added an extra test case to validate we handle byte order marks properly
162  - Moved author tests from t to xt
163  - Fixed CPAN RT#26082: scalar { %%x } is misparsed
164  - Fixed CPAN RT#26591: VMS patch for PPI 1.118
165  - Fixed CPAN RT#44862: PPI cannot parse "package Foo::100;" correctly
166  - Fixed CPAN RT#54208: PPI::Token::Quote::Literal::literal missing
167- run release tests as well as regular test suite
168- BR: perl(File::Find::Rule) >= 0.32, perl(File::Find::Rule::Perl) >= 1.09,
169  perl(Perl::MinimumVersion) >= 1.24 and perl(Test::MinimumVersion) >= 0.101080
170  for release tests
171
172* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.210-1
173- update to 1.210 (packaging fixes)
174- use RELEASE_TESTING rather than AUTOMATED_TESTING for better test coverage
175
176* Sat Jul 31 2010 Paul Howarth <paul@city-fan.org> - 1.209-1
177- update to 1.209 (small optimisation release, no functional changes)
178
179* Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.208-1
180- update to 1.208
181  - don't assign '' to $^W, it generates a warning on Gentoo
182  - added missing PPI::Token::Regexp fix to Changes file
183  - updating Copyright to the new year
184  - fixed #50309: literal() wrong result on "qw (a b c)"
185  - PPI::Dumper no longer causes Elements to flush location data
186  - PPI::Dumper no longer disables location information for non-Documents
187  - +{ package => 1 } doesn't create a PPI::Statement::Package
188  - extra methods in PPI::Token::Regexp and PPI::Token::QuoteLike::Regexp
189- use %%{_fixperms} macro instead of our own chmod incantation
190
191* Fri Jul 30 2010 Paul Howarth <paul@city-fan.org> - 1.206-6
192- BR: perl(Task::Weaken) and perl(Test::CPAN::Meta) for improved test coverage
193- enable AUTOMATED_TESTING
194- use DESTDIR rather than PERL_INSTALL_ROOT
195
196* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.206-5
197- Mass rebuild with perl-5.12.0
198
199* Thu Feb 11 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-4
200- fix filtering, provide versioned provides
201
202* Wed Feb 10 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.206-3
203- make rpmlint happy
204
205* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-2
206- rebuild against perl 5.10.1
207
208* Wed Oct  7 2009 Stepan Kasal <skasal@redhat.com> - 1.206-1
209- new upstream version
210- update build requires
211
212* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-3
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
214
215* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.203-2
216- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
217
218* Tue Sep  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.203-1
219- update to 1.203
220
221* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-3
222- Rebuild for perl 5.10 (again)
223
224* Sun Jan 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-2
225- rebuild for new perl
226
227* Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.201-1
228- bump to 1.201
229
230* Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.118-1
231- Update to 1.118.
232
233* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.117-1
234- Update to 1.117.
235
236* Sun Jun  4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-2
237- Removed the perl(IO::Scalar) build requirement.
238
239* Sun Jun  4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.115-1
240- Update to 1.115.
241
242* Wed May 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.113-1
243- Update to 1.113.
244
245* Tue Apr 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.112-1
246- Update to 1.112.
247
248* Sat Apr 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.111-1
249- First build.
Note: See TracBrowser for help on using the repository browser.