source: projects/specs/trunk/p/perl-Net_SSLeay/perl-Net_SSLeay-vl.spec @ 8662

Revision 8662, 5.4 KB checked in by iwaim, 10 years ago (diff)

perl-Net_SSLeay 1.42-2

Line 
1%define real_name Net-SSLeay
2
3Summary: Perl module for using OpenSSL via Network
4Summary(ja): OpenSSL を Network にて用いる為の perl モジュール
5Name: perl-Net_SSLeay
6Version: 1.42
7Release: 2%{?_dist_release}
8License: BSDish
9Group: Development/Libraries
10Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Net/%{real_name}-%{version}.tar.gz
11Source1: COPYRIGHT.SSLeay-0.9.0
12BuildRequires: perl, openssl-devel >= 0.9.6b
13BuildRequires: zlib-devel
14Requires: perl, openssl >= 0.9.6b
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16
17%description
18Perl module for using OpenSSL via Network, Net::SSLeay.
19
20%description -l ja
21OpenSSL を Network にて用いる為の perl モジュール, Net::SSLeay
22
23%prep
24%setup -q -n %{real_name}-%{version}
25cp -p %{SOURCE1} .
26
27# openssl_path is /usr here, therefore don't -I/usr/include and
28# especially don't (badly) hardcode standard library search path
29# /usr/lib
30if [[ "%{_prefix}" = "/usr" ]]; then
31  perl -pi -e "s@-[LI]\\\$openssl_path[^\s\"]*@@g" Makefile.PL INSTALLDIRS=vendor
32fi
33
34%build
35# note the %{_prefix} which must passed to Makefile.PL, weird but necessary :-(
36perl Makefile.PL %{_prefix} INSTALLDIRS=vendor << EOI
37n
38EOI
39make OPTIMIZE="$RPM_OPT_FLAGS" PREFIX=%{_prefix}
40perl -p -i -e 's|/usr/local/bin|/usr/bin|g;' *.pm examples/*
41
42%install
43rm -rf %{buildroot}
44#mkdir -p %{buildroot}%{perl_archlib}
45#make install PREFIX=%{buildroot}%{_prefix} \
46#       SITEPREFIX=%{buildroot}%{_prefix} \
47#       VENDORPREFIX=%{buildroot}%{_prefix} \
48#       INSTALLPRIVLIB=%{buildroot}%{perl_privlib} \
49#       INSTALLSITELIB=%{buildroot}%{perl_sitelib} \
50#       INSTALLVENDORLIB=%{buildroot}%{perl_vendorlib} \
51#       INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
52#       INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
53#       INSTALLVENDORARCH=%{buildroot}%{perl_vendorarch} \
54#       INSTALLBIN=%{buildroot}%{_bindir} \
55#       INSTALLSITEBIN=%{buildroot}%{_bindir} \
56#       INSTALLVENDORBIN=%{buildroot}%{_bindir} \
57#       INSTALLSCRIPT=%{buildroot}%{_bindir} \
58#       INSTALLMAN1DIR=%{buildroot}%{_mandir}/man1 \
59#       INSTALLSITEMAN1DIR=%{buildroot}%{_mandir}/man1 \
60#       INSTALLVENDORMAN1DIR=%{buildroot}%{_mandir}/man1 \
61#       INSTALLMAN3DIR=%{buildroot}%{_mandir}/man3 \
62#       INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 \
63#       INSTALLVENDORMAN3DIR=%{buildroot}%{_mandir}/man3
64make install DESTDIR=%{buildroot}
65
66sed -e "s@^%{buildroot}@@g" < %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist > .packlist
67mv -f .packlist %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist
68
69#if [ -f %{buildroot}%{perl_archlib}/perllocal.pod ] ; then
70#    mv %{buildroot}%{perl_archlib}/perllocal.pod .
71#else
72#    touch perllocal.pod
73#fi
74
75perllocalfile=`find %{buildroot} -name perllocal.pod`
76echo "mv $perllocalfile ."
77mv $perllocalfile .
78
79{
80find %{buildroot}  \
81  -type f -o -type l | sed -e "s@^%{buildroot}@@g" -e 's@^\(.*/man/.*\)$@\1*@g'
82} > %{name}.files
83
84%clean
85rm -rf %{buildroot}
86
87#check
88#make test
89
90%files -f %{name}.files
91%defattr(-,root,root)
92%doc Changes Credits QuickRef README COPYRIGHT.SSLeay-0.9.0 perllocal.pod
93#%dir %{perl_vendorarch}/auto/Net
94#%dir %{perl_vendorarch}/auto/Net/SSLeay
95#%dir %{perl_vendorarch}/Net
96#%dir %{perl_vendorarch}/Net/SSLeay
97
98%changelog
99* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.42-2
100- build with Perl 5.16
101
102* Sun Feb 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.42-1
103- new upstream release
104
105* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-2
106- rebuild with perl-5.12.3
107
108* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-1
109- new upstream release
110- change BuildRequires: openssl-devel instead of openssl
111- add BuildRequires: zlib-devel
112
113* Wed Jul  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.35-1
114- new upstream release
115
116* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.30-2
117- spec in utf-8
118
119* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-1
120- rebuilt with perl-5.10.0
121- applied new versioning policy
122
123* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl2
124- rebuilt with openssl-0.9.8e
125
126* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl1
127- updated to 1.30
128
129* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.25-0vl4
130- installed files to vendor_perl
131- changed Group to Development/Libraries
132
133* Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl3
134- build on perl-5.8.6-0vl1
135
136* Wed Dec 10 2003 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl2
137- build with perl-5.8.2
138- add %%{perl_sitearch}/{Net,Net/SSLeay} directories in %%files
139
140* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.25-0vl1
141- new upstream version
142- built on perl-5.8.1
143
144* Thu May 08 2003 Tomoya TAKA <taka@vinelinux.org> 1.22-0vl5
145- fixed install man dir, again
146
147* Tue May 06 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl4
148- fixed install dir of perllocal.pod
149
150* Thu May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl3
151- fixed install man dir
152
153* Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl2
154- comment out "make test"
155
156* Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl1
157- updated to 1.22
158
159* Fri Feb 15 2002 Toru Sagami <sagami@vinelinux.org> 1.13-0vl1
160- updated to 1.13
161- BuildPreReq/Requires: perl, openssl-0.9.6b
162- rewrite a better spec with License/Group
163
164* Mon Jul 16 2001 <sagami@vinelinux.org>
165- 1.07-0vl3: rebuilt with openssl-0.9.6b
166- erase unneeeded files from %%doc
167- use _prefix, not prefix
168
169* Thu Jul 05 2001 <sagami@vinelinux.org>
170- 1.07-0vl2: built with perl-5.6.1
171
172* Thu Jun  7 2001 Yasuhide OMORI <omori@m-t.com>
173- 1.07
174
175* Fri Sep 1 2000 Yoshishiro Kajiki <kajiki@ylug.org>
176- first version of rpm.
Note: See TracBrowser for help on using the repository browser.