source: projects/specs/trunk/p/perl-Net-Server/perl-Net-Server-vl.spec @ 12120

Revision 12120, 2.5 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define pkgname Net-Server
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        2.009
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/R/RH/RHANDOM/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Net::Server - Extensible, general Perl server engine
18Summary(ja):    Net::Server - 拡張可能で一般的な Perl サーバーエンジン
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27Net::Server is an extensible, generic Perl server engine. Net::Server
28combines the good properties from Net::Daemon (0.34), NetServer::Generic
29(1.03), and Net::FTPServer (1.0), and also from various concepts in the
30Apache Webserver.
31
32%description -l ja
33Net::Server は、拡張可能で一般的な Perl サーバーエンジンです。Net::Server は、
34Net::Daemon (0.34)、NetServer::Generic (1.03)、Net::FTPServer (1.0) の良い特
35性を組み合わせています。Apache ウェブサーバーのさまざまなコンセプトも取り入
36れています。
37
38%prep
39%setup -q -n Net-Server-%{version}
40
41%build
42perl Makefile.PL INSTALLDIRS="vendor"
43%{__make}
44
45%install
46%{__rm} -rf ${RPM_BUILD_ROOT}
47%{__make} install DESTDIR=${RPM_BUILD_ROOT}
48
49find $RPM_BUILD_ROOT%{_prefix} -type f -print |
50        sed "s@^$RPM_BUILD_ROOT@@g" |
51        grep -v ^%{_mandir} |
52        grep -v perllocal.pod |
53        grep -v "\.packlist" > %{name}.files
54
55if [ "$(cat %{name}.files)X" = "X" ] ; then
56        echo "ERROR: EMPTY FILE LIST"
57        exit -1
58fi
59
60# remove unnecessary files.
61%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
62%{__rm} ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/Net/Server/.packlist
63
64
65%clean
66%{__rm} -rf ${RPM_BUILD_ROOT}
67
68
69%files -f %{name}.files
70%defattr(-,root,root)
71%doc Changes README
72%{_mandir}/man1/*
73%{_mandir}/man3/*
74
75%changelog
76* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.009-1
77- new upstream release.
78- rebuilt with perl-5.26.
79
80* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.008-1
81- new upstream release.
82
83* Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.007-1
84- new upstream release.
85
86* Wed Jan 25 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.99-2
87- Add BuildArch (noarch)
88
89* Fri Jan 13 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.99-1
90- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.