source: projects/specs/trunk/p/perl-Net-SSLeay/perl-Net-SSLeay-vl.spec @ 8699

Revision 8699, 5.6 KB checked in by tomop, 10 years ago (diff)

spamassassin-3.4.0

Line 
1%define real_name Net-SSLeay
2
3Summary: Perl module for using OpenSSL via Network
4Summary(ja): OpenSSL を Network にて用いる為の perl モジュール
5Name: perl-Net-SSLeay
6Version: 1.64
7Release: 1%{?_dist_release}
8License: BSDish
9Group: Development/Libraries
10Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/Net/%{real_name}-%{version}.tar.gz
11Source1: COPYRIGHT.SSLeay-0.9.0
12BuildRequires: perl, openssl-devel >= 0.9.6b
13BuildRequires: zlib-devel
14Requires: perl, openssl >= 0.9.6b
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16
17Obsoletes: perl-Net_SSLeay < 1.64
18Provides: perl-Net_SSLeay
19
20%description
21Perl module for using OpenSSL via Network, Net::SSLeay.
22
23%description -l ja
24OpenSSL を Network にて用いる為の perl モジュール, Net::SSLeay
25
26%prep
27%setup -q -n %{real_name}-%{version}
28cp -p %{SOURCE1} .
29
30# openssl_path is /usr here, therefore don't -I/usr/include and
31# especially don't (badly) hardcode standard library search path
32# /usr/lib
33if [[ "%{_prefix}" = "/usr" ]]; then
34  perl -pi -e "s@-[LI]\\\$openssl_path[^\s\"]*@@g" Makefile.PL INSTALLDIRS=vendor
35fi
36
37%build
38# note the %{_prefix} which must passed to Makefile.PL, weird but necessary :-(
39perl Makefile.PL %{_prefix} INSTALLDIRS=vendor << EOI
40n
41EOI
42make OPTIMIZE="$RPM_OPT_FLAGS" PREFIX=%{_prefix}
43perl -p -i -e 's|/usr/local/bin|/usr/bin|g;' *.pm examples/*
44
45%install
46rm -rf %{buildroot}
47#mkdir -p %{buildroot}%{perl_archlib}
48#make install PREFIX=%{buildroot}%{_prefix} \
49#       SITEPREFIX=%{buildroot}%{_prefix} \
50#       VENDORPREFIX=%{buildroot}%{_prefix} \
51#       INSTALLPRIVLIB=%{buildroot}%{perl_privlib} \
52#       INSTALLSITELIB=%{buildroot}%{perl_sitelib} \
53#       INSTALLVENDORLIB=%{buildroot}%{perl_vendorlib} \
54#       INSTALLARCHLIB=%{buildroot}%{perl_archlib} \
55#       INSTALLSITEARCH=%{buildroot}%{perl_sitearch} \
56#       INSTALLVENDORARCH=%{buildroot}%{perl_vendorarch} \
57#       INSTALLBIN=%{buildroot}%{_bindir} \
58#       INSTALLSITEBIN=%{buildroot}%{_bindir} \
59#       INSTALLVENDORBIN=%{buildroot}%{_bindir} \
60#       INSTALLSCRIPT=%{buildroot}%{_bindir} \
61#       INSTALLMAN1DIR=%{buildroot}%{_mandir}/man1 \
62#       INSTALLSITEMAN1DIR=%{buildroot}%{_mandir}/man1 \
63#       INSTALLVENDORMAN1DIR=%{buildroot}%{_mandir}/man1 \
64#       INSTALLMAN3DIR=%{buildroot}%{_mandir}/man3 \
65#       INSTALLSITEMAN3DIR=%{buildroot}%{_mandir}/man3 \
66#       INSTALLVENDORMAN3DIR=%{buildroot}%{_mandir}/man3
67make install DESTDIR=%{buildroot}
68
69sed -e "s@^%{buildroot}@@g" < %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist > .packlist
70mv -f .packlist %{buildroot}/%{perl_vendorarch}/auto/Net/SSLeay/.packlist
71
72#if [ -f %{buildroot}%{perl_archlib}/perllocal.pod ] ; then
73#    mv %{buildroot}%{perl_archlib}/perllocal.pod .
74#else
75#    touch perllocal.pod
76#fi
77
78perllocalfile=`find %{buildroot} -name perllocal.pod`
79echo "mv $perllocalfile ."
80mv $perllocalfile .
81
82{
83find %{buildroot}  \
84  -type f -o -type l | sed -e "s@^%{buildroot}@@g" -e 's@^\(.*/man/.*\)$@\1*@g'
85} > %{name}.files
86
87%clean
88rm -rf %{buildroot}
89
90#check
91#make test
92
93%files -f %{name}.files
94%defattr(-,root,root)
95%doc Changes Credits QuickRef README COPYRIGHT.SSLeay-0.9.0 perllocal.pod
96#%dir %{perl_vendorarch}/auto/Net
97#%dir %{perl_vendorarch}/auto/Net/SSLeay
98#%dir %{perl_vendorarch}/Net
99#%dir %{perl_vendorarch}/Net/SSLeay
100
101%changelog
102* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.64-1
103- new upstream release.
104- renamed from "perl-Net_SSLeay".
105- added "Obsoletes: perl-Net_SSLeay" and "Provides: perl-Net_SSLeay".
106
107* Sun Feb 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.42-1
108- new upstream release
109
110* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-2
111- rebuild with perl-5.12.3
112
113* Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36-1
114- new upstream release
115- change BuildRequires: openssl-devel instead of openssl
116- add BuildRequires: zlib-devel
117
118* Wed Jul  8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.35-1
119- new upstream release
120
121* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.30-2
122- spec in utf-8
123
124* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-1
125- rebuilt with perl-5.10.0
126- applied new versioning policy
127
128* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl2
129- rebuilt with openssl-0.9.8e
130
131* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.30-0vl1
132- updated to 1.30
133
134* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.25-0vl4
135- installed files to vendor_perl
136- changed Group to Development/Libraries
137
138* Mon Nov 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl3
139- build on perl-5.8.6-0vl1
140
141* Wed Dec 10 2003 IWAI, Masaharu <iwai@alib.jp> 1.25-0vl2
142- build with perl-5.8.2
143- add %%{perl_sitearch}/{Net,Net/SSLeay} directories in %%files
144
145* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.25-0vl1
146- new upstream version
147- built on perl-5.8.1
148
149* Thu May 08 2003 Tomoya TAKA <taka@vinelinux.org> 1.22-0vl5
150- fixed install man dir, again
151
152* Tue May 06 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl4
153- fixed install dir of perllocal.pod
154
155* Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl3
156- fixed install man dir
157
158* Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl2
159- comment out "make test"
160
161* Thu May 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.22-0vl1
162- updated to 1.22
163
164* Fri Feb 15 2002 Toru Sagami <sagami@vinelinux.org> 1.13-0vl1
165- updated to 1.13
166- BuildPreReq/Requires: perl, openssl-0.9.6b
167- rewrite a better spec with License/Group
168
169* Mon Jul 16 2001 <sagami@vinelinux.org>
170- 1.07-0vl3: rebuilt with openssl-0.9.6b
171- erase unneeeded files from %%doc
172- use _prefix, not prefix
173
174* Thu Jul 05 2001 <sagami@vinelinux.org>
175- 1.07-0vl2: built with perl-5.6.1
176
177* Thu Jun  7 2001 Yasuhide OMORI <omori@m-t.com>
178- 1.07
179
180* Fri Sep 1 2000 Yoshishiro Kajiki <kajiki@ylug.org>
181- first version of rpm.
Note: See TracBrowser for help on using the repository browser.