source: projects/specs/trunk/p/perl-Net-SNMP/perl-Net-SNMP-vl.spec @ 8702

Revision 8702, 2.8 KB checked in by tomop, 10 years ago (diff)

updated perl modules.

Line 
1%define pkgname Net-SNMP
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        6.0.1
6Release:        2%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/D/DT/DTOWN/%{pkgname}-v%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Net::SNMP - Object oriented interface to SNMP
18Summary(ja):    Net::SNMP - SNMP へのオブジェクト指向インターフェース
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27The Net::SNMP module implements an object oriented interface to the
28Simple Network Management Protocol.  Perl applications can use the 
29module to retrieve or update information on a remote host using the
30SNMP protocol.  The module supports SNMP version-1, SNMP version-2c
31(Community-Based SNMPv2), and SNMP version-3.  The Net::SNMP module
32assumes that the user has a basic understanding of the Simple Network
33Management Protocol and related network management concepts.
34
35%description -l ja
36Net::SNMP モジュールは、Simple Network Management Protocol へのオブジェクト
37指向インターフェースを実装しています。Perl アプリケーションでこのモジュール
38を利用すれば、 SNMP プロトコルを利用してリモートホストの情報を受信や更新でき
39ます。このモジュールは、SNMP version-1、SNMP version-2c (コミュニティーベー
40ス SNMPv2) および SNMP version-3 をサポートしています。Net::SNMP モジュール
41は、ユーザーが Simple Network Management Protocol および関連するネットワーク
42管理の概念について基本的な理解をもっているものと仮定しています。
43
44%prep
45%setup -q -n Net-SNMP-v6.0.1
46
47%build
48perl Makefile.PL INSTALLDIRS="vendor"
49%{__make}
50
51%install
52%{__rm} -rf ${RPM_BUILD_ROOT}
53%{__make} install DESTDIR=${RPM_BUILD_ROOT}
54
55find $RPM_BUILD_ROOT%{_prefix} -type f -print |
56        sed "s@^$RPM_BUILD_ROOT@@g" |
57        grep -v ^%{_mandir} |
58        grep -v perllocal.pod |
59        grep -v "\.packlist" > %{name}.files
60
61if [ "$(cat %{name}.files)X" = "X" ] ; then
62        echo "ERROR: EMPTY FILE LIST"
63        exit -1
64fi
65
66# remove unnecessary files.
67%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
68find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
69find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
70
71
72%clean
73%{__rm} -rf ${RPM_BUILD_ROOT}
74
75
76%files -f %{name}.files
77%defattr(-,root,root)
78%doc Changes LICENSE README
79
80%changelog
81* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.1-2
82- rebuilt with perl-5.16.3.
83
84* Sat Feb 25 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 6.0.1-1
85- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.