source: projects/specs/trunk/p/perl-Net-DNS/perl-Net-DNS-vl.spec @ 521

Revision 521, 3.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: perl-Net-DNS
2Version: 0.65
3Release: 1%{?_dist_release}
4Summary: Net-DNS module for perl
5License: distributable
6Group: Development/Libraries
7URL: http://search.cpan.org/search?query=Net%3A%3ADNS&mode=module
8Requires: perl >= 0:5.8, perl(Digest::HMAC), perl(Net::IP)
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: perl >= 0:5.8
11BuildRequires: perl(Digest::HMAC), perl(Net::IP), perl(Test::Pod)
12Source0: Net-DNS-%{version}.tar.gz
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
16
17%description
18Net::DNS is a collection of Perl modules that act as a Domain Name
19System (DNS) resolver. It allows the programmer to perform DNS queries
20that are beyond the capabilities of gethostbyname and gethostbyaddr.
21
22The programmer should be somewhat familiar with the format of a DNS
23packet and its various sections. See RFC 1035 or DNS and BIND (Albitz
24& Liu) for details.
25
26# Provide perl-specific find-{provides,requires}.
27%define __find_provides /usr/lib/rpm/find-provides.perl
28%define __find_requires /usr/lib/rpm/find-requires.perl
29
30%prep
31%setup -q -n Net-DNS-%{version}
32
33%build
34CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor < /dev/null
35make
36
37%install
38[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
39
40make DESTDIR=$RPM_BUILD_ROOT install
41
42[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
43
44find ${RPM_BUILD_ROOT}%{_prefix} -type f -print |
45        sed "s@^${RPM_BUILD_ROOT}@@g" |
46        grep -v perllocal.pod |
47        grep -v Win32 |
48        grep -v "\.packlist" > Net-DNS-%{version}-filelist
49if [ "$(cat Net-DNS-%{version}-filelist)X" = "X" ] ; then
50    echo "ERROR: EMPTY FILE LIST"
51    exit -1
52fi
53
54%clean
55[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
56
57%check
58make test
59
60%files -f Net-DNS-%{version}-filelist
61%defattr(-,root,root)
62%doc README TODO
63
64%changelog
65* Thu Mar 14 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
66- 0.65-1
67- new upstream release
68- add BuildRequires perl(Test::Pod) which is needed for test process
69
70* Mon May 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
71- 0.63-3
72- add BuildRequires perl(Net::IP) which is needed for test process
73
74* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.63-2
75- rebuilt with perl-5.10.0
76
77* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
78- 0.63-1
79- new upstream release with security fix (CVE-2007-6341)
80- build under new versioning policy
81
82* Sat Aug 18 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
83- 0.60-0vl3
84- rebuild for VineSeed
85
86* Wed Aug 15 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
87- 0.60-0vl2
88- Build for Vine 4.x (0vl1 is for Vine 3.x)
89- new upstream release with security fixes (CVE-2007-3377, 3409)
90
91* Mon Oct 09 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
92- 0.59-0vl2
93- Build for VineSeed / Vine 4.0
94- changed Group to Development/Languages
95- installs to vendor_arch directory
96
97* Wed Oct 04 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
98- 0.59-0vl1
99- add require tag
100- Build for Vine 3.2
101
102* Thu Aug 16 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
103- 0.53-0vl1
104- Build for Vine 3.1 (was not put)
105
106* Wed Jun 17 2004 Masaru Sato <masachan@mediaship.ne.jp> 0.47-0vl1
107- 1st release for Vine
Note: See TracBrowser for help on using the repository browser.