source: projects/specs/trunk/p/perl-Moose/perl-Moose-vl.spec @ 5864

Revision 5864, 15.7 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Moose
2Summary:        Complete modern object system for Perl 5
3Version:        2.0402
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Moose-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/
9Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
10
11# Class::MOP is now included in Moose itself
12Obsoletes:      perl-Class-MOP <= 1.12-2.fc15
13Obsoletes:      perl-Class-MOP-tests <= 1.12-2.fc15
14
15# configure
16BuildRequires:  perl(Dist::CheckConflicts) >= 0.02
17BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.30
18
19# develop
20BuildRequires:  perl(Algorithm::C3)
21BuildRequires:  perl(DBM::Deep) >= 1.0003
22BuildRequires:  perl(DateTime)
23BuildRequires:  perl(DateTime::Calendar::Mayan)
24BuildRequires:  perl(File::Find::Rule)
25BuildRequires:  perl(HTTP::Headers)
26BuildRequires:  perl(IO::File)
27BuildRequires:  perl(IO::String)
28BuildRequires:  perl(Locale::US)
29BuildRequires:  perl(Module::Info)
30BuildRequires:  perl(PadWalker)
31BuildRequires:  perl(Params::Coerce)
32BuildRequires:  perl(Regexp::Common)
33BuildRequires:  perl(Test::Deep)
34# author test - we almost certainly don't want this in mock!
35#BuildRequires:  perl(Test::DependentModules) >= 0.12
36BuildRequires:  perl(Test::Inline)
37BuildRequires:  perl(Test::LeakTrace)
38BuildRequires:  perl(Test::Output)
39BuildRequires:  perl(Test::Spelling)
40BuildRequires:  perl(URI)
41# not decalared in META.json
42BuildRequires:  perl(Carp)
43BuildRequires:  perl(Carp::Heavy)
44BuildRequires:  perl(SUPER) >= 1.10
45
46# test
47BuildRequires:  perl(Test::Fatal) >= 0.001
48BuildRequires:  perl(Test::More) >= 0.88
49BuildRequires:  perl(Test::Requires) >= 0.05
50BuildRequires:  perl(Declare::Constraints::Simple)
51BuildRequires:  perl(Module::Refresh)
52
53# runtime
54BuildRequires:  perl(Class::Load) >= 0.09
55BuildRequires:  perl(Class::Load::XS) >= 0.01
56BuildRequires:  perl(Data::OptList) >= 0.107
57BuildRequires:  perl(Devel::GlobalDestruction)
58BuildRequires:  perl(Eval::Closure) >= 0.04
59BuildRequires:  perl(List::MoreUtils) >= 0.28
60BuildRequires:  perl(MRO::Compat) >= 0.05
61BuildRequires:  perl(Package::DeprecationManager) >= 0.11
62BuildRequires:  perl(Package::Stash) >= 0.32
63BuildRequires:  perl(Package::Stash::XS) >= 0.24
64BuildRequires:  perl(Params::Util) >= 1.00
65BuildRequires:  perl(Scalar::Util) >= 1.19
66BuildRequires:  perl(Sub::Exporter) >= 0.980
67BuildRequires:  perl(Sub::Name) >= 0.05
68BuildRequires:  perl(Task::Weaken)
69BuildRequires:  perl(Try::Tiny) >= 0.02
70
71
72Requires:       perl(Data::OptList) >= 0.107
73Requires:       perl(Dist::CheckConflicts) >= 0.02
74
75# hidden from PAUSE
76Provides:       perl(Moose::Conflicts)
77Provides:       perl(Moose::Error::Util)
78
79# virtual provides for perl-Any-Moose
80Provides:       perl(Any-Moose) = %{version}
81
82# obsolete/provide old tests subpackage
83# can be removed during F19 development cycle
84Obsoletes:      %{name}-tests < 2.0401-2
85Provides:       %{name}-tests = %{version}-%{release}
86
87%{?perl_default_filter}
88
89%description
90Moose is an extension of the Perl 5 object system.
91
92The main goal of Moose is to make Perl 5 Object Oriented programming easier,
93more consistent and less tedious. With Moose you can to think more about what
94you want to do and less about the mechanics of OOP.
95
96Additionally, Moose is built on top of Class::MOP, which is a metaclass system
97for Perl 5. This means that Moose not only makes building normal Perl 5
98objects better, but it provides the power of metaclass programming as well.
99Moose is different from other Perl 5 object systems because it is not a new
100system, but instead an extension of the existing one.
101
102%package -n perl-Test-Moose
103License:    GPL+ or Artistic
104Group:      Development/Libraries
105Summary:    Test functions for Moose specific features
106Requires:   %{name} = %{version}-%{release}
107
108%description -n perl-Test-Moose
109This module provides some useful test functions for Moose based classes.
110It is an experimental first release, so comments and suggestions are
111very welcome.
112
113%prep
114%setup -q -n Moose-%{version}
115
116# silence rpmlint warnings
117find benchmarks/ -type f -name '*.pl' -print0 \
118  | xargs -0 sed -i '1s,#!.*perl,#!%{__perl},'
119find t/ -type f -name '*.t' -print0 \
120  | xargs -0 sed -i '1s,#!.*perl,#!%{__perl},'
121
122%build
123%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
124make %{?_smp_mflags}
125
126%install
127make pure_install DESTDIR=%{buildroot}
128find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
129find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
130find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
131
132%{_fixperms} %{buildroot}/*
133
134chmod -x benchmarks/*.pl benchmarks/cmop/*.pl
135
136%check
137make test
138
139
140%files
141%doc Changes Changes.Class-MOP LICENSE README TODO doap.rdf
142%doc t/ benchmarks/
143%{perl_vendorarch}/*
144%exclude %dir %{perl_vendorarch}/auto/
145%{_mandir}/man3/*
146%{_bindir}/moose-outdated
147%exclude %{perl_vendorarch}/Test
148%exclude %{_mandir}/man3/Test::Moose*
149
150%files -n perl-Test-Moose
151%{perl_vendorarch}/Test
152%{_mandir}/man3/Test::Moose*
153
154%changelog
155* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0402-1
156- initial build for Vine Linux
157
158* Sun Feb 05 2012 Iain Arnell <iarnell@gmail.com> 2.0402-1
159- update to latest upstream version
160
161* Sun Jan 22 2012 Iain Arnell <iarnell@gmail.com> 2.0401-2
162- drop tests subpackage; move tests to main package documentation
163
164* Thu Jan 12 2012 Iain Arnell <iarnell@gmail.com> 2.0401-1
165- update to latest upstream version
166
167* Sun Oct 09 2011 Iain Arnell <iarnell@gmail.com> 2.0205-2
168- add virtual provides for perl-Any-Moose
169
170* Sat Oct 01 2011 Iain Arnell <iarnell@gmail.com> 2.0205-1
171- update to latest upstream version
172
173* Tue Sep 13 2011 Petr Pisar <ppisar@redhat.com> - 2.0204-2
174- Build-require Carp because Carp dual-lives now (bug #736768)
175
176* Sun Aug 28 2011 Iain Arnell <iarnell@gmail.com> 2.0204-1
177- update to latest upstream version
178- additional build/test dependencies for more testing
179
180* Sat Jul 30 2011 Iain Arnell <iarnell@gmail.com> 2.0202-1
181- update to latest upstream version
182
183* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 2.0010-2
184- Perl mass rebuild
185
186* Sat Jun 25 2011 Iain Arnell <iarnell@gmail.com> 2.0010-1
187- update to latest upstream version
188
189* Fri May 20 2011 Iain Arnell <iarnell@gmail.com> 2.0007-1
190- update to latest upstream version
191
192* Tue May 03 2011 Iain Arnell <iarnell@gmail.com> 2.0002-2
193- drop unnecessary BR perl(Devel::PartialDump)
194
195* Tue May 03 2011 Iain Arnell <iarnell@gmail.com> 2.0002-1
196- update to latest upstream version
197
198* Tue Apr 26 2011 Iain Arnell <iarnell@gmail.com> 2.0001-3
199- add explicit perl(Dist::CheckConflicts) requirement
200
201* Sat Apr 23 2011 Iain Arnell <iarnell@gmail.com> 2.0001-2
202- obsolete perl-Class-MOP-tests too
203
204* Sat Apr 23 2011 Iain Arnell <iarnell@gmail.com> 2.0001-1
205- update to latest upstream version
206
207* Fri Apr 22 2011 Iain Arnell <iarnell@gmail.com> 2.00-1
208- update to latest upstream version
209- regenerate BuildRequires from META.json
210- obsoletes perl-Class-MOP (now incluced in Moose itself)
211- clean up spec for modern rpmbuild
212
213* Sun Apr 03 2011 Iain Arnell <iarnell@gmail.com> 1.25-1
214- update to latest upstream version
215
216* Sat Mar 05 2011 Iain Arnell <iarnell@gmail.com> 1.24-1
217- update to latest upstream version
218
219* Thu Feb 17 2011 Iain Arnell <iarnell@gmail.com> 1.23-1
220- update to latest upstream version
221
222* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.21-2
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
224
225* Mon Jan 24 2011 Iain Arnell <iarnell@gmail.com> 1.21-1
226- update to latest upstream version
227- update R/BR perl(Class::MOP) >= 1.11
228- update R/BR perl(Params::Util) >= 1.00
229- update R/BR perl(Package::DeprecationManager) >= 0.10
230- new BR perl(Test::Fatal) >= 0.001
231- drop old BR perl(Test::Exception)
232
233* Sat Oct 09 2010 Iain Arnell <iarnell@gmail.com> 1.15-1
234- update to latest upstream version
235- update BR perl(Class::MOP) >= 1.09
236- new BR perl(Params:Util)
237
238* Tue Oct 05 2010 Iain Arnell <iarnell@gmail.com> 1.14-1
239- update to latest upstream version
240- update BR perl(Class:MOP) >= 1.05
241- new BR perl(Test::Requires) >= 0.05
242- new R/BR perl(Package::DeprecationManager) >= 0.04
243
244* Sat Jul 03 2010 Iain Arnell <iarnell@gmail.com> 1.08-1
245- update to latest upstream
246- update BR perl(Class:MOP) >= 1.02
247
248* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.03-1
249- update
250
251* Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.02-1
252- Mass rebuild with perl-5.12.0
253- switch off tests for meantime, needs Class::ISA
254
255* Fri Apr 30 2010 Marclea Mašláňová <mmaslano@redhat.com> 1.01-1
256- update
257
258* Fri Mar 12 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.99-1
259- update by Fedora::App::MaintainerTools 0.006
260- updating to latest GA CPAN version (0.99)
261
262* Sat Feb 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.98-1
263- update by Fedora::App::MaintainerTools 0.003
264
265* Sat Feb 13 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.96-1
266- auto-update by cpan-spec-update 0.002
267- dropped old BR on perl(UNIVERSAL::require)
268- dropped old BR on perl(Sub::Install)
269- dropped old BR on perl(Test::LongString)
270- dropped old BR on perl(Filter::Simple)
271
272* Fri Feb 05 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-3
273- PERL_INSTALL_ROOT => DESTDIR
274- add perl_default_subpackage_tests
275- properly exclude vendorarch/auto/ directory
276- add br on DateTime::Calendar::Mayan
277
278* Wed Jan 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-2
279- we're not noarch anymore :)
280
281* Wed Jan 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-1
282- auto-update to 0.94 (by cpan-spec-update 0.01)
283- altered br on perl(Class::MOP) (0.94 => 0.98)
284- altered req on perl(Class::MOP) (0.94 => 0.98)
285
286* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.92-2
287- rebuild against perl 5.10.1
288
289* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.92-1
290- auto-update to 0.92 (by cpan-spec-update 0.01)
291- altered br on perl(Class::MOP) (0.93 => 0.94)
292- altered req on perl(Class::MOP) (0.93 => 0.94)
293
294* Fri Sep 18 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.90-1
295- switch filtering systems...
296- auto-update to 0.90 (by cpan-spec-update 0.01)
297- altered br on perl(Class::MOP) (0.92 => 0.93)
298- altered br on perl(Test::More) (0.77 => 0.88)
299- added a new br on perl(Try::Tiny) (version 0.02)
300- altered req on perl(Class::MOP) (0.92 => 0.93)
301- added a new req on perl(Try::Tiny) (version 0.02)
302
303* Wed Aug 19 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.89-1
304- auto-update to 0.89 (by cpan-spec-update 0.01)
305- altered br on perl(Class::MOP) (0.89 => 0.92)
306- altered req on perl(Class::MOP) (0.89 => 0.92)
307
308* Mon Jul 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.88-1
309- auto-update to 0.88 (by cpan-spec-update 0.01)
310- altered br on perl(Class::MOP) (0.85 => 0.89)
311- altered br on perl(Sub::Exporter) (0.972 => 0.980)
312- added a new req on perl(Carp) (version 0)
313- added a new req on perl(Class::MOP) (version 0.89)
314- added a new req on perl(Data::OptList) (version 0)
315- added a new req on perl(List::MoreUtils) (version 0.12)
316- added a new req on perl(Scalar::Util) (version 1.19)
317- added a new req on perl(Sub::Exporter) (version 0.980)
318- added a new req on perl(Sub::Name) (version 0)
319- added a new req on perl(Task::Weaken) (version 0)
320
321* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.81-3
322- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
323
324* Mon Jun 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.81-2
325- split off Test::Moose
326
327* Tue Jun 09 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.81-1
328- auto-update to 0.81 (by cpan-spec-update 0.01)
329- altered br on perl(Class::MOP) (0.83 => 0.85)
330
331* Sun Jun 07 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.80-1
332- auto-update to 0.80 (by cpan-spec-update 0.01)
333
334* Tue May 19 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.79-1
335- auto-update to 0.79 (by cpan-spec-update 0.01)
336
337* Wed May 13 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.78-1
338- auto-update to 0.78 (by cpan-spec-update 0.01)
339- altered br on perl(Test::Exception) (0.21 => 0.27)
340- altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
341- added a new br on perl(Sub::Name) (version 0)
342- altered br on perl(Class::MOP) (0.81 => 0.83)
343- altered br on perl(Sub::Exporter) (0.954 => 0.972)
344- added a new br on perl(Carp) (version 0)
345
346* Mon May 04 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.74-2
347- switch filtering to a cleaner system
348
349* Sat Apr 18 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.74-1
350- update to 0.74
351
352* Wed Apr 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.73-1
353- update to 0.73
354
355* Sun Mar 08 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.72-1
356- update to 0.72
357
358* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.71-2
359- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
360
361* Sun Feb 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.71-1
362- update to 0.71
363
364* Sun Jan 04 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.64-1
365- update to 0.64
366
367* Sun Dec 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.63-1
368- update to 0.63
369- bump br versions on Moose, List::MoreUtils
370
371* Sat Dec 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.62-1
372- update to 0.62
373- new Task::Weaken and Class::MOP requirements
374
375* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-4
376- aaaand drop them again, as it was really perl-Class-MOP's issue.
377
378* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-3
379- same with Devel::GlobalDestruction (same RT as below)
380
381* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-2
382- add Sub::Name as a build dep (RT#40772)
383
384* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-1
385- update to 0.61
386- update BR's
387
388* Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.57-2
389- add additional test BR's
390
391* Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.57-1
392- update to 0.57
393
394* Fri Jul 18 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.54-1
395- update to 0.54
396
397* Sat Jun 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.51-1
398- update to 0.51
399
400* Tue Jun 17 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.50-1
401- update to 0.50
402- drop obviated test patch
403
404* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.44-2
405- bump
406
407* Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.44-1
408- update to 0.44
409
410* Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.33-3
411- rebuild for new perl
412
413* Mon Jan 07 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.33-2
414- remove *.orig files from t/ (BZ#427754)
415
416* Sat Dec 15 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.33-1
417- update to 0.33
418
419* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.32-1
420- update to 0.32
421
422* Sun Nov 25 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.30-1
423- update to 0.30
424
425* Sat Nov 17 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.29-1
426- update to 0.29
427- refactor to Module::Install
428
429* Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.26-1
430- udpate to 0.26
431
432* Sat Aug 11 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.24-1
433- update to 0.24
434- license tag: GPL -> GPL+
435- patch t/202_...t to write to a tmpdir rather than .
436
437* Thu May 31 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.22-1
438- update to 0.22
439
440* Fri May 04 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.21-1
441- update to 0.21
442
443* Tue May 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.20-2
444- add t/ to %%doc
445- add br for optional test #7
446
447* Sat Apr 07 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.20-1
448- update to 0.20
449- add additional BR's for new optional tests
450
451* Fri Mar 23 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
452- Sub::Name only needed as a br for Moose < 0.18
453- update to 0.18
454
455* Thu Nov 16 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.17-2
456- add IO::File and IO::String to br's for testing
457
458* Thu Nov 16 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
459- update to 0.17
460
461* Mon Nov 06 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.15-1
462- update to 0.15
463
464* Tue Oct 10 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.14-1
465- update to 0.14
466- drop some cruft from the specfile
467- make %%description a touch more verbose :)
468
469* Tue Oct 03 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.13-1
470- update to 0.13
471
472* Fri Sep 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.12-2
473- bump
474
475* Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.12-1
476- Specfile autogenerated by cpanspec 1.69.1.
Note: See TracBrowser for help on using the repository browser.