source: projects/specs/trunk/p/perl-Moose/perl-Moose-vl.spec @ 9187

Revision 9187, 16.0 KB checked in by inagaki, 9 years ago (diff)

2014-12-23 Ryoichi INAGAKI <ryo1@…>

  • perl-CGI-FormBuilder?, perl-Devel-{EnforceEncapsulation?, GlobalDestruction?}, perl-Moose, perl-Net-{Pcap, Radius, Telnet, Write}, perl-Template-Toolkit, perl-Text-Unidecode, perl-XML-RSS: updated
  • perl-CGI-SSI, perl-Geography-Countries, perl-MIME-Lite-TT, perl-MP3-Info, perl-Text-Glob: rebuilt
  • perl-Sub-Exporter-Progressive: new


Line 
1Name:           perl-Moose
2Summary:        Complete modern object system for Perl 5
3Version:        2.0604
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/
8
9Source0:        http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Moose-%{version}.tar.gz
10# Vine patch
11Patch100:       perl-Moose-2.0604-test-methods.patch     
12
13Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14
15# Class::MOP is now included in Moose itself
16Obsoletes:      perl-Class-MOP <= 1.12-2.fc15
17Obsoletes:      perl-Class-MOP-tests <= 1.12-2.fc15
18
19# configure
20BuildRequires:  perl(Dist::CheckConflicts) >= 0.02
21BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.30
22
23# develop
24BuildRequires:  perl(Algorithm::C3)
25BuildRequires:  perl(DBM::Deep) >= 1.0003
26BuildRequires:  perl(DateTime)
27BuildRequires:  perl(DateTime::Calendar::Mayan)
28BuildRequires:  perl(File::Find::Rule)
29BuildRequires:  perl(HTTP::Headers)
30BuildRequires:  perl(IO::File)
31BuildRequires:  perl(IO::String)
32BuildRequires:  perl(Locale::US)
33BuildRequires:  perl(Module::Info)
34BuildRequires:  perl(PadWalker)
35BuildRequires:  perl(Params::Coerce)
36BuildRequires:  perl(Regexp::Common)
37BuildRequires:  perl(Test::Deep)
38# author test - we almost certainly don't want this in mock!
39#BuildRequires:  perl(Test::DependentModules) >= 0.12
40BuildRequires:  perl(Test::Inline)
41BuildRequires:  perl(Test::LeakTrace)
42BuildRequires:  perl(Test::Output)
43BuildRequires:  perl(Test::Spelling)
44BuildRequires:  perl(URI)
45# not decalared in META.json
46BuildRequires:  perl(Carp)
47BuildRequires:  perl(Carp::Heavy)
48BuildRequires:  perl(SUPER) >= 1.10
49
50# test
51BuildRequires:  perl(Test::Fatal) >= 0.001
52BuildRequires:  perl(Test::More) >= 0.88
53BuildRequires:  perl(Test::Requires) >= 0.05
54BuildRequires:  perl(Declare::Constraints::Simple)
55BuildRequires:  perl(Module::Refresh)
56
57# runtime
58BuildRequires:  perl(Class::Load) >= 0.09
59BuildRequires:  perl(Class::Load::XS) >= 0.01
60BuildRequires:  perl(Data::OptList) >= 0.107
61BuildRequires:  perl(Devel::GlobalDestruction)
62BuildRequires:  perl(Eval::Closure) >= 0.04
63BuildRequires:  perl(List::MoreUtils) >= 0.28
64BuildRequires:  perl(MRO::Compat) >= 0.05
65BuildRequires:  perl(Package::DeprecationManager) >= 0.11
66BuildRequires:  perl(Package::Stash) >= 0.32
67BuildRequires:  perl(Package::Stash::XS) >= 0.24
68BuildRequires:  perl(Params::Util) >= 1.00
69BuildRequires:  perl(Scalar::Util) >= 1.19
70BuildRequires:  perl(Sub::Exporter) >= 0.980
71BuildRequires:  perl(Sub::Name) >= 0.05
72BuildRequires:  perl(Task::Weaken)
73BuildRequires:  perl(Try::Tiny) >= 0.02
74
75Requires:       perl(Data::OptList) >= 0.107
76Requires:       perl(Dist::CheckConflicts) >= 0.02
77
78# hidden from PAUSE
79Provides:       perl(Moose::Conflicts)
80Provides:       perl(Moose::Error::Util)
81
82# virtual provides for perl-Any-Moose
83Provides:       perl(Any-Moose) = %{version}
84
85# obsolete/provide old tests subpackage
86# can be removed during F19 development cycle
87Obsoletes:      %{name}-tests < 2.0401-2
88Provides:       %{name}-tests = %{version}-%{release}
89
90%{?perl_default_filter}
91
92%description
93Moose is an extension of the Perl 5 object system.
94
95The main goal of Moose is to make Perl 5 Object Oriented programming easier,
96more consistent and less tedious. With Moose you can to think more about what
97you want to do and less about the mechanics of OOP.
98
99Additionally, Moose is built on top of Class::MOP, which is a metaclass system
100for Perl 5. This means that Moose not only makes building normal Perl 5
101objects better, but it provides the power of metaclass programming as well.
102Moose is different from other Perl 5 object systems because it is not a new
103system, but instead an extension of the existing one.
104
105%package -n perl-Test-Moose
106License:    GPL+ or Artistic
107Group:      Development/Libraries
108Summary:    Test functions for Moose specific features
109Requires:   %{name} = %{version}-%{release}
110
111%description -n perl-Test-Moose
112This module provides some useful test functions for Moose based classes.
113It is an experimental first release, so comments and suggestions are
114very welcome.
115
116%prep
117%setup -q -n Moose-%{version}
118%patch100 -p1
119
120# silence rpmlint warnings
121find benchmarks/ -type f -name '*.pl' -print0 \
122  | xargs -0 sed -i '1s,#!.*perl,#!%{__perl},'
123find t/ -type f -name '*.t' -print0 \
124  | xargs -0 sed -i '1s,#!.*perl,#!%{__perl},'
125
126%build
127%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
128make %{?_smp_mflags}
129
130%install
131make pure_install DESTDIR=%{buildroot}
132find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
133find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
134find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
135
136%{_fixperms} %{buildroot}/*
137
138chmod -x benchmarks/*.pl benchmarks/cmop/*.pl
139
140%check
141make test
142
143
144%files
145%doc Changes Changes.Class-MOP LICENSE README TODO doap.rdf
146%doc t/ benchmarks/
147%{perl_vendorarch}/*
148%exclude %dir %{perl_vendorarch}/auto/
149%{_mandir}/man3/*
150%{_bindir}/moose-outdated
151%exclude %{perl_vendorarch}/Test
152%exclude %{_mandir}/man3/Test::Moose*
153
154%files -n perl-Test-Moose
155%{perl_vendorarch}/Test
156%{_mandir}/man3/Test::Moose*
157
158%changelog
159* Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0604-1
160- updated to 2.0604
161- added Patch100 to build with current perl-Package-Stash
162- built with perl 5.16.3
163
164* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0402-1
165- initial build for Vine Linux
166
167* Sun Feb 05 2012 Iain Arnell <iarnell@gmail.com> 2.0402-1
168- update to latest upstream version
169
170* Sun Jan 22 2012 Iain Arnell <iarnell@gmail.com> 2.0401-2
171- drop tests subpackage; move tests to main package documentation
172
173* Thu Jan 12 2012 Iain Arnell <iarnell@gmail.com> 2.0401-1
174- update to latest upstream version
175
176* Sun Oct 09 2011 Iain Arnell <iarnell@gmail.com> 2.0205-2
177- add virtual provides for perl-Any-Moose
178
179* Sat Oct 01 2011 Iain Arnell <iarnell@gmail.com> 2.0205-1
180- update to latest upstream version
181
182* Tue Sep 13 2011 Petr Pisar <ppisar@redhat.com> - 2.0204-2
183- Build-require Carp because Carp dual-lives now (bug #736768)
184
185* Sun Aug 28 2011 Iain Arnell <iarnell@gmail.com> 2.0204-1
186- update to latest upstream version
187- additional build/test dependencies for more testing
188
189* Sat Jul 30 2011 Iain Arnell <iarnell@gmail.com> 2.0202-1
190- update to latest upstream version
191
192* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 2.0010-2
193- Perl mass rebuild
194
195* Sat Jun 25 2011 Iain Arnell <iarnell@gmail.com> 2.0010-1
196- update to latest upstream version
197
198* Fri May 20 2011 Iain Arnell <iarnell@gmail.com> 2.0007-1
199- update to latest upstream version
200
201* Tue May 03 2011 Iain Arnell <iarnell@gmail.com> 2.0002-2
202- drop unnecessary BR perl(Devel::PartialDump)
203
204* Tue May 03 2011 Iain Arnell <iarnell@gmail.com> 2.0002-1
205- update to latest upstream version
206
207* Tue Apr 26 2011 Iain Arnell <iarnell@gmail.com> 2.0001-3
208- add explicit perl(Dist::CheckConflicts) requirement
209
210* Sat Apr 23 2011 Iain Arnell <iarnell@gmail.com> 2.0001-2
211- obsolete perl-Class-MOP-tests too
212
213* Sat Apr 23 2011 Iain Arnell <iarnell@gmail.com> 2.0001-1
214- update to latest upstream version
215
216* Fri Apr 22 2011 Iain Arnell <iarnell@gmail.com> 2.00-1
217- update to latest upstream version
218- regenerate BuildRequires from META.json
219- obsoletes perl-Class-MOP (now incluced in Moose itself)
220- clean up spec for modern rpmbuild
221
222* Sun Apr 03 2011 Iain Arnell <iarnell@gmail.com> 1.25-1
223- update to latest upstream version
224
225* Sat Mar 05 2011 Iain Arnell <iarnell@gmail.com> 1.24-1
226- update to latest upstream version
227
228* Thu Feb 17 2011 Iain Arnell <iarnell@gmail.com> 1.23-1
229- update to latest upstream version
230
231* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.21-2
232- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
233
234* Mon Jan 24 2011 Iain Arnell <iarnell@gmail.com> 1.21-1
235- update to latest upstream version
236- update R/BR perl(Class::MOP) >= 1.11
237- update R/BR perl(Params::Util) >= 1.00
238- update R/BR perl(Package::DeprecationManager) >= 0.10
239- new BR perl(Test::Fatal) >= 0.001
240- drop old BR perl(Test::Exception)
241
242* Sat Oct 09 2010 Iain Arnell <iarnell@gmail.com> 1.15-1
243- update to latest upstream version
244- update BR perl(Class::MOP) >= 1.09
245- new BR perl(Params:Util)
246
247* Tue Oct 05 2010 Iain Arnell <iarnell@gmail.com> 1.14-1
248- update to latest upstream version
249- update BR perl(Class:MOP) >= 1.05
250- new BR perl(Test::Requires) >= 0.05
251- new R/BR perl(Package::DeprecationManager) >= 0.04
252
253* Sat Jul 03 2010 Iain Arnell <iarnell@gmail.com> 1.08-1
254- update to latest upstream
255- update BR perl(Class:MOP) >= 1.02
256
257* Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.03-1
258- update
259
260* Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.02-1
261- Mass rebuild with perl-5.12.0
262- switch off tests for meantime, needs Class::ISA
263
264* Fri Apr 30 2010 Marclea Mašláňová <mmaslano@redhat.com> 1.01-1
265- update
266
267* Fri Mar 12 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.99-1
268- update by Fedora::App::MaintainerTools 0.006
269- updating to latest GA CPAN version (0.99)
270
271* Sat Feb 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.98-1
272- update by Fedora::App::MaintainerTools 0.003
273
274* Sat Feb 13 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.96-1
275- auto-update by cpan-spec-update 0.002
276- dropped old BR on perl(UNIVERSAL::require)
277- dropped old BR on perl(Sub::Install)
278- dropped old BR on perl(Test::LongString)
279- dropped old BR on perl(Filter::Simple)
280
281* Fri Feb 05 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-3
282- PERL_INSTALL_ROOT => DESTDIR
283- add perl_default_subpackage_tests
284- properly exclude vendorarch/auto/ directory
285- add br on DateTime::Calendar::Mayan
286
287* Wed Jan 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-2
288- we're not noarch anymore :)
289
290* Wed Jan 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-1
291- auto-update to 0.94 (by cpan-spec-update 0.01)
292- altered br on perl(Class::MOP) (0.94 => 0.98)
293- altered req on perl(Class::MOP) (0.94 => 0.98)
294
295* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.92-2
296- rebuild against perl 5.10.1
297
298* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.92-1
299- auto-update to 0.92 (by cpan-spec-update 0.01)
300- altered br on perl(Class::MOP) (0.93 => 0.94)
301- altered req on perl(Class::MOP) (0.93 => 0.94)
302
303* Fri Sep 18 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.90-1
304- switch filtering systems...
305- auto-update to 0.90 (by cpan-spec-update 0.01)
306- altered br on perl(Class::MOP) (0.92 => 0.93)
307- altered br on perl(Test::More) (0.77 => 0.88)
308- added a new br on perl(Try::Tiny) (version 0.02)
309- altered req on perl(Class::MOP) (0.92 => 0.93)
310- added a new req on perl(Try::Tiny) (version 0.02)
311
312* Wed Aug 19 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.89-1
313- auto-update to 0.89 (by cpan-spec-update 0.01)
314- altered br on perl(Class::MOP) (0.89 => 0.92)
315- altered req on perl(Class::MOP) (0.89 => 0.92)
316
317* Mon Jul 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.88-1
318- auto-update to 0.88 (by cpan-spec-update 0.01)
319- altered br on perl(Class::MOP) (0.85 => 0.89)
320- altered br on perl(Sub::Exporter) (0.972 => 0.980)
321- added a new req on perl(Carp) (version 0)
322- added a new req on perl(Class::MOP) (version 0.89)
323- added a new req on perl(Data::OptList) (version 0)
324- added a new req on perl(List::MoreUtils) (version 0.12)
325- added a new req on perl(Scalar::Util) (version 1.19)
326- added a new req on perl(Sub::Exporter) (version 0.980)
327- added a new req on perl(Sub::Name) (version 0)
328- added a new req on perl(Task::Weaken) (version 0)
329
330* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.81-3
331- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
332
333* Mon Jun 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.81-2
334- split off Test::Moose
335
336* Tue Jun 09 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.81-1
337- auto-update to 0.81 (by cpan-spec-update 0.01)
338- altered br on perl(Class::MOP) (0.83 => 0.85)
339
340* Sun Jun 07 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.80-1
341- auto-update to 0.80 (by cpan-spec-update 0.01)
342
343* Tue May 19 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.79-1
344- auto-update to 0.79 (by cpan-spec-update 0.01)
345
346* Wed May 13 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.78-1
347- auto-update to 0.78 (by cpan-spec-update 0.01)
348- altered br on perl(Test::Exception) (0.21 => 0.27)
349- altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
350- added a new br on perl(Sub::Name) (version 0)
351- altered br on perl(Class::MOP) (0.81 => 0.83)
352- altered br on perl(Sub::Exporter) (0.954 => 0.972)
353- added a new br on perl(Carp) (version 0)
354
355* Mon May 04 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.74-2
356- switch filtering to a cleaner system
357
358* Sat Apr 18 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.74-1
359- update to 0.74
360
361* Wed Apr 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.73-1
362- update to 0.73
363
364* Sun Mar 08 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.72-1
365- update to 0.72
366
367* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.71-2
368- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
369
370* Sun Feb 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.71-1
371- update to 0.71
372
373* Sun Jan 04 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.64-1
374- update to 0.64
375
376* Sun Dec 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.63-1
377- update to 0.63
378- bump br versions on Moose, List::MoreUtils
379
380* Sat Dec 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.62-1
381- update to 0.62
382- new Task::Weaken and Class::MOP requirements
383
384* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-4
385- aaaand drop them again, as it was really perl-Class-MOP's issue.
386
387* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-3
388- same with Devel::GlobalDestruction (same RT as below)
389
390* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-2
391- add Sub::Name as a build dep (RT#40772)
392
393* Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-1
394- update to 0.61
395- update BR's
396
397* Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.57-2
398- add additional test BR's
399
400* Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.57-1
401- update to 0.57
402
403* Fri Jul 18 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.54-1
404- update to 0.54
405
406* Sat Jun 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.51-1
407- update to 0.51
408
409* Tue Jun 17 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.50-1
410- update to 0.50
411- drop obviated test patch
412
413* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.44-2
414- bump
415
416* Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.44-1
417- update to 0.44
418
419* Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.33-3
420- rebuild for new perl
421
422* Mon Jan 07 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.33-2
423- remove *.orig files from t/ (BZ#427754)
424
425* Sat Dec 15 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.33-1
426- update to 0.33
427
428* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.32-1
429- update to 0.32
430
431* Sun Nov 25 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.30-1
432- update to 0.30
433
434* Sat Nov 17 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.29-1
435- update to 0.29
436- refactor to Module::Install
437
438* Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.26-1
439- udpate to 0.26
440
441* Sat Aug 11 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.24-1
442- update to 0.24
443- license tag: GPL -> GPL+
444- patch t/202_...t to write to a tmpdir rather than .
445
446* Thu May 31 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.22-1
447- update to 0.22
448
449* Fri May 04 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.21-1
450- update to 0.21
451
452* Tue May 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.20-2
453- add t/ to %%doc
454- add br for optional test #7
455
456* Sat Apr 07 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.20-1
457- update to 0.20
458- add additional BR's for new optional tests
459
460* Fri Mar 23 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
461- Sub::Name only needed as a br for Moose < 0.18
462- update to 0.18
463
464* Thu Nov 16 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.17-2
465- add IO::File and IO::String to br's for testing
466
467* Thu Nov 16 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
468- update to 0.17
469
470* Mon Nov 06 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.15-1
471- update to 0.15
472
473* Tue Oct 10 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.14-1
474- update to 0.14
475- drop some cruft from the specfile
476- make %%description a touch more verbose :)
477
478* Tue Oct 03 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.13-1
479- update to 0.13
480
481* Fri Sep 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.12-2
482- bump
483
484* Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.12-1
485- Specfile autogenerated by cpanspec 1.69.1.
Note: See TracBrowser for help on using the repository browser.