source: projects/specs/trunk/p/perl-Module-Signature/perl-Module-Signature-vl.spec @ 9315

Revision 9315, 8.8 KB checked in by inagaki, 9 years ago (diff)

2015-01-31 Ryoichi INAGAKI <ryo1@…>

  • perl-Date-Time-Format-ISO8601, perl-IO-SessionData?, perl-Module-Signature, perl-Net-UPnP, perl-Params-Classify, perl-SOAP-Lite, perl-Test-Distribution: <requests:2508>
Line 
1Name:           perl-Module-Signature
2Version:        0.73
3Release:        6%{?_dist_release}
4Summary:        CPAN signature management utilities and modules
5Summary(ja):    CPAN の署名管理ツール及び perl モジュール
6
7Group:          Development/Libraries
8License:        CC0
9URL:            http://search.cpan.org/dist/Module-Signature/
10Source0:        http://search.cpan.org/CPAN/authors/id/A/AU/AUDREYT/Module-Signature-%{version}.tar.gz
11Source1:        AKOENIG.pub
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildArch:      noarch
15# Module build
16BuildRequires:  perl(base)
17BuildRequires:  perl(Cwd)
18BuildRequires:  perl(ExtUtils::MakeMaker)
19# Module runtime
20BuildRequires:  gnupg
21BuildRequires:  perl(constant)
22BuildRequires:  perl(Digest::SHA)
23BuildRequires:  perl(Digest::SHA1)
24BuildRequires:  perl(Exporter)
25BuildRequires:  perl(ExtUtils::Manifest)
26BuildRequires:  perl(File::Spec)
27BuildRequires:  perl(IO::Socket::INET)
28BuildRequires:  perl(Text::Diff)
29# Test suite
30BuildRequires:  perl(Data::Dumper)
31BuildRequires:  perl(File::Path)
32BuildRequires:  perl(Getopt::Long)
33BuildRequires:  perl(IPC::Run)
34BuildRequires:  perl(lib)
35BuildRequires:  perl(Pod::Usage)
36BuildRequires:  perl(Test::More)
37# Module runtime
38Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
39Requires:       gnupg
40Requires:       perl(Digest::SHA)
41Requires:       perl(Digest::SHA1)
42Requires:       perl(IO::Socket::INET)
43Requires:       perl(PAR::Dist)
44Requires:       perl(Text::Diff)
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48
49%description
50This package contains a command line tool and module for checking and creating
51SIGNATURE files for Perl CPAN distributions.
52
53%prep
54%setup -q -c -n Module-Signature
55
56# Copy up documentation for convenience with %%doc
57cp -a Module-Signature-%{version}/{AUTHORS,Changes,README,*.pub} .
58
59# Create a GPG directory for testing, to avoid using ~/.gnupg
60mkdir --mode=0700 gnupghome
61
62# Import AKOENIG key so we don't try to download it later
63export GNUPGHOME=$(pwd)/gnupghome
64gpg --import %{SOURCE1}
65
66%build
67export GNUPGHOME=$(pwd)/gnupghome
68cd Module-Signature-%{version}
69perl Makefile.PL INSTALLDIRS=vendor --skipdeps </dev/null
70make %{?_smp_mflags}
71cd -
72
73%install
74rm -rf %{buildroot}
75make -C Module-Signature-%{version} pure_install DESTDIR=%{buildroot}
76find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
77%{_fixperms} %{buildroot}
78
79%check
80export GNUPGHOME=$(pwd)/gnupghome
81make -C Module-Signature-%{version} test TEST_SIGNATURE=1
82
83%clean
84rm -rf %{buildroot}
85
86%files
87%doc AUTHORS Changes README *.pub
88%{_bindir}/cpansign
89%{perl_vendorlib}/Module/
90%{_mandir}/man1/cpansign.1*
91%{_mandir}/man3/Module::Signature.3pm*
92
93%changelog
94* Sat Jan 31 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.73-6
95- Initial build for Vine Linux
96
97* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.73-5
98- Perl 5.20 rebuild
99
100* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.73-4
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
102
103* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.73-3
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
105
106* Thu Jul 18 2013 Petr Pisar <ppisar@redhat.com> - 0.73-2
107- Perl 5.18 rebuild
108
109* Fri Jun  7 2013 Paul Howarth <paul@city-fan.org> - 0.73-1
110- Update to 0.73
111  - Constrain the user-specified digest name to /^\w+\d+$/
112  - Only allow loading Digest::* from absolute paths in @INC (CVE-2013-2145)
113
114* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.70-2
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
116
117* Wed Nov 28 2012 Paul Howarth <paul@city-fan.org> - 0.70-1
118- Update to 0.70
119  - Don't check gpg version if gpg does not exist
120
121* Fri Nov  2 2012 Paul Howarth <paul@city-fan.org> - 0.69-1
122- Update to 0.69
123  - Support for gpg under these alternate names: gpg gpg2 gnupg gnupg2
124- This release by AUDREYT -> update source URL
125- BR:/R: perl(Text::Diff)
126- Include Andreas Koenig's GPG key in the SRPM and import it in %%prep so
127  that we don't need to get it from a keyserver in %%check
128
129* Thu Nov  1 2012 Petr Pisar <ppisar@redhat.com> - 0.68-7
130- Make building non-interactive
131- Specify all dependencies
132
133* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.68-6
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
135
136* Tue Jun 12 2012 Paul Howarth <paul@city-fan.org> - 0.68-5
137- BR: perl(constant), perl(Data::Dumper) and perl(lib)
138- Don't need to remove empty directories from the buildroot
139- Drop %%defattr, redundant since rpm 4.4
140
141* Tue Jun 12 2012 Petr Pisar <ppisar@redhat.com> - 0.68-4
142- Perl 5.16 rebuild
143
144* Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.68-3
145- BR: perl(Exporter) and perl(ExtUtils::Manifest)
146- Use %%{_fixperms} macro rather than our own chmod incantation
147
148* Fri Jun 24 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.68-2
149- Perl mass rebuild
150
151* Fri May 13 2011 Paul Howarth <paul@city-fan.org> - 0.68-1
152- Update to 0.68
153  - Fix breakage introduced by 0.67 (CPAN RT#68150)
154
155* Thu Apr 21 2011 Paul Howarth <paul@city-fan.org> - 0.67-3
156- Pseudo-merge EPEL-5/EPEL-6/Fedora versions
157
158* Tue Apr 19 2011 Ville Skyttä <ville.skytta@iki.fi> - 0.67-2
159- Appease rpmbuild >= 4.9
160
161* Tue Apr 19 2011 Ville Skyttä <ville.skytta@iki.fi> - 0.67-1
162- Update to 0.67
163
164* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
166
167* Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.66-2
168- Rebuild to fix problems with vendorarch/lib (#661697)
169
170* Tue Sep  7 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.66-1
171- Update to 0.66 (#630714)
172
173* Tue Sep  7 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.65-1
174- Update to 0.65 (#630714)
175
176* Wed Jun 30 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.64-2
177- Rebuild
178
179* Sun May  9 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.64-1
180- Update to 0.64 (#590385)
181
182* Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.63-2
183- Mass rebuild with perl-5.12.0
184
185* Fri Apr 23 2010 Ville Skyttä <ville.skytta@iki.fi> - 0.63-1
186- Update to 0.63
187- Sync with current rpmdevtools spec template
188
189* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.61-2
190- Rebuild against perl 5.10.1
191
192* Thu Nov 19 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.61-1
193- Update to 0.61 (#538780)
194
195* Tue Nov 17 2009 Ville Skyttä <ville.skytta@iki.fi> - 0.60-1
196- Update to 0.60 (#538043); license changed from MIT to CC0
197
198* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.55-5
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
200
201* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.55-4
202- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
203
204* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.55-3
205- Rebuild for new perl
206
207* Tue Apr 17 2007 Ville Skyttä <ville.skytta@iki.fi> - 0.55-2
208- BuildRequire perl(ExtUtils::MakeMaker) and perl(Test::More)
209
210* Tue Aug 22 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.55-1
211- 0.55
212- Make PAR::Dist dependency a Requires(hint)
213
214* Fri May 12 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.54-1
215- 0.54, license changed to MIT
216
217* Wed Feb  1 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.53-1
218- 0.53
219
220* Fri Jan 20 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.52-1
221- 0.52
222- Run non-live tests during build and make live ones optional, enabled
223  when building with "--with livetests"
224
225* Mon Jan  2 2006 Ville Skyttä <ville.skytta@iki.fi> - 0.51-1
226- 0.51
227
228* Mon Aug 22 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.50-1
229- 0.50
230
231* Wed Aug 10 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.45-1
232- 0.45
233
234* Thu Apr  7 2005 Ville Skyttä <ville.skytta@iki.fi> - 0.44-2
235- Drop Epoch: 0 and 0.fdr. release prefix
236
237* Fri Dec 17 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.44-0.fdr.1
238- Update to 0.44
239
240* Sun Nov 21 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.42-0.fdr.1
241- Update to 0.42
242
243* Tue Jul  6 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.41-0.fdr.2
244- Require perl(Digest::SHA1) (bug 1606)
245
246* Mon Jul  5 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.41-0.fdr.1
247- Update to 0.41
248
249* Fri Jul  2 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.40-0.fdr.1
250- Update to 0.40
251
252* Fri Jun 18 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.39-0.fdr.1
253- Update to 0.39
254
255* Mon May 31 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.38-0.fdr.4
256- Really use pure_install (bug 1606)
257- Fix build with older mktemp versions which require a template (bug 1606)
258
259* Mon May 31 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.38-0.fdr.3
260- Fix build in setups which do not generate debug packages (bug 1606)
261- Require perl >= 1:5.6.1 for vendor install dir support
262- Use pure_install to avoid perllocal.pod workarounds
263
264* Sun Apr 25 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.38-0.fdr.2
265- Require perl(:MODULE_COMPAT_*)
266
267* Sat Mar 27 2004 Ville Skyttä <ville.skytta@iki.fi> - 0:0.38-0.fdr.1
268- First build
Note: See TracBrowser for help on using the repository browser.