source: projects/specs/trunk/p/perl-Module-ScanDeps/perl-Module-ScanDeps-vl.spec @ 12120

Revision 12120, 7.1 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Module-ScanDeps
2Summary:        Recursively scan Perl code for dependencies
3Version:        1.27
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/R/RS/RSCHUPP/Module-ScanDeps-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/Module-ScanDeps/
9Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
10BuildArch:      noarch
11
12Vendor:        Project Vine
13Distribution:  Vine Linux
14
15BuildRequires:  perl(Config)
16BuildRequires:  perl(Cwd)
17BuildRequires:  perl(DynaLoader)
18BuildRequires:  perl(Encode)
19BuildRequires:  perl(Exporter)
20BuildRequires:  perl(ExtUtils::MakeMaker)
21BuildRequires:  perl(File::Basename)
22BuildRequires:  perl(File::Find)
23BuildRequires:  perl(File::Path)
24BuildRequires:  perl(File::Spec)
25BuildRequires:  perl(File::Temp)
26BuildRequires:  perl(FileHandle)
27BuildRequires:  perl-Module-Pluggable
28BuildRequires:  perl(Test::More)
29BuildRequires:  perl(Test::Pod)
30BuildRequires:  perl(Test::Requires)
31BuildRequires:  perl(constant)
32BuildRequires:  perl(prefork)
33BuildRequires:  perl(vars)
34BuildRequires:  perl(version)
35
36Requires:       perl(DynaLoader)
37Requires:       perl(Encode)
38Requires:       perl(Exporter)
39Requires:       perl(File::Find)
40Requires:       perl(File::Spec)
41Requires:       perl(File::Temp)
42Requires:       perl(version)
43
44
45%{?perl_default_filter}
46%{?perl_default_subpackage_tests}
47
48%description
49This module scans potential modules used by perl programs and returns a
50hash reference.  Its keys are the module names as appears in %INC (e.g.
51Test/More.pm).  The values are hash references.
52
53%prep
54%setup -q -n Module-ScanDeps-%{version}
55
56%build
57%{__perl} Makefile.PL INSTALLDIRS=vendor
58make %{?_smp_mflags}
59
60%install
61make pure_install PERL_INSTALL_ROOT=%{buildroot}
62find %{buildroot} -type f -name .packlist -exec rm -f {} \;
63find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
64%{_fixperms} %{buildroot}/*
65
66%check
67make test
68
69%files
70%doc AUTHORS Changes README
71%{_bindir}/*
72%{perl_vendorlib}/*
73%{_mandir}/man1/*
74%{_mandir}/man3/*
75
76%changelog
77* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.27-1
78- new upstream release.
79- rebuilt with perl-5.26.
80
81* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.08-2
82- rebuild with VineSeed environment
83
84* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.08-1
85- initial build for Vine Linux
86
87* Thu Feb 23 2012 Petr Šabata <contyk@redhat.com> - 1.08-1
88- 1.08 bump
89
90* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.07-2
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
92
93* Wed Nov 30 2011 Petr Šabata <contyk@redhat.com> - 1.07-1
94- 1.07 bump
95
96* Tue Nov 29 2011 Petr Šabata <contyk@redhat.com> - 1.06-1
97- 1.06 bump
98
99* Thu Nov 03 2011 Petr Sabata <contyk@redhat.com> - 1.05-1
100- 1.05 bump
101
102* Mon Jul 25 2011 Petr Sabata <contyk@redhat.com> - 1.04-1
103- 1.04 bump
104
105* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.02-2
106- Perl mass rebuild
107
108* Thu May  5 2011 Petr sabata <psabata@redhat.com> - 1.02-1
109- 1.02 bump (rhbz#691369)
110- Removing now obsolete Buildroot and defattr
111- Correcting BRs/Rs
112
113* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
115
116* Tue Nov 23 2010 Marcela Mašláňová <mmaslano@redhat.com> 0.98-1
117- update by Fedora::App::MaintainerTools 0.006
118- updating to latest GA CPAN version (0.98)
119- added a new br on perl(File::Spec) (version 0)
120- added a new br on perl(File::Temp) (version 0)
121- added a new req on perl(File::Spec) (version 0)
122- added a new req on perl(File::Temp) (version 0)
123- added a new req on perl(Module::Build::ModuleInfo) (version 0)
124- added a new req on perl(version) (version 0)
125
126* Fri Jun 11 2010 Petr Sabata <psabata@redhat.com> - 0.97-1
127- Update to the latest version
128
129* Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.95-3
130- Mass rebuild with perl-5.12.0
131
132* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.95-2
133- rebuild against perl 5.10.1
134
135* Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.95-1
136- auto-update to 0.95 (by cpan-spec-update 0.01)
137- add perl_default_filter (pro forma)
138- altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
139
140* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.89-3
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
142
143* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.89-2
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
145
146* Mon Dec 15 2008 Steven Pritchard <steve@kspei.com> 0.89-1
147- Update to 0.89.
148- BR Test::More and prefork.
149- Improve description.
150
151* Fri May 16 2008 Steven Pritchard <steve@kspei.com> 0.84-1
152- Update to 0.84.
153
154* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.82-2
155- rebuild for new perl
156
157* Mon Jan 28 2008 Steven Pritchard <steve@kspei.com> 0.82-1
158- Update to 0.82.
159- BR version.
160
161* Thu Jan 24 2008 Steven Pritchard <steve@kspei.com> 0.81-1
162- Update to 0.81.
163- Use fixperms macro instead of our own chmod incantation.
164- Reformat to match cpanspec output.
165- BR ExtUtils::MakeMaker.
166
167* Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.75-1
168- Update to 0.75.
169
170* Sat May  5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.74-1
171- Update to 0.74.
172
173* Sat Mar 31 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.73-1
174- Update to 0.73.
175
176* Sun Feb  4 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.72-1
177- Update to 0.72.
178- Added perl(Module::Pluggable) to the build requirements list (t/2-pluggable.t).
179
180* Fri Jan  5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.71-1
181- Update to 0.71.
182
183* Wed Nov 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.70-1
184- Update to 0.70.
185
186* Sat Nov 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.69-1
187- Update to 0.69.
188
189* Sat Oct 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.68-1
190- Update to 0.68.
191
192* Sun Sep 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.66-1
193- Update to 0.66.
194
195* Sat Sep 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.64-1
196- Update to 0.64.
197
198* Mon Sep  4 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.63-1
199- Update to 0.63.
200
201* Sun Jul 16 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.62-1
202- Update to 0.62.
203
204* Sat Jul  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.61-1
205- Update to 0.61.
206
207* Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.60-1
208- Update to 0.60.
209
210* Sun May  7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.59-2
211- Source URL corrected (failed to detect the maintainer change).
212
213* Wed May  3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.59-1
214- Update to 0.59.
215
216* Thu Mar 16 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.57-1
217- Update to 0.57.
218
219* Tue Feb 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.56-1
220- Update to 0.56.
221
222* Tue Jan 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.53-1
223- Update to 0.53.
224
225* Fri Sep  9 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.51-1
226- Update to Fedora Extras Template.
227
228* Sat Jan 08 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:0.51-0.fdr.1
229- First build.
Note: See TracBrowser for help on using the repository browser.