source: projects/specs/trunk/p/perl-Module-Install/perl-Module-Install-vl.spec @ 9140

Revision 9140, 7.2 KB checked in by Takemikaduchi, 9 years ago (diff)

perl-WWW-Curl: NEW
dotconf,perl-HTTP-Server-Simple,speech-dispatcher: new upstream release
others: rebuild

Line 
1Name:           perl-Module-Install
2Version:        1.04
3Release:        2%{?_dist_release}
4Summary:        Standalone, extensible Perl module installer
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Module-Install/
8Source0:        http://www.cpan.org/authors/id/A/AD/ADAMK/Module-Install-%{version}.tar.gz
9BuildArch:      noarch
10
11# Note, Makefile.PL is going to complain about having lower versions of
12# certain modules than is supported. (Especially under F-10.) However,
13# all tests pass and AFAICT everything works just fine in normal usage.
14
15BuildRequires:  perl(Archive::Tar) >= 1.44
16BuildRequires:  perl(CPAN)
17BuildRequires:  perl(Devel::PPPort)
18BuildRequires:  perl(ExtUtils::Install) >= 1.52
19BuildRequires:  perl(ExtUtils::MakeMaker)
20BuildRequires:  perl(ExtUtils::ParseXS) >= 2.19
21BuildRequires:  perl(File::Remove) >= 1.42
22BuildRequires:  perl(File::Spec)
23BuildRequires:  perl(JSON) >= 2.14
24BuildRequires:  perl(LWP::UserAgent) >= 5.812
25BuildRequires:  perl(Module::Build) >= 0.29
26BuildRequires:  perl(Module::CoreList) >= 2.17
27BuildRequires:  perl(Module::ScanDeps) >= 0.89
28BuildRequires:  perl(PAR::Dist) >= 0.29
29BuildRequires:  perl(Parse::CPAN::Meta) >= 1.39
30BuildRequires:  perl(Test::CPAN::Meta) >= 0.07
31BuildRequires:  perl(Test::Harness) >= 3.13
32BuildRequires:  perl(Test::MinimumVersion)
33BuildRequires:  perl(Test::More)
34BuildRequires:  perl(Test::Pod)
35BuildRequires:  perl(YAML::Tiny) >= 1.38
36Requires:       perl(Archive::Tar)
37Requires:       perl(ExtUtils::ParseXS)
38Requires:       perl(Module::Build)
39Requires:       perl(Module::ScanDeps)
40Requires:       perl(PAR::Dist) >= 0.29
41Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       shaolin
46
47%description
48Module::Install is a package for writing installers for CPAN (or CPAN-like)
49distributions that are clean, simple, minimalist, act in a strictly correct
50manner with ExtUtils::MakeMaker, and will run on any Perl installation
51version 5.005 or newer.
52
53%prep
54%setup -q -n Module-Install-%{version}
55
56%build
57%{__perl} Makefile.PL INSTALLDIRS=vendor
58make %{?_smp_mflags}
59
60%install
61make pure_install DESTDIR=%{buildroot}
62
63find %{buildroot} -type f -name .packlist -exec rm -f {} \;
64find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
65rm -rf %{buildroot}/blib/lib/auto/share/dist/Module-Install/dist_file.txt
66%{_fixperms} %{buildroot}/*
67find %{buildroot}%{perl_vendorlib} -type f -perm +100 -exec chmod a-x {} \;
68
69%check
70make test AUTOMATED_TESTING=1
71
72%files
73%doc Changes LICENSE README
74%{perl_vendorlib}/*
75%{_mandir}/man3/*
76
77%changelog
78* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.04-2
79- rebuild with VineSeed environment
80
81* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.04-1
82- initial build for Vine Linux
83
84* Thu Jan 12 2012 Iain Arnell <iarnell@gmail.com> 1.04-1
85- update to latest upstream version
86
87* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1.01-2
88- Perl mass rebuild
89
90* Sat May 14 2011 Iain Arnell <iarnell@gmail.com> 1.01-1
91- update to latest upstream version
92- clean up spec for modern rpmbuild
93
94* Thu Mar 10 2011 Steven Pritchard <steve@kspei.com> 1.00-1
95- Update to 1.00.
96- Update build dependencies:
97  + Archive::Tar >= 1.44
98  + ExtUtils::Install >= 1.52
99  + ExtUtils::ParseXS >= 2.19
100  + JSON >= 2.14
101  + LWP::UserAgent >= 5.812
102  + Module::Build >= 0.29
103  + Module::CoreList >= 2.17
104  + Module::ScanDeps >= 0.89
105- Update description (pulled from module).
106
107* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.95-3
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
109
110* Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.95-2
111- 661697 rebuild for fixing problems with vendorach/lib
112
113* Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.95-1
114- Mass rebuild with perl-5.12.0 & update
115
116* Thu Feb 25 2010 Marcela Mašláňová <mmaslano@redhat.com> - 0.91-4
117- change to DESTDIR
118- add README
119- dist_file.txt wasn't packaged -> removed, it's needed only for test of build
120
121* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.91-3
122- rebuild against perl 5.10.1
123
124* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-2
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
126
127* Sun Jun 14 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.91-1
128- update to 0.91
129- add br on Parse::CPAN::Meta: 1.39
130
131* Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.90-1
132- update to 0.90
133- add br on JSON, Test::Harness (3.13)
134- update br on YAML::Tiny (1.38)
135
136* Mon May 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.87-1
137- update to 0.87
138
139* Sun Apr 26 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.85-1
140- update to 0.85
141- add BR on File::Spec
142
143* Thu Apr 09 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.82-1
144- update to 0.82
145
146* Sun Mar 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.80-1
147- update to 0.80
148- remove 03_autoinstall.t swizzle (now self-skipped; see RT29448)
149
150* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.79-1
151- update to 0.79
152
153* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.77-2
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
155
156* Thu Dec 04 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.77-1
157- update to 0.77
158
159* Wed Jun 04 2008 Steven Pritchard <steve@kspei.com> 0.75-1
160- Update to 0.75.
161
162* Sat May 31 2008 Steven Pritchard <steve@kspei.com> 0.74-1
163- Update to 0.74.
164- Update versioned dependencies for File::Remove, Module::ScanDeps,
165  PAR::Dist, and YAML::Tiny.
166- BR Test::CPAN::Meta.
167
168* Fri May 16 2008 Steven Pritchard <steve@kspei.com> 0.73-1
169- Update to 0.73.
170- BR File::Remove.
171- Drop zero-length README.
172
173* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.68-3
174- disable broken test (upstream bug present)
175- add Test::MinimumVersion as BR
176
177* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.68-2
178- rebuild for new perl
179
180* Mon Jan 28 2008 Steven Pritchard <steve@kspei.com> 0.68-1
181- Update to 0.68.
182- Explicitly require Archive::Tar and ExtUtils::ParseXS.
183
184* Sun Dec 30 2007 Ralf Corsépius <rc040203@freenet.de> - 0.67-2
185- BR: perl(Test::More), perl(CPAN) (BZ 419631).
186- Remove TEST_POD (Unused).
187- Add AUTOMATED_TESTING.
188- BR: perl(Test::Pod) for AUTOMATED_TESTING.
189- Adjust License-tag.
190
191* Fri May 18 2007 Steven Pritchard <steve@kspei.com> 0.67-1
192- Update to 0.67.
193- BR Archive::Tar, ExtUtils::ParseXS, and YAML::Tiny.
194- Add a couple more docs.
195
196* Tue Mar 13 2007 Steven Pritchard <steve@kspei.com> 0.65-1
197- Update to 0.65.
198- Use fixperms macro instead of our own chmod incantation.
199- BR ExtUtils::MakeMaker.
200
201* Sun Sep 17 2006 Steven Pritchard <steve@kspei.com> 0.64-2
202- Rebuild.
203
204* Fri Aug 25 2006 Steven Pritchard <steve@kspei.com> 0.64-1
205- Update to 0.64.
206- Fix find option order.
207
208* Thu Jun 08 2006 Steven Pritchard <steve@kspei.com> 0.63-1
209- Update to 0.63.
210
211* Mon May 08 2006 Steven Pritchard <steve@kspei.com> 0.62-2
212- Fix Source0 URL.
213
214* Sat May 06 2006 Steven Pritchard <steve@kspei.com> 0.62-1
215- Update to 0.62.
216- Drop executable bit from everything in vendor_perl to make rpmlint happy.
217
218* Thu Mar 23 2006 Steven Pritchard <steve@kspei.com> 0.61-1
219- Specfile autogenerated by cpanspec 1.63.
220- Drop explicit BR: perl.
221- Turn on TEST_POD.
Note: See TracBrowser for help on using the repository browser.