source: projects/specs/trunk/p/perl-Module-Implementation/perl-Module-Implementation-vl.spec @ 12120

Revision 12120, 4.5 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# We need to patch the test suite if we have an old version of Test::More
2%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
3
4# Test::CPAN::Changes isn't available in EPEL < 7, due to requirement of perl(version) ≥ 0.79
5
6#TODO: BR: Test::Pod::No404s when available
7#TODO: BR: Test::Pod::LinkCheck when available
8
9Name:           perl-Module-Implementation
10Version:        0.09
11Release:        1%{?_dist_release}
12Summary:        Loads one of several alternate underlying implementations for a module
13Group:          Development/Libraries
14License:        Artistic 2.0
15URL:            http://search.cpan.org/dist/perl-Module-Implementation/
16Source0:        http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Module-Implementation-%{version}.tar.gz
17Patch1:         Module-Implementation-0.05-old-Test::More.patch
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
19
20Vendor:        Project Vine
21Distribution:  Vine Linux
22
23BuildArch:      noarch
24# ===================================================================
25# Build requirements
26# ===================================================================
27BuildRequires:  perl(ExtUtils::MakeMaker)
28# ===================================================================
29# Module requirements
30# ===================================================================
31BuildRequires:  perl(Module::Runtime)
32# ===================================================================
33# Test suite requirements
34# ===================================================================
35BuildRequires:  perl(Test::Fatal)
36BuildRequires:  perl(Test::Requires)
37# ===================================================================
38# Runtime requirements
39# ===================================================================
40Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
41#Requires:      perl(Carp)
42
43%description
44This module abstracts out the process of choosing one of several underlying
45implementations for a module. This can be used to provide XS and pure Perl
46implementations of a module, or it could be used to load an implementation
47for a given OS or any other case of needing to provide multiple
48implementations.
49
50This module is only useful when you know all the implementations ahead of
51time. If you want to load arbitrary implementations then you probably want
52something like a plugin system, not this module.
53
54%prep
55%setup -q -n Module-Implementation-%{version}
56
57# We have to patch the test suite if we have an old Test::More
58%if %{old_test_more}
59%patch1 -p1
60%endif
61
62%build
63perl Makefile.PL INSTALLDIRS=vendor
64make %{?_smp_mflags}
65
66%install
67rm -rf %{buildroot}
68make pure_install DESTDIR=%{buildroot}
69find %{buildroot} -type f -name .packlist -exec rm -f {} \;
70find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
71%{_fixperms} %{buildroot}
72
73%check
74#make test RELEASE_TESTING=1
75make test
76
77%clean
78rm -rf %{buildroot}
79
80%files
81%defattr(-,root,root,-)
82%license LICENSE
83%doc Changes README
84%{perl_vendorlib}/Module/
85%{_mandir}/man3/Module::Implementation.3pm*
86
87%changelog
88* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.09-1
89- new upstream release.
90- rebuilt with perl-5.26.
91
92* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.07-1
93- new upstream release.
94
95* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.06-1
96- initial build for Vine Linux
97
98* Sun Feb 12 2012 Paul Howarth <paul@city-fan.org> - 0.06-1
99- Update to 0.06
100  - Require Module::Runtime 0.012, which has a number of useful bug fixes
101
102* Fri Feb 10 2012 Paul Howarth <paul@city-fan.org> - 0.05-1
103- Update to 0.05
104  - Make Test::Taint an optional dependency; it requires XS, and requiring a
105    compiler for Module::Implementation defeats its purpose (CPAN RT#74817)
106- BR: perl(Test::Requires)
107- Update patch for building with old Test::More versions
108
109* Thu Feb  9 2012 Paul Howarth <paul@city-fan.org> - 0.04-1
110- Update to 0.04
111  - This module no longer installs an _implementation() subroutine in callers;
112    instead, you can call Module::Implementation::implementation_for($package)
113    to get the implementation used for a given package
114- Update patch for building with old Test::More versions
115
116* Wed Feb  8 2012 Paul Howarth <paul@city-fan.org> - 0.03-3
117- Incorporate feedback from package review (#788258)
118  - Correct License tag, which should be Artistic 2.0
119  - BR: perl(lib) for test suite
120  - Explicitly require perl(Carp), not automatically detected
121
122* Tue Feb  7 2012 Paul Howarth <paul@city-fan.org> - 0.03-2
123- Sanitize for Fedora submission
124
125* Tue Feb  7 2012 Paul Howarth <paul@city-fan.org> - 0.03-1
126- Initial RPM version
Note: See TracBrowser for help on using the repository browser.