source: projects/specs/trunk/p/perl-Module-Find/perl-Module-Find-vl.spec @ 4917

Revision 4917, 2.0 KB checked in by yasumichi, 13 years ago (diff)

Import spec file.

Line 
1%define pkgname Module-Find
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.10
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/C/CR/CRENZ/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Find and use installed modules in a (sub)category
17Summary(ja):    (サブ)カテゴリー内にインストールされたモジュールを見つけて利用する
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26Module::Find lets you find and use modules in categories. This can be very
27useful for auto-detecting driver or plugin modules. You can differentiate
28between looking in the category itself or in all subcategories.
29
30If you want Module::Find to search in a certain directory on your harddisk
31(such as the plugins directory of your software installation), make sure you
32modify @INC before you call the Module::Find functions.
33
34#%%description -l ja
35#ここに日本語で詳細を記述してください。
36
37%prep
38%setup -q -n Module-Find-0.10
39
40%build
41perl Makefile.PL
42%{__make}
43
44%install
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%{__make} install DESTDIR=${RPM_BUILD_ROOT}
47
48find $RPM_BUILD_ROOT%{_prefix} -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v ^%{_mandir} |
51        grep -v perllocal.pod |
52        grep -v "\.packlist" > %{name}.files
53if [ "$(cat %{name}.files)X" = "X" ] ; then
54        echo "ERROR: EMPTY FILE LIST"
55        exit -1
56fi
57
58# remove unnecessary files.
59%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
60%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Module/Find/.packlist
61
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66
67%files -f %{name}.files
68%defattr(-,root,root)
69%doc Changes README
70%{_mandir}/*/*
71
72
73%changelog
74* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.10-1
75- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.