source: projects/specs/trunk/p/perl-Math-BigInt/perl-Math-BigInt-vl.spec @ 12121

Revision 12121, 6.5 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1Name:           perl-Math-BigInt
2%global cpan_version 1.999816
3# Keep 4-digit version to compete with perl.spec
4Version:        %(echo %{cpan_version} | sed 's/\(\.....\)/\1./')
5Release:        440%{?_dist_release}
6Summary:        Arbitrary-size integer and float mathematics
7License:        GPL+ or Artistic
8URL:            https://metacpan.org/release/Math-BigInt
9Source0:        https://cpan.metacpan.org/authors/id/P/PJ/PJACKLAM/Math-BigInt-%{cpan_version}.tar.gz
10BuildArch:      noarch
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15BuildRequires:  make
16BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.76
17BuildRequires:  perl(strict)
18BuildRequires:  perl(warnings)
19BuildRequires:  sed
20# Run-time:
21BuildRequires:  perl(Carp)
22BuildRequires:  perl(constant)
23BuildRequires:  perl(Exporter)
24# File::Spec not used on recent perl
25BuildRequires:  perl(integer)
26BuildRequires:  perl(Math::Complex) >= 1.39
27BuildRequires:  perl(overload)
28# Tests:
29BuildRequires:  perl(base)
30BuildRequires:  perl(Config)
31# Config::Tiny not used
32BuildRequires:  perl(lib)
33# Module::Signature not used
34# Scalar::Util not used
35# Socket not used
36# Test::CPAN::Changes not used
37BuildRequires:  perl(Test::More)
38# Optional tests:
39# This core module must be buildable without non-core modules at bootstrap.
40# Test::Pod 1.22 not used
41# Test::Pod::Coverage 1.08 not used
42# Test::Portability::Files not used
43# Test::Whitespaces not used
44# Pod::Coverage 0.18 not used
45Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
46Requires:       perl(Math::Complex) >= 1.39
47
48# Do not export unversioned module
49%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(Math::BigInt\\)\\s*$
50
51%description
52This provides Perl modules for arbitrary-size integer and float mathematics.
53
54%prep
55%setup -q -n Math-BigInt-%{cpan_version}
56
57%build
58perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
59make %{?_smp_mflags}
60
61%install
62make pure_install DESTDIR=$RPM_BUILD_ROOT
63%{_fixperms} $RPM_BUILD_ROOT/*
64
65%check
66unset AUTHOR_TESTING RELEASE_TESTING
67make test
68
69%files
70%license LICENSE
71# NEW file is useless
72%doc BUGS CHANGES CREDITS examples GOALS HISTORY README TODO
73%{perl_vendorlib}/*
74%exclude %{_mandir}/man3/*
75
76%changelog
77* Fri Aug 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9998.16-440
78- initial build for Vine Linux.
79
80* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9998.16-439
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
82
83* Thu May 30 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.9998.16-438
84- Increase release to favour standalone package
85
86* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9998.16-2
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
88
89* Wed Oct 31 2018 Petr Pisar <ppisar@redhat.com> - 1:1.9998.16-1
90- 1.999816 bump
91
92* Tue Oct 23 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.9998.15-1
93- 1.999815 bump
94
95* Fri Oct 12 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.9998.14-1
96- 1.999814 bump
97
98* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9998.13-3
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
100
101* Tue Jun 26 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.9998.13-2
102- Perl 5.28 rebuild
103
104* Wed Apr 18 2018 Petr Pisar <ppisar@redhat.com> - 1:1.9998.13-1
105- 1.999813 bump
106
107* Wed Apr 18 2018 Petr Pisar <ppisar@redhat.com> - 1:1.9998.12-1
108- 1.999812 bump
109
110* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9998.11-5
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
112
113* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9998.11-4
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
115
116* Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.9998.11-3
117- Perl 5.26 re-rebuild of bootstrapped packages
118
119* Sat Jun 03 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1:1.9998.11-2
120- Perl 5.26 rebuild
121
122* Fri Mar 17 2017 Petr Pisar <ppisar@redhat.com> - 1.9998.11-1
123- 1.999811 bump
124
125* Thu Mar 02 2017 Petr Pisar <ppisar@redhat.com> - 1.9998.10-1
126- 1.999810 bump
127
128* Mon Feb 13 2017 Petr Pisar <ppisar@redhat.com> - 1.9998.09-1
129- 1.999809 bump
130
131* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9998.08-2
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
133
134* Thu Jan 12 2017 Paul Howarth <paul@city-fan.org> - 1.9998.08-1
135- 1.999808 bump
136
137* Mon Jan 02 2017 Petr Pisar <ppisar@redhat.com> - 1.9998.07-1
138- 1.999807 bump
139
140* Wed Dec 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.9998.06-1
141- 1.999806 bump
142
143* Mon Dec 12 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.05-1
144- 1.999805 bump
145
146* Fri Dec 09 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.04-1
147- 1.999804 bump
148
149* Mon Dec 05 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.03-1
150- 1.999803 bump
151
152* Thu Dec 01 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.02-1
153- 1.999802 bump
154
155* Fri Nov 25 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.01-1
156- 1.999801 bump
157
158* Fri Nov 18 2016 Petr Pisar <ppisar@redhat.com> - 1.9998.00-1
159- 1.999800 bump
160
161* Tue Nov 08 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.27-1
162- 1.999727 bump
163
164* Mon Jul 18 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.26-1
165- 1.999726 bump
166
167* Mon Jun 20 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.24-1
168- 1.999724 bump
169
170* Wed Jun 15 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.23-1
171- 1.999723 bump
172
173* Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.9997.22-3
174- Perl 5.24 re-rebuild of bootstrapped packages
175
176* Sat May 14 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.9997.22-2
177- Perl 5.24 rebuild
178
179* Wed Apr 27 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.22-1
180- 1.999722 bump
181
182* Tue Apr 26 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.20-1
183- 1.999720 bump
184
185* Mon Apr 18 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.17-1
186- 1.999717 bump
187
188* Tue Apr 05 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.16-1
189- 1.999716 bump
190
191* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.9997.15-2
192- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
193
194* Wed Jan 06 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.15-1
195- 1.999715 bump
196
197* Mon Jan 04 2016 Petr Pisar <ppisar@redhat.com> - 1.9997.14-1
198- 1.999714 bump
199
200* Mon Nov 16 2015 Petr Pisar <ppisar@redhat.com> - 1.9997.10-1
201- 1.999710 bump
202
203* Tue Nov 10 2015 Petr Pisar <ppisar@redhat.com> - 1.9997.09-1
204- 1.999709 bump
205
206* Thu Nov 05 2015 Petr Pisar <ppisar@redhat.com> - 1.9997.08-1
207- 1.999708 bump
208
209* Mon Nov 02 2015 Petr Pisar <ppisar@redhat.com> 1.9997.07-354
210- Specfile autogenerated by cpanspec 1.78.
211- Use bundled modules when bootstrapping
Note: See TracBrowser for help on using the repository browser.