source: projects/specs/trunk/p/perl-MailTools/perl-MailTools-vl.spec @ 521

Revision 521, 2.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perl_vendorlib    %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2
3Summary: a set of perl modules related to mail applications
4Summary(ja): メールアプリケーション関連の Perl モジュールセット
5Name: perl-MailTools
6Version: 2.04
7Release: 2%{_dist_release}
8License: Artistic
9Group: Development/Libraries
10Source0: http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/MailTools-%{version}.tar.gz
11Url: http://search.cpan.org/author/MARKOV/MailTools/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: perl >= 5.8.0
14BuildRequires: perl-TimeDate
15Requires: perl >= 5.8.0
16Requires: perl-TimeDate
17BuildArch: noarch
18
19%description
20This is MailTools, a set of perl modules related to mail applications.
21
22%description -l ja
23MailTools は、メールアプリケーション関連の Perl モジュールセットです。
24
25%prep
26%setup -q -n MailTools-%{version}
27
28%build
29CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
30make
31
32%check
33make test
34
35%clean
36rm -rf $RPM_BUILD_ROOT
37
38%install
39rm -rf $RPM_BUILD_ROOT
40mkdir -p $RPM_BUILD_ROOT%{_prefix}
41make DESTDIR=$RPM_BUILD_ROOT install
42
43find $RPM_BUILD_ROOT%{_prefix} -type f -print |
44        sed "s@^$RPM_BUILD_ROOT@@g" |
45        grep -v ^%{_mandir} |
46        grep -v perllocal.pod |
47        grep -v "\.packlist" > %{name}.files
48if [ "$(cat %{name}.files)X" = "X" ] ; then
49    echo "ERROR: EMPTY FILE LIST"
50    exit -1
51fi
52
53%files -f %{name}.files
54%defattr(-,root,root)
55%doc ChangeLog README README.demos examples
56%{_mandir}/man3/*
57%dir %{perl_vendorlib}/Mail
58%dir %{perl_vendorlib}/Mail/Field
59%dir %{perl_vendorlib}/Mail/Mailer
60
61%changelog
62* Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.04-2
63- spec in utf-8
64
65* Sat Feb 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.04-1
66- new upstream release.
67
68* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.03-1
69- new upstream release.
70- built with perl-5.10.0.
71
72* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.77-0vl1
73- new upstream release
74- changed Group to Development/Libraries
75
76* Thu Sep 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.67-0vl1
77- new upstream release
78- s/Copyright/License/
79- use vendor_perl dir
80
81* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 1.65-0vl1
82- new upstream release
83- build on perl-5.8.6-0vl1
84- update {Build,}Requires
85- add Japanese Summary and description
86
87* Thu Apr 24 2003 IWAI Masaharu <iwai@alib.jp> 1.58-0vl1
88- version up to 1.58
89- build with perl-5.8.0
90
91* Sun Aug 25 2002 IWAI Masaharu <iwai@alib.jp> 1.48-0vl1
92- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.