source: projects/specs/trunk/p/perl-Mail-Sender/perl-Mail-Sender-vl.spec @ 12120

Revision 12120, 2.4 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

RevLine 
[5484]1%define pkgname Mail-Sender
2
3# Basic Information
4Name:           perl-%{pkgname}
[12120]5Version:        0.903
[5484]6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/J/JE/JENDA/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Mail::Sender - module for sending mails with attachments through an SMTP server
18Summary(ja):    Mail::Sender - SMTP サーバー経由で添付ファイル付メールを送信するためのモジュール
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27Mail::Sender provides an object oriented interface to sending mails. It
28doesn't need any outer program. It connects to a mail server directly from
29Perl, using Socket.
30
31%description -l ja
32Mail::Sender は、メール送信のためのオブジェクト指向インターフェースを提供し
33ます。他の外部プログラムは必要ありません。ソケットを使って Perl から直接、
34メールサーバーへ接続します。
35
36%prep
[8705]37%setup -q -n %{pkgname}-%{version}
[5484]38
39%build
40perl Makefile.PL
41%{__make} << EOM
42n
43EOM
44
45
46%install
47%{__rm} -rf ${RPM_BUILD_ROOT}
48%{__make} install DESTDIR=${RPM_BUILD_ROOT}
49
50# Remove the Win32 module in order to avoid requiring perl(Win32API::Registry)
51# This idea is from fedora.
52find $RPM_BUILD_ROOT -type f -name Win32.pm -exec rm -f {} ';'
53
54find $RPM_BUILD_ROOT%{_prefix} -type f -print |
55        sed "s@^$RPM_BUILD_ROOT@@g" |
56        grep -v ^%{_mandir} |
57        grep -v perllocal.pod |
58        grep -v "\.packlist" > %{name}.files
59
60if [ "$(cat %{name}.files)X" = "X" ] ; then
61        echo "ERROR: EMPTY FILE LIST"
62        exit -1
63fi
64
65# remove unnecessary files.
66%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
67%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Mail/Sender/.packlist
68
69%clean
70%{__rm} -rf ${RPM_BUILD_ROOT}
71
72
73%files -f %{name}.files
74%defattr(-,root,root)
75%doc Changes README
[12120]76%{_mandir}/man*/*
[5484]77
78%changelog
[12120]79* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.903-1
80- new upstream release.
81- rebuilt with perl-5.26.
82
[8705]83* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.8.21-1
84- update to 0.8.21
85
[5484]86* Wed Jan 25 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.8.16-1
87- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.