source: projects/specs/trunk/p/perl-Mail-DKIM/perl-Mail-DKIM-vl.spec @ 8699

Revision 8699, 4.1 KB checked in by tomop, 10 years ago (diff)

spamassassin-3.4.0

Line 
1#
2#   - Mail::DKIM -
3#   This spec file was automatically generated by cpan2rpm [ver: 2.028]
4#   The following arguments were used:
5#       Mail::DKIM
6#   For more information on cpan2rpm please visit: http://perl.arix.com/
7#
8
9%define pkgname Mail-DKIM
10%define filelist %{pkgname}-%{version}-filelist
11%define NVR %{pkgname}-%{version}-%{release}
12%define maketest 1
13
14Name:      perl-Mail-DKIM
15Summary:   Mail-DKIM - Signs/verifies Internet mail with DKIM/DomainKey signatures
16Version:   0.40
17Release:   2%{?_dist_release}
18License:   Artistic
19Group:     Development/Languages
20Url:       http://www.cpan.org
21BuildRoot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
22BuildArch: noarch
23Source:    http://search.cpan.org//CPAN/authors/id/J/JA/JASLONG/Mail-DKIM-%{version}.tar.gz
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: tomop
27
28BuildRequires: perl(Mail::Address)
29
30%description
31This module implements the various components of the DKIM and
32DomainKeys message-signing and verifying standards for Internet mail.
33It currently tries to implement these specifications:
34
35=over
36
37=item RFC4871, for DKIM
38
39=item RFC4870, for DomainKeys
40
41=back
42
43The module uses an object-oriented interface. You use one of
44two different classes, depending on whether you are signing or verifying
45a message. To sign, use the L<Mail::DKIM::Signer> class. To verify, use
46the L<Mail::DKIM::Verifier> class. Simple, eh?
47
48#
49# This package was generated automatically with the cpan2rpm
50# utility.  To get this software or for more information
51# please visit: http://perl.arix.com/
52#
53
54%prep
55%setup -q -n %{pkgname}-%{version}
56chmod -R u+w %{_builddir}/%{pkgname}-%{version}
57
58%build
59grep -rsl '^#!.*perl' . |
60grep -v '.bak$' |xargs --no-run-if-empty \
61%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
62CFLAGS="$RPM_OPT_FLAGS"
63%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLDIRS=vendor
64%{__make}
65%if %maketest
66%{__make} test
67%endif
68
69%install
70[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
71
72%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
73
74cmd=/usr/share/spec-helper/compress_files
75[ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
76[ -x $cmd ] && $cmd
77
78# SuSE Linux
79if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
80then
81    %{__mkdir_p} %{buildroot}/var/adm/perl-modules
82    %{__cat} `find %{buildroot} -name "perllocal.pod"`  \
83        | %{__sed} -e s+%{buildroot}++g                 \
84        > %{buildroot}/var/adm/perl-modules/%{name}
85fi
86
87# remove special files
88find %{buildroot} -name "perllocal.pod" \
89    -o -name ".packlist"                \
90    -o -name "*.bs"                     \
91    |xargs -i rm -f {}
92
93# no empty directories
94find %{buildroot}%{_prefix}             \
95    -type d -depth                      \
96    -exec rmdir {} \; 2>/dev/null
97
98%{__perl} -MFile::Find -le '
99    find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
100    print "%doc  TODO scripts Changes README";
101    for my $x (sort @dirs, @files) {
102        push @ret, $x unless indirs($x);
103        }
104    print join "\n", sort @ret;
105
106    sub wanted {
107        return if /auto$/;
108
109        local $_ = $File::Find::name;
110        my $f = $_; s|^\Q%{buildroot}\E||;
111        return unless length;
112        return $files[@files] = $_ if -f $f;
113
114        $d = $_;
115        /\Q$d\E/ && return for reverse sort @INC;
116        $d =~ /\Q$_\E/ && return
117            for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
118
119        $dirs[@dirs] = $_;
120        }
121
122    sub indirs {
123        my $x = shift;
124        $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
125        }
126    ' > %filelist
127
128[ -z %filelist ] && {
129    echo "ERROR: empty %files listing"
130    exit -1
131    }
132
133%clean
134[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
135
136%files -f %filelist
137%defattr(-,root,root)
138
139%changelog
140* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-2
141- rebuilt with perl-5.16.3.
142
143* Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-1
144- new upstream release.
145
146* Fri Dec 02 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.39-1
147- Initial build.
Note: See TracBrowser for help on using the repository browser.