source: projects/specs/trunk/p/perl-Mail-DKIM/perl-Mail-DKIM-vl.spec @ 12120

Revision 12120, 4.7 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1#
2#   - Mail::DKIM -
3#   This spec file was automatically generated by cpan2rpm [ver: 2.028]
4#   The following arguments were used:
5#       Mail::DKIM
6#   For more information on cpan2rpm please visit: http://perl.arix.com/
7#
8
9%define pkgname Mail-DKIM
10%define filelist %{pkgname}-%{version}-filelist
11%define NVR %{pkgname}-%{version}-%{release}
12%define maketest 1
13
14Name:      perl-Mail-DKIM
15Summary:   Mail-DKIM - Signs/verifies Internet mail with DKIM/DomainKey signatures
16Version:   0.55
17Release:   1%{?_dist_release}
18License:   Artistic
19Group:     Development/Libraries
20URL:       http://search.cpan.org/~jaslong/Mail-DKIM/
21
22Source:    http://search.cpan.org//CPAN/authors/id/J/JA/JASLONG/Mail-DKIM-%{version}.tar.gz
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildArch: noarch
26BuildRequires: perl(Crypt::OpenSSL::RSA)
27BuildRequires: perl(Mail::Address)
28BuildRequires: perl(Net::DNS)
29BuildRequires: perl(Net::DNS::Resolver::Mock)
30BuildRequires: perl(Test::RequiresInternet)
31Requires:      perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: tomop
36
37%description
38This module implements the various components of the DKIM and
39DomainKeys message-signing and verifying standards for Internet mail.
40It currently tries to implement these specifications:
41
42=over
43
44=item RFC4871, for DKIM
45
46=item RFC4870, for DomainKeys
47
48=back
49
50The module uses an object-oriented interface. You use one of
51two different classes, depending on whether you are signing or verifying
52a message. To sign, use the L<Mail::DKIM::Signer> class. To verify, use
53the L<Mail::DKIM::Verifier> class. Simple, eh?
54
55#
56# This package was generated automatically with the cpan2rpm
57# utility.  To get this software or for more information
58# please visit: http://perl.arix.com/
59#
60
61%prep
62%setup -q -n %{pkgname}-%{version}
63chmod -R u+w %{_builddir}/%{pkgname}-%{version}
64
65%build
66grep -rsl '^#!.*perl' . |
67grep -v '.bak$' |xargs --no-run-if-empty \
68%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
69CFLAGS="$RPM_OPT_FLAGS"
70%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLDIRS=vendor
71%{__make}
72%if %maketest
73%{__make} test
74%endif
75
76%install
77[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
78
79%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
80
81cmd=/usr/share/spec-helper/compress_files
82[ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
83[ -x $cmd ] && $cmd
84
85# SuSE Linux
86if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
87then
88    %{__mkdir_p} %{buildroot}/var/adm/perl-modules
89    %{__cat} `find %{buildroot} -name "perllocal.pod"`  \
90        | %{__sed} -e s+%{buildroot}++g                 \
91        > %{buildroot}/var/adm/perl-modules/%{name}
92fi
93
94# remove special files
95find %{buildroot} -name "perllocal.pod" \
96    -o -name ".packlist"                \
97    -o -name "*.bs"                     \
98    |xargs -i rm -f {}
99
100# no empty directories
101find %{buildroot}%{_prefix}             \
102    -type d -depth                      \
103    -exec rmdir {} \; 2>/dev/null
104
105%{__perl} -MFile::Find -le '
106    find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
107    print "%doc  TODO scripts Changes README";
108    for my $x (sort @dirs, @files) {
109        push @ret, $x unless indirs($x);
110        }
111    print join "\n", sort @ret;
112
113    sub wanted {
114        return if /auto$/;
115
116        local $_ = $File::Find::name;
117        my $f = $_; s|^\Q%{buildroot}\E||;
118        return unless length;
119        return $files[@files] = $_ if -f $f;
120
121        $d = $_;
122        /\Q$d\E/ && return for reverse sort @INC;
123        $d =~ /\Q$_\E/ && return
124            for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
125
126        $dirs[@dirs] = $_;
127        }
128
129    sub indirs {
130        my $x = shift;
131        $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
132        }
133    ' > %filelist
134
135[ -z %filelist ] && {
136    echo "ERROR: empty %files listing"
137    exit -1
138    }
139
140%clean
141[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
142
143%files -f %filelist
144%defattr(-,root,root)
145
146%changelog
147* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.55-1
148- new upstream release.
149- rebuilt with perl-5.26.
150
151* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.40-3
152- added BR: perl(Crypt::OpenSSL::RSA), perl(Net::DNS)
153- moved to Development/Libraries
154
155* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-2
156- rebuilt with perl-5.16.3.
157
158* Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-1
159- new upstream release.
160
161* Fri Dec 02 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.39-1
162- Initial build.
Note: See TracBrowser for help on using the repository browser.