source: projects/specs/trunk/p/perl-Mail-DKIM/perl-Mail-DKIM-vl.spec @ 9329

Revision 9329, 4.5 KB checked in by inagaki, 9 years ago (diff)

2015-02-05 Ryoichi INAGAKI <ryo1@…>

  • Cython, swig: updated
  • emacsen-common, gtkparasite, perl-Mail-{DKIM,Sendmail}: moved Group


Line 
1#
2#   - Mail::DKIM -
3#   This spec file was automatically generated by cpan2rpm [ver: 2.028]
4#   The following arguments were used:
5#       Mail::DKIM
6#   For more information on cpan2rpm please visit: http://perl.arix.com/
7#
8
9%define pkgname Mail-DKIM
10%define filelist %{pkgname}-%{version}-filelist
11%define NVR %{pkgname}-%{version}-%{release}
12%define maketest 1
13
14Name:      perl-Mail-DKIM
15Summary:   Mail-DKIM - Signs/verifies Internet mail with DKIM/DomainKey signatures
16Version:   0.40
17Release:   3%{?_dist_release}
18License:   Artistic
19Group:     Development/Libraries
20URL:       http://search.cpan.org/~jaslong/Mail-DKIM/
21
22Source:    http://search.cpan.org//CPAN/authors/id/J/JA/JASLONG/Mail-DKIM-%{version}.tar.gz
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildArch: noarch
26BuildRequires: perl(Crypt::OpenSSL::RSA)
27BuildRequires: perl(Mail::Address)
28BuildRequires: perl(Net::DNS)
29Requires:      perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: tomop
34
35%description
36This module implements the various components of the DKIM and
37DomainKeys message-signing and verifying standards for Internet mail.
38It currently tries to implement these specifications:
39
40=over
41
42=item RFC4871, for DKIM
43
44=item RFC4870, for DomainKeys
45
46=back
47
48The module uses an object-oriented interface. You use one of
49two different classes, depending on whether you are signing or verifying
50a message. To sign, use the L<Mail::DKIM::Signer> class. To verify, use
51the L<Mail::DKIM::Verifier> class. Simple, eh?
52
53#
54# This package was generated automatically with the cpan2rpm
55# utility.  To get this software or for more information
56# please visit: http://perl.arix.com/
57#
58
59%prep
60%setup -q -n %{pkgname}-%{version}
61chmod -R u+w %{_builddir}/%{pkgname}-%{version}
62
63%build
64grep -rsl '^#!.*perl' . |
65grep -v '.bak$' |xargs --no-run-if-empty \
66%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
67CFLAGS="$RPM_OPT_FLAGS"
68%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '` INSTALLDIRS=vendor
69%{__make}
70%if %maketest
71%{__make} test
72%endif
73
74%install
75[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
76
77%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
78
79cmd=/usr/share/spec-helper/compress_files
80[ -x $cmd ] || cmd=/usr/lib/rpm/brp-compress
81[ -x $cmd ] && $cmd
82
83# SuSE Linux
84if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
85then
86    %{__mkdir_p} %{buildroot}/var/adm/perl-modules
87    %{__cat} `find %{buildroot} -name "perllocal.pod"`  \
88        | %{__sed} -e s+%{buildroot}++g                 \
89        > %{buildroot}/var/adm/perl-modules/%{name}
90fi
91
92# remove special files
93find %{buildroot} -name "perllocal.pod" \
94    -o -name ".packlist"                \
95    -o -name "*.bs"                     \
96    |xargs -i rm -f {}
97
98# no empty directories
99find %{buildroot}%{_prefix}             \
100    -type d -depth                      \
101    -exec rmdir {} \; 2>/dev/null
102
103%{__perl} -MFile::Find -le '
104    find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
105    print "%doc  TODO scripts Changes README";
106    for my $x (sort @dirs, @files) {
107        push @ret, $x unless indirs($x);
108        }
109    print join "\n", sort @ret;
110
111    sub wanted {
112        return if /auto$/;
113
114        local $_ = $File::Find::name;
115        my $f = $_; s|^\Q%{buildroot}\E||;
116        return unless length;
117        return $files[@files] = $_ if -f $f;
118
119        $d = $_;
120        /\Q$d\E/ && return for reverse sort @INC;
121        $d =~ /\Q$_\E/ && return
122            for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
123
124        $dirs[@dirs] = $_;
125        }
126
127    sub indirs {
128        my $x = shift;
129        $x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
130        }
131    ' > %filelist
132
133[ -z %filelist ] && {
134    echo "ERROR: empty %files listing"
135    exit -1
136    }
137
138%clean
139[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
140
141%files -f %filelist
142%defattr(-,root,root)
143
144%changelog
145* Thu Feb  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.40-3
146- added BR: perl(Crypt::OpenSSL::RSA), perl(Net::DNS)
147- moved to Development/Libraries
148
149* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-2
150- rebuilt with perl-5.16.3.
151
152* Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40-1
153- new upstream release.
154
155* Fri Dec 02 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.39-1
156- Initial build.
Note: See TracBrowser for help on using the repository browser.