source: projects/specs/trunk/p/perl-MRO-Compat/perl-MRO-Compat-vl.spec @ 5844

Revision 5844, 4.6 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1# MRO is part of the Perl core since 5.9.5
2%global mro_in_core %(perl -e 'print $] > 5.009005 ? 1 : 0;')
3
4Name:           perl-MRO-Compat
5Version:        0.11
6Release:        1%{?_dist_release}
7Summary:        Mro::* interface compatibility for Perls < 5.9.5
8License:        GPL+ or Artistic
9Group:          Development/Libraries
10URL:            http://search.cpan.org/dist/MRO-Compat/
11Source0:        http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/MRO-Compat-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
13BuildArch:      noarch
14# Build
15BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.42
16# Module
17%if ! %{mro_in_core}
18BuildRequires:  perl(Class::C3) >= 0.20
19BuildRequires:  perl(Class::C3::XS) >= 0.08
20%endif
21# Test
22BuildRequires:  perl(Test::More) >= 0.47
23BuildRequires:  perl(Test::Pod)
24BuildRequires:  perl(Test::Pod::Coverage)
25# Runtime
26Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
27%if ! %{mro_in_core}
28Requires:       perl(Class::C3) >= 0.20
29Requires:       perl(Class::C3::XS) >= 0.08
30%endif
31
32%description
33The "mro" namespace provides several utilities for dealing with method
34resolution order and method caching in general in Perl 5.9.5 and higher.
35This module provides those interfaces for earlier versions of Perl (back
36to 5.6.0 anyways).
37
38It is a harmless no-op to use this module on 5.9.5+. That is to say,
39code which properly uses MRO::Compat will work unmodified on both older
40Perls and 5.9.5+.
41
42If you're writing a piece of software that would like to use the parts
43of 5.9.5+'s mro:: interfaces that are supported here, and you want
44compatibility with older Perls, this is the module for you.
45
46%prep
47%setup -q -n MRO-Compat-%{version}
48
49# Fix script interpreter
50perl -pi -e 's|^#!./perl|#!/usr/bin/perl|' t/15pkg_gen.t
51
52%build
53perl Makefile.PL INSTALLDIRS=vendor
54make %{?_smp_mflags}
55
56%install
57rm -rf %{buildroot}
58make pure_install DESTDIR=%{buildroot}
59find %{buildroot} -type f -name .packlist -exec rm -f {} \;
60find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
61%{_fixperms} %{buildroot}
62
63%check
64make test
65
66%clean
67rm -rf %{buildroot}
68
69%files
70%defattr(-,root,root,-)
71%doc ChangeLog README t/
72%{perl_vendorlib}/MRO/
73%{_mandir}/man3/MRO::Compat.3pm*
74
75%changelog
76* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
77- initial build for Vine Linux
78
79* Thu Jan 26 2012 Paul Howarth <paul@city-fan.org> - 0.11-9
80- Spec clean-up:
81  - Only require Class::C3 with perl < 5.9.5
82  - Require Class::C3::XS for performance and consistency, but only with
83    perl < 5.9.5
84  - Use DESTDIR rather than PERL_INSTALL_ROOT
85  - Make %%files list more explicit
86  - Classify buildreqs by build/module/test
87  - Don't use macros for commands
88  - Use tabs
89
90* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-8
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
92
93* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.11-7
94- Perl mass rebuild
95
96* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-6
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
98
99* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-5
100- Rebuild to fix problems with vendorarch/lib (#661697)
101
102* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-4
103- Mass rebuild with perl-5.12.0
104
105* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.11-3
106- Rebuild against perl 5.10.1
107
108* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
110
111* Tue Jun 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.11-1
112- Auto-update to 0.11 (by cpan-spec-update 0.01)
113- Altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
114- Altered br on perl(Class::C3) (0.19 => 0.20)
115
116* Thu Apr 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.10-1
117- Update to 0.10
118
119* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.09-2
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
121
122* Sat Jun 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.09
123- Update to 0.09
124
125* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.07-1
126- Update to 0.07
127
128* Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.05-6
129- Rebuild for new perl
130
131* Thu Dec 06 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-5
132- Bump
133
134* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-4
135- Update INstall -> install
136
137* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-3
138- Add Test::Pod deps
139
140* Tue Dec 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-2
141- Make Class::C3 dep explicit
142
143* Tue Sep 18 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-1
144- Specfile autogenerated by cpanspec 1.71
Note: See TracBrowser for help on using the repository browser.