source: projects/specs/trunk/p/perl-MRO-Compat/perl-MRO-Compat-vl.spec @ 12120

Revision 12120, 4.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# MRO is part of the Perl core since 5.9.5
2%global mro_in_core %(perl -e 'print $] > 5.009005 ? 1 : 0;')
3
4Name:           perl-MRO-Compat
5Version:        0.13
6Release:        1%{?_dist_release}
7Summary:        Mro::* interface compatibility for Perls < 5.9.5
8License:        GPL+ or Artistic
9Group:          Development/Libraries
10URL:            http://search.cpan.org/dist/MRO-Compat/
11Source0:        http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/MRO-Compat-%{version}.tar.gz
12
13Vendor:        Project Vine
14Distribution:  Vine Linux
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildArch:      noarch
18# Build
19BuildRequires:  perl(ExtUtils::MakeMaker)
20# Module
21%if ! %{mro_in_core}
22BuildRequires:  perl(Class::C3)
23BuildRequires:  perl(Class::C3::XS)
24%endif
25# Test
26BuildRequires:  perl(Test::More)
27BuildRequires:  perl(Test::Pod)
28BuildRequires:  perl(Test::Pod::Coverage)
29# Runtime
30Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
31%if ! %{mro_in_core}
32Requires:       perl(Class::C3)
33Requires:       perl(Class::C3::XS)
34%endif
35
36%description
37The "mro" namespace provides several utilities for dealing with method
38resolution order and method caching in general in Perl 5.9.5 and higher.
39This module provides those interfaces for earlier versions of Perl (back
40to 5.6.0 anyways).
41
42It is a harmless no-op to use this module on 5.9.5+. That is to say,
43code which properly uses MRO::Compat will work unmodified on both older
44Perls and 5.9.5+.
45
46If you're writing a piece of software that would like to use the parts
47of 5.9.5+'s mro:: interfaces that are supported here, and you want
48compatibility with older Perls, this is the module for you.
49
50%prep
51%setup -q -n MRO-Compat-%{version}
52
53# Fix script interpreter
54perl -pi -e 's|^#!./perl|#!/usr/bin/perl|' t/15pkg_gen.t
55
56%build
57perl Makefile.PL INSTALLDIRS=vendor
58make %{?_smp_mflags}
59
60%install
61rm -rf %{buildroot}
62make pure_install DESTDIR=%{buildroot}
63find %{buildroot} -type f -name .packlist -exec rm -f {} \;
64find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
65%{_fixperms} %{buildroot}
66
67%check
68make test
69
70%clean
71rm -rf %{buildroot}
72
73%files
74%defattr(-,root,root,-)
75%doc ChangeLog README t/
76%{perl_vendorlib}/MRO/
77%{_mandir}/man3/MRO::Compat.3pm*
78
79%changelog
80* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.13-1
81- new upstream release.
82- rebuilt with perl-5.26.
83
84* Wed Dec 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12-1
85- updated to 0.12
86- built with perl 5.16.3
87
88* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
89- initial build for Vine Linux
90
91* Thu Jan 26 2012 Paul Howarth <paul@city-fan.org> - 0.11-9
92- Spec clean-up:
93  - Only require Class::C3 with perl < 5.9.5
94  - Require Class::C3::XS for performance and consistency, but only with
95    perl < 5.9.5
96  - Use DESTDIR rather than PERL_INSTALL_ROOT
97  - Make %%files list more explicit
98  - Classify buildreqs by build/module/test
99  - Don't use macros for commands
100  - Use tabs
101
102* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-8
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
104
105* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.11-7
106- Perl mass rebuild
107
108* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-6
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
110
111* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-5
112- Rebuild to fix problems with vendorarch/lib (#661697)
113
114* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-4
115- Mass rebuild with perl-5.12.0
116
117* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.11-3
118- Rebuild against perl 5.10.1
119
120* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
122
123* Tue Jun 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.11-1
124- Auto-update to 0.11 (by cpan-spec-update 0.01)
125- Altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
126- Altered br on perl(Class::C3) (0.19 => 0.20)
127
128* Thu Apr 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.10-1
129- Update to 0.10
130
131* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.09-2
132- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
133
134* Sat Jun 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.09
135- Update to 0.09
136
137* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.07-1
138- Update to 0.07
139
140* Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.05-6
141- Rebuild for new perl
142
143* Thu Dec 06 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-5
144- Bump
145
146* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-4
147- Update INstall -> install
148
149* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-3
150- Add Test::Pod deps
151
152* Tue Dec 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-2
153- Make Class::C3 dep explicit
154
155* Tue Sep 18 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-1
156- Specfile autogenerated by cpanspec 1.71
Note: See TracBrowser for help on using the repository browser.