source: projects/specs/trunk/p/perl-MRO-Compat/perl-MRO-Compat-vl.spec @ 9143

Revision 9143, 4.7 KB checked in by inagaki, 9 years ago (diff)

2014-12-11 Ryoichi INAGAKI <ryo1@…>

  • perl-Apache-Htpasswd, perl-Cache-Cache, perl-MRO-Compat, perl-Parse-RecDescent?, perl-Pod-{Eventual, POM, Tests}, perl-Proc-{ProcessTable?, Simpler}: updated
  • perl-Parse-Nessus-NBE: rebuilt


Line 
1# MRO is part of the Perl core since 5.9.5
2%global mro_in_core %(perl -e 'print $] > 5.009005 ? 1 : 0;')
3
4Name:           perl-MRO-Compat
5Version:        0.12
6Release:        1%{?_dist_release}
7Summary:        Mro::* interface compatibility for Perls < 5.9.5
8License:        GPL+ or Artistic
9Group:          Development/Libraries
10URL:            http://search.cpan.org/dist/MRO-Compat/
11Source0:        http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/MRO-Compat-%{version}.tar.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildArch:      noarch
15# Build
16BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.42
17# Module
18%if ! %{mro_in_core}
19BuildRequires:  perl(Class::C3) >= 0.20
20BuildRequires:  perl(Class::C3::XS) >= 0.08
21%endif
22# Test
23BuildRequires:  perl(Test::More) >= 0.47
24BuildRequires:  perl(Test::Pod)
25BuildRequires:  perl(Test::Pod::Coverage)
26# Runtime
27Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
28%if ! %{mro_in_core}
29Requires:       perl(Class::C3) >= 0.20
30Requires:       perl(Class::C3::XS) >= 0.08
31%endif
32
33%description
34The "mro" namespace provides several utilities for dealing with method
35resolution order and method caching in general in Perl 5.9.5 and higher.
36This module provides those interfaces for earlier versions of Perl (back
37to 5.6.0 anyways).
38
39It is a harmless no-op to use this module on 5.9.5+. That is to say,
40code which properly uses MRO::Compat will work unmodified on both older
41Perls and 5.9.5+.
42
43If you're writing a piece of software that would like to use the parts
44of 5.9.5+'s mro:: interfaces that are supported here, and you want
45compatibility with older Perls, this is the module for you.
46
47%prep
48%setup -q -n MRO-Compat-%{version}
49
50# Fix script interpreter
51perl -pi -e 's|^#!./perl|#!/usr/bin/perl|' t/15pkg_gen.t
52
53%build
54perl Makefile.PL INSTALLDIRS=vendor
55make %{?_smp_mflags}
56
57%install
58rm -rf %{buildroot}
59make pure_install DESTDIR=%{buildroot}
60find %{buildroot} -type f -name .packlist -exec rm -f {} \;
61find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
62%{_fixperms} %{buildroot}
63
64%check
65make test
66
67%clean
68rm -rf %{buildroot}
69
70%files
71%defattr(-,root,root,-)
72%doc ChangeLog README t/
73%{perl_vendorlib}/MRO/
74%{_mandir}/man3/MRO::Compat.3pm*
75
76%changelog
77* Wed Dec 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12-1
78- updated to 0.12
79- built with perl 5.16.3
80
81* Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
82- initial build for Vine Linux
83
84* Thu Jan 26 2012 Paul Howarth <paul@city-fan.org> - 0.11-9
85- Spec clean-up:
86  - Only require Class::C3 with perl < 5.9.5
87  - Require Class::C3::XS for performance and consistency, but only with
88    perl < 5.9.5
89  - Use DESTDIR rather than PERL_INSTALL_ROOT
90  - Make %%files list more explicit
91  - Classify buildreqs by build/module/test
92  - Don't use macros for commands
93  - Use tabs
94
95* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-8
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
97
98* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.11-7
99- Perl mass rebuild
100
101* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-6
102- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
103
104* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-5
105- Rebuild to fix problems with vendorarch/lib (#661697)
106
107* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-4
108- Mass rebuild with perl-5.12.0
109
110* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.11-3
111- Rebuild against perl 5.10.1
112
113* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
115
116* Tue Jun 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.11-1
117- Auto-update to 0.11 (by cpan-spec-update 0.01)
118- Altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
119- Altered br on perl(Class::C3) (0.19 => 0.20)
120
121* Thu Apr 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.10-1
122- Update to 0.10
123
124* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.09-2
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Sat Jun 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.09
128- Update to 0.09
129
130* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.07-1
131- Update to 0.07
132
133* Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.05-6
134- Rebuild for new perl
135
136* Thu Dec 06 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-5
137- Bump
138
139* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-4
140- Update INstall -> install
141
142* Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-3
143- Add Test::Pod deps
144
145* Tue Dec 04 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-2
146- Make Class::C3 dep explicit
147
148* Tue Sep 18 2007 Chris Weyl <cweyl@alumni.drew.edu> - 0.05-1
149- Specfile autogenerated by cpanspec 1.71
Note: See TracBrowser for help on using the repository browser.