source: projects/specs/trunk/p/perl-MIME-tools/perl-MIME-tools-vl.spec @ 521

Revision 521, 2.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: modules for parsing (and creating!) MIME entities with Perl
2Name: perl-MIME-tools
3Version: 5.426
4Release: 1%{_dist_release}
5License: Perl's
6Group: Development/Languages
7Source0:http://search.cpan.org/CPAN/authors/id/E/ER/ERYQ/MIME-tools-%{version}.tar.gz
8Url: http://search.cpan.org/author/ERYQ/MIME-tools/
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: perl >= 5.004 perl-IO-stringy perl-MailTools
11Requires: perl >= 5.004 perl-IO-stringy perl-MailTools
12Vendor: Project Vine
13Distribution: Vine Linux
14BuildArch: noarch
15
16%description
17MIME-tools is a collection of Perl5 MIME:: modules for parsing,
18decoding, *and generating* single- or multipart (even nested multipart)
19MIME messages. (Yes, kids, that means you can send messages with
20attached GIF files).
21
22%prep
23%setup -q -n MIME-tools-%{version}
24
25%build
26CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=%{buildroot}%{_prefix} INSTALLDIRS=vendor
27make %{?_smp_mflags}
28make test
29
30%clean
31rm -rf $RPM_BUILD_ROOT
32
33%install
34rm -rf $RPM_BUILD_ROOT
35mkdir -p $RPM_BUILD_ROOT%{_prefix}
36make PREFIX=$RPM_BUILD_ROOT%{_prefix} install
37
38find $RPM_BUILD_ROOT%{_prefix} -type f -print |
39        sed "s@^$RPM_BUILD_ROOT@@g" |
40        grep -v ^%{_mandir} |
41        grep -v perllocal.pod |
42        grep -v "\.packlist" > %{name}.files
43if [ "$(cat %{name}.files)X" = "X" ] ; then
44    echo "ERROR: EMPTY FILE LIST"
45    exit -1
46fi
47
48%files -f %{name}.files
49%defattr(-,root,root)
50%doc COPYING ChangeLog MANIFEST README README-OR-DIE README.system examples
51%{_mandir}/*/*
52%dir %{perl_vendorlib}/MIME
53%dir %{perl_vendorlib}/MIME/Parser
54%dir %{perl_vendorlib}/MIME/Decoder
55%dir %{perl_vendorlib}/MIME/Field
56
57%changelog
58* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.426-1
59- new upstream release.
60- built with perl-5.10.0.
61- moved files to %%{perl_vendorlib}.
62
63* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 5.415-0vl1
64- new upstream release
65- build on perl-5.8.6-0vl1
66- drop unnecessary patch ( Patch0 )
67
68* Sat Nov 13 2004 IWAI, Masaharu <iwai@alib.jp> 5.411a-0vl4
69- SECURITY FIX: add empty boundary patch ( Patch0 )
70  - http://lists.roaringpenguin.com/pipermail/mimedefang/2004-October/024959.html
71
72* Tue Apr 29 2003 IWAI Masaharu <iwai@alib.jp> 5.411a-0vl3
73- build with perl-5.8.0
74
75* Sun Nov  3 2002 IWAI Masaharu <iwai@alib.jp> 5.411a-0vl2
76- update Summary and Description
77
78* Sun Nov  3 2002 IWAI Masaharu <iwai@alib.jp> 5.411a-0vl1
79- first build for Vine Linux
80
Note: See TracBrowser for help on using the repository browser.