source: projects/specs/trunk/p/perl-Log-Log4perl/perl-Log-Log4perl-vl.spec @ 8708

Revision 8708, 2.3 KB checked in by daisuke, 10 years ago (diff)

perl-*: rebuild with perl 5.16

  • update: Data-OptList?, Log-Dispatch,Log-Log4perl,

Package-Stash, Package-Stash-XS, Sub-Install

Line 
1%define pkgname Log-Log4perl
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.44
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/M/MS/MSCHILLI/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Log::Log4perl - Log4j implementation for Perl
17Summary(ja):    Log::Log4perl - Perl 向け Log4j 実装
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26Log::Log4perl lets you remote-control and fine-tune the logging
27behaviour of your system from the outside. It implements the widely
28popular (Java-based) Log4j logging package in pure Perl.
29
30For a detailed tutorial on Log::Log4perl usage, please read
31
32    http://www.perl.com/pub/a/2002/09/11/log4perl.html
33
34
35%description -l ja
36Log::Log4perl により、外部からシステムのログ取得を遠隔操作および微調整できま
37す。広く普及された (Java ベースの) Log4j ロギングパッケージを純粋な Perl で
38実装しています。
39
40Log::Log4perl の使い方に関するより詳細なチュートリアルは、
41
42    http://www.perl.com/pub/a/2002/09/11/log4perl.html
43
44を読んでください。
45
46%prep
47%setup -q -n %{pkgname}-%{version}
48
49%build
50perl Makefile.PL
51%{__make}
52
53%install
54%{__rm} -rf ${RPM_BUILD_ROOT}
55%{__make} install DESTDIR=${RPM_BUILD_ROOT}
56
57find $RPM_BUILD_ROOT%{_prefix} -type f -print |
58        sed "s@^$RPM_BUILD_ROOT@@g" |
59        grep -v ^%{_mandir} |
60        grep -v perllocal.pod |
61        grep -v "\.packlist" > %{name}.files
62
63if [ "$(cat %{name}.files)X" = "X" ] ; then
64        echo "ERROR: EMPTY FILE LIST"
65        exit -1
66fi
67
68# remove unnecessary files.
69%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
70find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
71find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
72
73
74%clean
75%{__rm} -rf ${RPM_BUILD_ROOT}
76
77
78%files -f %{name}.files
79%defattr(-,root,root)
80%doc Changes LICENSE README
81
82%changelog
83* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.44-1
84- update to 1.44
85
86* Wed Feb 22 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.35-1
87- initial build for Vine Linux
88
Note: See TracBrowser for help on using the repository browser.