source: projects/specs/trunk/p/perl-Log-Log4perl/perl-Log-Log4perl-vl.spec @ 12120

Revision 12120, 2.5 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

RevLine 
[5730]1%define pkgname Log-Log4perl
2
3# Basic Information
4Name:           perl-%{pkgname}
[12120]5Version:        1.49
[5730]6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/M/MS/MSCHILLI/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Log::Log4perl - Log4j implementation for Perl
17Summary(ja):    Log::Log4perl - Perl 向け Log4j 実装
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
[12120]25#global __requires_exclude %{?__provides_exclude:%__provides_exclude|}perl\\(Log::Dispatch
26
[5730]27%description
28Log::Log4perl lets you remote-control and fine-tune the logging
29behaviour of your system from the outside. It implements the widely
30popular (Java-based) Log4j logging package in pure Perl.
31
32For a detailed tutorial on Log::Log4perl usage, please read
33
34    http://www.perl.com/pub/a/2002/09/11/log4perl.html
35
36
37%description -l ja
38Log::Log4perl により、外部からシステムのログ取得を遠隔操作および微調整できま
39す。広く普及された (Java ベースの) Log4j ロギングパッケージを純粋な Perl で
40実装しています。
41
42Log::Log4perl の使い方に関するより詳細なチュートリアルは、
43
44    http://www.perl.com/pub/a/2002/09/11/log4perl.html
45
46を読んでください。
47
48%prep
[8708]49%setup -q -n %{pkgname}-%{version}
[5730]50
51%build
52perl Makefile.PL
53%{__make}
54
55%install
56%{__rm} -rf ${RPM_BUILD_ROOT}
57%{__make} install DESTDIR=${RPM_BUILD_ROOT}
58
59find $RPM_BUILD_ROOT%{_prefix} -type f -print |
60        sed "s@^$RPM_BUILD_ROOT@@g" |
61        grep -v ^%{_mandir} |
62        grep -v perllocal.pod |
63        grep -v "\.packlist" > %{name}.files
64
65if [ "$(cat %{name}.files)X" = "X" ] ; then
66        echo "ERROR: EMPTY FILE LIST"
67        exit -1
68fi
69
70# remove unnecessary files.
71%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
72find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
73find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
74
75
76%clean
77%{__rm} -rf ${RPM_BUILD_ROOT}
78
79
80%files -f %{name}.files
81%defattr(-,root,root)
[12120]82%license LICENSE
83%doc Changes README
[5730]84
85%changelog
[12120]86* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.49-1
87- new upstream release.
88- rebuilt with perl-5.26.
89
[8708]90* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.44-1
91- update to 1.44
92
[5730]93* Wed Feb 22 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.35-1
94- initial build for Vine Linux
95
Note: See TracBrowser for help on using the repository browser.