source: projects/specs/trunk/p/perl-Log-Dump/perl-Log-Dump-vl.spec @ 4913

Revision 4913, 2.0 KB checked in by yasumichi, 13 years ago (diff)

Import spec file.

Line 
1%define pkgname Log-Dump
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.09
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        simple logger mainly for debugging
17Summary(ja):    主にデバッグのための簡単なロガー
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26Log::Dump is a simple logger mix-in mainly for debugging. This installs five
27methods into a caller (the class that used Log::Dump) via Sub::Install. The
28point is you don't need to load extra dumper modules or you don't need to
29concatenate messages. Just log things and they will be dumped (and
30concatenated if necessary) to stderr, and to a file if you prefer. Also, you
31can use these logging methods as class methods or object methods (though
32usually you don't want to mix them, especially when you're doing something
33special).
34
35#%%description -l ja
36
37%prep
38%setup -q -n Log-Dump-0.09
39
40%build
41perl Makefile.PL
42%{__make}
43
44%install
45%{__rm} -rf ${RPM_BUILD_ROOT}
46%{__make} install DESTDIR=${RPM_BUILD_ROOT}
47
48find $RPM_BUILD_ROOT%{_prefix} -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v ^%{_mandir} |
51        grep -v perllocal.pod |
52        grep -v "\.packlist" > %{name}.files
53if [ "$(cat %{name}.files)X" = "X" ] ; then
54        echo "ERROR: EMPTY FILE LIST"
55        exit -1
56fi
57
58# remove unnecessary files.
59%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
60%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Log/Dump/.packlist
61
62
63%clean
64%{__rm} -rf ${RPM_BUILD_ROOT}
65
66
67%files -f %{name}.files
68%defattr(-,root,root)
69%doc Changes README
70%dir %{perl_sitelib}/Log/Dump
71%{_mandir}/*/*
72
73%changelog
74* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.09-1
75- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.