source: projects/specs/trunk/p/perl-Log-Dispatch/perl-Log-Dispatch-vl.spec @ 8708

Revision 8708, 3.1 KB checked in by daisuke, 10 years ago (diff)

perl-*: rebuild with perl 5.16

  • update: Data-OptList?, Log-Dispatch,Log-Log4perl,

Package-Stash, Package-Stash-XS, Sub-Install

Line 
1%define pkgname Log-Dispatch
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        2.41
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Log::Dispatch - Dispatches messages to one or more outputs
18Summary(ja):    Log::Dispatch - 1 つ以上の出力へのメッセージの急送
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27This module manages a set of Log::Dispatch::* output objects that can be
28logged to via a unified interface.
29
30The idea is that you create a Log::Dispatch object and then add various
31logging objects to it (such as a file logger or screen logger). Then you
32call the log method of the dispatch object, which passes the message to each
33of the objects, which in turn decide whether or not to accept the message
34and what to do with it.
35
36This makes it possible to call single method and send a message to a log
37file, via email, to the screen, and anywhere else, all with very little code
38needed on your part, once the dispatching object has been created.
39
40%description -l ja
41このモジュールは、統一されたインターフェース経由でログを記録できる
42Log::Dispatch::* 出力オブジェクトのセットを管理します。
43
44このアイディアは、Log::Dispatch オブジェクトを作成し、(ファイルロガーや
45スクリーンロガーといった)さまざまなログ記録オブジェクトを追加します。
46それから、dispatch オブジェクトのメソッドを呼び出します。このメソッドは、
47メッセージをそれぞれのオブジェクトへ渡し、それぞれのオブジェクトはメッセージ
48を受理すべきかどうか決定します。
49
50これにより単一のメソッドを呼び出して一旦、dispatching オブジェクトが生成され
51たならば、ログファイル、E-メール経由、画面やその他すべてに僅かなコードで
52メッセージを送信できます。
53
54%prep
55%setup -q -n %{pkgname}-%{version}
56
57%build
58perl Makefile.PL
59%{__make}
60
61%install
62%{__rm} -rf ${RPM_BUILD_ROOT}
63%{__make} install DESTDIR=${RPM_BUILD_ROOT}
64
65find $RPM_BUILD_ROOT%{_prefix} -type f -print |
66        sed "s@^$RPM_BUILD_ROOT@@g" |
67        grep -v ^%{_mandir} |
68        grep -v perllocal.pod |
69        grep -v "\.packlist" > %{name}.files
70
71if [ "$(cat %{name}.files)X" = "X" ] ; then
72        echo "ERROR: EMPTY FILE LIST"
73        exit -1
74fi
75
76# remove unnecessary files.
77%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
78%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Log/Dispatch/.packlist
79
80
81%clean
82%{__rm} -rf ${RPM_BUILD_ROOT}
83
84
85%files -f %{name}.files
86%defattr(-,root,root)
87%doc Changes LICENSE README
88
89%changelog
90* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 2.41-1
91- update to 2.41
92
93* Sat Jan 21 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.29-1
94- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.