source: projects/specs/trunk/p/perl-Log-Dispatch-FileRotate/perl-Log-Dispatch-FileRotate-vl.spec @ 5665

Revision 5665, 1.9 KB checked in by yasumichi, 12 years ago (diff)

first import

Line 
1%define pkgname Log-Dispatch-FileRotate
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.19
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/M/MA/MARKPF/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Log::Dispatch::FileRotate - Log to files that archive/rotate themselves
18#Summary(ja):   
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27This module provides a simple object for logging to files under the
28Log::Dispatch::* system, and automatically rotating them according to
29different constraints. This is basically a Log::Dispatch::File wrapper
30with additions. To that end the arguments
31
32        name, min_level, filename and  mode
33
34behave the same as Log::Dispatch::File. So see its man page (perldoc
35Log::Dispatch::File)
36
37#%%description -l ja
38
39%prep
40%setup -q -n Log-Dispatch-FileRotate-1.19
41
42%build
43perl Makefile.PL
44%{__make}
45
46%install
47%{__rm} -rf ${RPM_BUILD_ROOT}
48%{__make} install DESTDIR=${RPM_BUILD_ROOT}
49
50find $RPM_BUILD_ROOT%{_prefix} -type f -print |
51        sed "s@^$RPM_BUILD_ROOT@@g" |
52        grep -v ^%{_mandir} |
53        grep -v perllocal.pod |
54        grep -v "\.packlist" > %{name}.files
55
56if [ "$(cat %{name}.files)X" = "X" ] ; then
57        echo "ERROR: EMPTY FILE LIST"
58        exit -1
59fi
60
61# remove unnecessary files.
62%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
63find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
64find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
65
66
67%clean
68%{__rm} -rf ${RPM_BUILD_ROOT}
69
70
71%files -f %{name}.files
72%defattr(-,root,root)
73%doc Changes README
74
75%changelog
76* Thu Jan 26 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.19-1
77- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.