source: projects/specs/trunk/p/perl-List-MoreUtils/perl-List-MoreUtils-vl.spec @ 12120

Revision 12120, 5.4 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# define bootstrap for initial build
2%define perl_bootstrap 1
3
4Name:           perl-List-MoreUtils
5Version:        0.428
6Release:        1%{?_dist_release}
7Summary:        Provide the stuff missing in List::Util
8Group:          Development/Libraries
9License:        GPL+ or Artistic
10URL:            http://search.cpan.org/dist/List-MoreUtils/
11Source0:        http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/List-MoreUtils-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
13BuildArch:      noarch
14BuildRequires:  perl(Exporter::Tiny)
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(List::MoreUtils::XS)
17BuildRequires:  perl(Pod::Simple)
18#BuildRequires: perl(Test::CPAN::Meta)
19BuildRequires:  perl(Test::LeakTrace)
20# Test::MinimumVersion -> Perl::MinimumVersion -> PPI -> List::MoreUtils
21%if 0%{!?perl_bootstrap:1}
22BuildRequires:  perl(Test::MinimumVersion)
23%endif
24BuildRequires:  perl(Test::More)
25BuildRequires:  perl(Test::Pod)
26Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
27
28# Don't "provide" private Perl libs
29%{?perl_default_filter}
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33Packager:       shaolin
34
35%description
36List::MoreUtils provides some trivial but commonly needed functionality
37on lists that is not going to go into List::Util.
38
39%prep
40%setup -q -n List-MoreUtils-%{version}
41
42%build
43perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
44make %{?_smp_mflags}
45
46%install
47rm -rf %{buildroot}
48make pure_install DESTDIR=%{buildroot}
49find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
50find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
51find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
52%{_fixperms} %{buildroot}
53
54%check
55make test
56make test TEST_FILES="xt/*.t" AUTOMATED_TESTING=1
57
58%clean
59rm -rf %{buildroot}
60
61%files
62%defattr(-,root,root,-)
63%license LICENSE
64%doc Changes README
65%{perl_vendorlib}/List/
66%{_mandir}/man3/*
67
68%changelog
69* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.428-1
70- new upstream release.
71- rebuilt with perl-5.26.
72
73* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.33-2
74- rebuilt with perl-5.16.3.
75
76* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.33-1
77- initial build for Vine Linux
78
79* Tue Jan 24 2012 Paul Howarth <paul@city-fan.org> - 0.33-1
80- Update to 0.33
81  - Updated can_xs to fix a bug in it
82- Reinstate compatibility with old distributions like EL-5
83- Drop Test::More version requirement to 0.42
84- BR: perl(ExtUtils::MakeMaker)
85- BR: perl(Test::LeakTrace) except on EL-4/EL-5 where it's not available
86- BR: perl(Pod::Simple), perl(Test::CPAN::Meta), perl(Test::MinimumVersion)
87  (if we're not bootstrapping) and perl(Test::Pod), and run the developer tests
88  too
89- Don't use macros for commands
90- Use %%{_fixperms} macro rather than our own chmod incantation
91- Make %%files list more specific
92- Use tabs
93
94* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.32-4
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
96
97* Mon Jul 18 2011 Petr Sabata <contyk@redhat.com> - 0.32-3
98- Perl mass rebuild
99
100* Tue Jul 12 2011 Tom Callaway <spot@fedoraproject.org> - 0.32-2
101- Rebuild to fix broken rawhide deps
102
103* Sat Jul 02 2011 Iain Arnell <iarnell@gmail.com> - 0.32-1
104- Update to latest upstream version
105
106* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.30-3
107- Perl mass rebuild
108
109* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.30-2
110- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
111
112* Mon Jan 03 2011 Iain Arnell <iarnell@gmail.com> - 0.30-1
113- Update to latest upstream version
114- Clean up spec for modern rpmbuild
115- Use perl_default_filter
116- Remove unnecessary buildrequires
117
118* Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.22-12
119- Rebuild to fix problems with vendorarch/lib (#661697)
120
121* Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.22-11
122- Mass rebuild with perl-5.12.0
123
124* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.22-10
125- Rebuild against perl 5.10.1
126
127* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22-9
128- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
129
130* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22-8
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
132
133* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22-7
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
135
136* Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.22-6
137- Rebuild normally, second pass
138
139* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.22-5
140- Rebuild for perl 5.10 (again), tests disabled for first pass
141
142* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.22-4
143- Autorebuild for GCC 4.3
144
145* Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.22-3
146- Rebuild normally, second pass
147
148* Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.22-2.1
149- Rebuild for new perl, first pass, disable TPC and tests
150
151* Sun Sep 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-2
152- Rebuild for FC6
153
154* Mon Jul  3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-1
155- Update to 0.22
156
157* Mon Jun 19 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.21-1
158- Update to 0.21
159
160* Sat Jun 10 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.20-1
161- Update to 0.20
162
163* Sat Apr 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.19-1
164- First build
Note: See TracBrowser for help on using the repository browser.