source: projects/specs/trunk/p/perl-List-MoreUtils-XS/perl-List-MoreUtils-XS-vl.spec @ 12120

Revision 12120, 5.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-List-MoreUtils-XS
2Version:        0.428
3Release:        6%{?_dist_release}
4Summary:        Provide compiled List::MoreUtils functions
5# Code from List-MoreUtils < 0.417 is GPL+ or Artistic
6# Anything after that is ASL 2.0
7# "git blame" on the upstream repo will probably be needed to
8# determine the license of any particular chunk of code
9License:        (GPL+ or Artistic) and ASL 2.0
10URL:            https://metacpan.org/release/List-MoreUtils-XS
11Source0:        https://cpan.metacpan.org/authors/id/R/RE/REHSACK/List-MoreUtils-XS-%{version}.tar.gz
12Patch0:         List-MoreUtils-XS-0.428-unbundle.patch
13
14Vendor:        Project Vine
15Distribution:  Vine Linux
16
17# Module Build
18BuildRequires:  coreutils
19BuildRequires:  findutils
20BuildRequires:  gcc
21BuildRequires:  make
22BuildRequires:  perl >= 2:5.26.2
23BuildRequires:  perl(Capture::Tiny)
24BuildRequires:  perl(Config::AutoConf)
25BuildRequires:  perl(ExtUtils::CBuilder)
26# Module Runtime
27BuildRequires:  perl(base)
28BuildRequires:  perl(Exporter)
29BuildRequires:  perl(strict)
30BuildRequires:  perl(vars)
31BuildRequires:  perl(warnings)
32BuildRequires:  perl(XSLoader)
33# Test Suite
34BuildRequires:  perl(JSON::PP)
35BuildRequires:  perl(List::Util)
36BuildRequires:  perl(Math::Trig)
37BuildRequires:  perl(overload)
38BuildRequires:  perl(Storable)
39BuildRequires:  perl(Test::Builder::Module)
40BuildRequires:  perl(Test::LeakTrace)
41BuildRequires:  perl(Test::More)
42BuildRequires:  perl(Tie::Array)
43# Runtime
44Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
45
46# Don't "provide" private Perl libs
47%{?perl_default_filter}
48
49%description
50This module provides accelerated versions of functions in List::MoreUtils.
51
52%prep
53%setup -q -n List-MoreUtils-XS-%{version}
54
55# Unbundle bundled modules except private inc::Config::AutoConf::LMU
56%patch0
57find inc/ -type f ! -name LMU.pm -print -delete
58
59%build
60perl Makefile.PL \
61        INSTALLDIRS=vendor \
62        OPTIMIZE="%{optflags}"\
63        NO_PERLLOCAL=1 \
64        NO_PACKLIST=1
65make %{?_smp_mflags}
66
67%install
68make install DESTDIR=%{buildroot}
69find %{buildroot} -type f -name '*.bs' -empty -delete
70%{_fixperms} -c %{buildroot}
71
72%check
73make test
74
75%files
76%license ARTISTIC-1.0 GPL-1 LICENSE
77%doc Changes MAINTAINER.md README.md
78%{perl_vendorarch}/auto/List/
79%{perl_vendorarch}/List/
80%{_mandir}/man3/List::MoreUtils::XS.3*
81
82%changelog
83* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.428-6
84- initial build for Vine Linux.
85- rebuilt with perl-5.26.
86
87* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-5
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
89
90* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-4
91- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
92
93* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.428-3
94- Perl 5.28 rebuild
95
96* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.428-2
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
98
99* Thu Dec 21 2017 Paul Howarth <paul@city-fan.org> - 0.428-1
100- Update to 0.428
101  - Fix build fails on perl ≥ 5.27.4 with -DDEBUGGING (CPAN RT#123613)
102  - Update ppport.h to 3.37 for improved blead support
103  - Fix context arg to croak() (CPAN RT#123869)
104  - Fix one() returning true on empty list (CPAN RT#123870)
105  - Pamper $a/$b/$_ refcounting bugs (CPAN RT#123868)
106
107* Tue Oct  3 2017 Paul Howarth <paul@city-fan.org> - 0.426-1
108- Update to 0.426
109  - Fix broken format in part (GH#4)
110  - Fix gcc 4.7 sequence point warning (GH#5)
111  - Fix incorrect padname resolving for perl > 5.21.6 (CPAN RT#122883)
112  - Fix compiling issue on CentOS 4 and CentOS 5
113
114* Sat Aug 19 2017 Paul Howarth <paul@city-fan.org> - 0.423-1
115- Update to 0.423
116  - Fix dealing with lists with one element on bremove/binsert (GH#2)
117  - Add support for compilers before C99
118  - Fix some 32-bit compiler warnings
119  - Add support for compilers without statement expression feature
120
121* Tue Aug 15 2017 Paul Howarth <paul@city-fan.org> - 0.422-1
122- Update to 0.422
123  - Rename 'occurances' into 'occurrences' (CPAN RT#91991, CPAN RT#122806)
124  - Add DESCRIPTION to Pod clarifying the role of List::MoreUtils::XS
125  - Improve Makefile.PL regarding some build artifacts
126
127* Tue Aug 15 2017 Paul Howarth <paul@city-fan.org> - 0.421-1
128- Update to 0.421
129  - Fix a lot of potential memory leaks when callbacks throw exceptions
130  - Add some new functions: qsort, binsert, bremove, listcmp, arrayify
131    (CPAN RT#17230), samples (CPAN RT#77562), minmaxstr (CPAN RT#106401),
132    lower_bound, upper_bound, equal_range, frequencies, occurances, mode
133    (CPAN RT#91991), zip6 (CPAN RT#42921), reduce_0, reduce_1, reduce_u
134  - Improve tests
135  - Make List::MoreUtils::XS independent from List::MoreUtils
136    Note that List::MoreUtils::XS doesn't guarantee API stability: this
137    feature is only provided through List::MoreUtils as frontend
138  - Improve configure toolchain to use Config::AutoConf 0.315
139  - Speed up some inner loops by hinting the expected result
140  - Fix mind screwed up issue in upper_bound and reduce elements visited in
141    equal_range
142  - Correct license in META (CPAN RT#122702)
143  - Fix issues with -DPERL_IMPLICIT_SYS on Windows with Strawberry-Perl
144
145* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.418-6
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
147
148* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.418-5
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
150
151* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.418-4
152- Perl 5.26 rebuild
153
154* Mon Apr  3 2017 Paul Howarth <paul@city-fan.org> - 0.418-3
155- Incorporate package review feedback (#1437588)
156  - Fix URL
157  - Unbundle bundled modules except private inc::Config::AutoConf::LMU
158
159* Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 0.418-2
160- Sanitize for Fedora submission
161
162* Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 0.418-1
163- Initial RPM version
Note: See TracBrowser for help on using the repository browser.