source: projects/specs/trunk/p/perl-LDAP/perl-LDAP-vl.spec @ 5793

Revision 5793, 5.8 KB checked in by shaolin, 12 years ago (diff)
  • rebuild
Line 
1Name:           perl-LDAP
2Version:        0.44
3Release:        2%{?_dist_release}
4Summary:        LDAP Perl module
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/perl-ldap/
9Source0:        http://www.cpan.org/authors/id/G/GB/GBARR/perl-ldap-%{version}.tar.gz
10
11BuildArch:      noarch
12# [Core Features]
13BuildRequires:  perl(Convert::ASN1)
14BuildRequires:  perl(IO::Socket::SSL)
15# [optional modules]
16BuildRequires:  perl(Authen::SASL) >= 2.00
17BuildRequires:  perl(URI::ldap) >= 1.1
18BuildRequires:  perl(MIME::Base64)
19BuildRequires:  perl(XML::SAX::Writer)
20# [test]
21BuildRequires:  perl(Test::More)
22BuildRequires:  perl(LWP::UserAgent)
23Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
24Requires:       perl(Authen::SASL)
25
26Provides:       perl-ldap = %{version}-%{release}
27Obsoletes:      perl-ldap < 0.44
28
29Vendor:         Project Vine
30Distribution:   Vine Linux
31Packager:       shaolin
32
33
34%description
35Net::LDAP is a collection of modules that implements a LDAP services API
36for Perl programs. The module may be used to search directories or perform
37maintenance functions such as adding, deleting or modifying entries.
38
39%description -l ja
40Net::LDAP は、LDAP サービス API を実装する Perl モジュール集です。
41このモジュールを使って、LDAP ディレクトリ検索や、LDAP エントリの
42追加・削除・修正などの機能を Perl から利用可能になります。
43
44
45%prep
46%setup -q -n perl-ldap-%{version}
47chmod -c 644 bin/* contrib/* lib/Net/LDAP/DSML.pm
48%{__perl} -pi -e 's|^#!/usr/local/bin/perl\b|#!%{__perl}|' contrib/*
49
50# Filter unwanted Provides:
51cat << \EOF > %{name}-prov
52#!/bin/sh
53%{__perl_provides} $* |\
54  sed -e '/perl(Net::LDAP::Filter)$/d'
55EOF
56
57%define __perl_provides %{_builddir}/perl-ldap-%{version}/%{name}-prov
58chmod +x %{__perl_provides}
59
60%build
61%{__perl} Makefile.PL INSTALLDIRS=vendor < /dev/null
62make %{?_smp_mflags}
63
64%install
65rm -rf %{buildroot}
66make pure_install DESTDIR=%{buildroot}
67find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
68find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
69chmod -R u+w %{buildroot}/*
70
71%check
72make test
73 
74%clean
75rm -rf %{buildroot}
76
77%files
78%doc Changes CREDITS
79%doc contrib/ bin/
80%{perl_vendorlib}/Bundle/
81%{perl_vendorlib}/LWP/
82%{perl_vendorlib}/Net/
83%{_mandir}/man3/*.3pm*
84
85
86%changelog
87* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.44-2
88- rebuild
89
90* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.44-1
91- renamed to perl-LDAP from perl-ldap for consistency
92- updated to 0.44
93- previous Vine changelog as follows:
94
95  - Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 0.3202-1vl5
96  - spec in utf-8
97  - applied vine5 versioning policy
98 
99  - Sun Sep 03 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3202-0vl2
100  - changed Group to Development/Libraries
101 
102  - Sun Apr 03 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3202-0vl1
103  - new upstream release
104 
105  - Tue Feb 08 2005 HOTTA Michihide <hotta@net-newbie.com> 0.31-0vl1
106  - Initial build for Vine Linux 3.1.
107 
108  - Mon Feb 23 2004  <yasuma@miraclelinux.com> 0.31-1
109  - Initial build.
110
111* Mon Feb  6 2012 Marcela Maslanova <mmaslano@redhat.com> - 1:0.44-1
112- update which should fix RT#66753
113- clean specfile according to new guidelines
114
115* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.40-6
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
117
118* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1:0.40-5
119- Perl mass rebuild
120
121* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.40-4
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
123
124* Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:0.40-3
125- 661697 rebuild for fixing problems with vendorach/lib
126
127* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:0.40-2
128- Mass rebuild with perl-5.12.0
129
130* Mon Apr 12 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:0.40-1
131- update
132
133* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1:0.34-7
134- rebuild against perl 5.10.1
135
136* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.34-6
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
138
139* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.34-5
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
141
142* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:0.34-4
143- rebuild for new perl
144
145* Mon Apr 09 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-3
146- Resolves: bz#226267
147- Only filter out the unversioned Provides: perl(Net::LDAP::Filter) to
148  avoid breaking dependencies.
149
150* Thu Apr 05 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-2
151- Resolves: bz#226267
152- Filter out provides perl(Net::LDAP::Filter) per package review.
153
154* Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-1
155- New version: 0.34
156
157* Wed Sep 27 2006 Robin Norwood <rnorwood@redhat.com> - 1:0.33-3
158- Bugzilla: 207430
159- Incorporate fixes from Jose Oliveira's patch
160- Add perl(IO::Socket::SSL) as a BuildRequires as well
161- Other cleanups from Jose
162
163* Wed Sep 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.33-1.3
164- Add a requirement for IO::Socket::SSL, per bug #122066
165
166* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
167- rebuild
168
169* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.33-1.2
170- rebuild for new perl-5.8.8
171
172* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
173- rebuilt for new gcc
174
175* Tue Apr 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.33-1
176- Update to 0.33.
177
178* Sat Apr 02 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.3202-1
179- Update to 0.3202.
180- Specfile cleanup. (#153766)
181
182* Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 0.31-5
183- rebuild
184
185* Wed Mar 10 2004 Chip Turner <cturner@redhat.com> - 0.31-1
186- Specfile autogenerated.
187
Note: See TracBrowser for help on using the repository browser.