source: projects/specs/trunk/p/perl-LDAP/perl-LDAP-vl.spec @ 9158

Revision 9158, 6.0 KB checked in by inagaki, 9 years ago (diff)

2014-12-16 Ryoichi INAGAKI <ryo1@…>

  • perl-DateTime?-TimeZone?, perl-LDAP: updated
  • perl-List-AllUtils?, perl-Test-Warnings: NEW
  • perl-Unicode-{Map, Map8, MapUTF8, String}: rebuilt
  • perl-X11-Protocol: rebuilt


Line 
1Name:           perl-LDAP
2Version:        0.64
3Release:        1%{?_dist_release}
4Summary:        LDAP Perl module
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/perl-ldap/
9Source0:        http://www.cpan.org/authors/id/G/GB/GBARR/perl-ldap-%{version}.tar.gz
10
11BuildArch:      noarch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13# [Core Features]
14BuildRequires:  perl(Convert::ASN1)
15BuildRequires:  perl(IO::Socket::SSL)
16# [optional modules]
17BuildRequires:  perl(Authen::SASL) >= 2.00
18BuildRequires:  perl(IO::Socket::INET6)
19BuildRequires:  perl(JSON)
20BuildRequires:  perl(URI::ldap) >= 1.1
21BuildRequires:  perl(MIME::Base64)
22BuildRequires:  perl(XML::SAX::Writer)
23# [test]
24BuildRequires:  perl(Test::More) >= 0.98
25BuildRequires:  perl(LWP::UserAgent)
26Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27Requires:       perl(Authen::SASL)
28
29Provides:       perl-ldap = %{version}-%{release}
30Obsoletes:      perl-ldap < 0.44
31
32Vendor:         Project Vine
33Distribution:   Vine Linux
34Packager:       shaolin
35
36
37%description
38Net::LDAP is a collection of modules that implements a LDAP services API
39for Perl programs. The module may be used to search directories or perform
40maintenance functions such as adding, deleting or modifying entries.
41
42%description -l ja
43Net::LDAP は、LDAP サービス API を実装する Perl モジュール集です。
44このモジュールを使って、LDAP ディレクトリ検索や、LDAP エントリの
45追加・削除・修正などの機能を Perl から利用可能になります。
46
47
48%prep
49%setup -q -n perl-ldap-%{version}
50chmod -c 644 bin/* contrib/* lib/Net/LDAP/DSML.pm
51%{__perl} -pi -e 's|^#!/usr/local/bin/perl\b|#!%{__perl}|' contrib/*
52
53# Filter unwanted Provides:
54cat << \EOF > %{name}-prov
55#!/bin/sh
56%{__perl_provides} $* |\
57  sed -e '/perl(Net::LDAP::Filter)$/d'
58EOF
59
60%define __perl_provides %{_builddir}/perl-ldap-%{version}/%{name}-prov
61chmod +x %{__perl_provides}
62
63%build
64%{__perl} Makefile.PL INSTALLDIRS=vendor < /dev/null
65make %{?_smp_mflags}
66
67%install
68rm -rf %{buildroot}
69make pure_install DESTDIR=%{buildroot}
70find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
71find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
72chmod -R u+w %{buildroot}/*
73
74%check
75make test
76 
77%clean
78rm -rf %{buildroot}
79
80%files
81%doc Changes CREDITS
82%doc contrib/ bin/
83%{perl_vendorlib}/Bundle/
84%{perl_vendorlib}/LWP/
85%{perl_vendorlib}/Net/
86%{_mandir}/man3/*.3pm*
87
88
89%changelog
90* Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.64-1
91- updated to 0.64
92- built with perl 5.16.3
93
94* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.44-2
95- rebuild
96
97* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.44-1
98- renamed to perl-LDAP from perl-ldap for consistency
99- updated to 0.44
100- previous Vine changelog as follows:
101
102  - Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 0.3202-1vl5
103  - spec in utf-8
104  - applied vine5 versioning policy
105 
106  - Sun Sep 03 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3202-0vl2
107  - changed Group to Development/Libraries
108 
109  - Sun Apr 03 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3202-0vl1
110  - new upstream release
111 
112  - Tue Feb 08 2005 HOTTA Michihide <hotta@net-newbie.com> 0.31-0vl1
113  - Initial build for Vine Linux 3.1.
114 
115  - Mon Feb 23 2004  <yasuma@miraclelinux.com> 0.31-1
116  - Initial build.
117
118* Mon Feb  6 2012 Marcela Maslanova <mmaslano@redhat.com> - 1:0.44-1
119- update which should fix RT#66753
120- clean specfile according to new guidelines
121
122* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.40-6
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
124
125* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1:0.40-5
126- Perl mass rebuild
127
128* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.40-4
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
130
131* Mon Dec 20 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:0.40-3
132- 661697 rebuild for fixing problems with vendorach/lib
133
134* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:0.40-2
135- Mass rebuild with perl-5.12.0
136
137* Mon Apr 12 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:0.40-1
138- update
139
140* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1:0.34-7
141- rebuild against perl 5.10.1
142
143* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.34-6
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
145
146* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.34-5
147- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
148
149* Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:0.34-4
150- rebuild for new perl
151
152* Mon Apr 09 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-3
153- Resolves: bz#226267
154- Only filter out the unversioned Provides: perl(Net::LDAP::Filter) to
155  avoid breaking dependencies.
156
157* Thu Apr 05 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-2
158- Resolves: bz#226267
159- Filter out provides perl(Net::LDAP::Filter) per package review.
160
161* Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 1:0.34-1
162- New version: 0.34
163
164* Wed Sep 27 2006 Robin Norwood <rnorwood@redhat.com> - 1:0.33-3
165- Bugzilla: 207430
166- Incorporate fixes from Jose Oliveira's patch
167- Add perl(IO::Socket::SSL) as a BuildRequires as well
168- Other cleanups from Jose
169
170* Wed Sep 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.33-1.3
171- Add a requirement for IO::Socket::SSL, per bug #122066
172
173* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
174- rebuild
175
176* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.33-1.2
177- rebuild for new perl-5.8.8
178
179* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
180- rebuilt for new gcc
181
182* Tue Apr 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.33-1
183- Update to 0.33.
184
185* Sat Apr 02 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.3202-1
186- Update to 0.3202.
187- Specfile cleanup. (#153766)
188
189* Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 0.31-5
190- rebuild
191
192* Wed Mar 10 2004 Chip Turner <cturner@redhat.com> - 0.31-1
193- Specfile autogenerated.
194
Note: See TracBrowser for help on using the repository browser.