source: projects/specs/trunk/p/perl-JSON/perl-JSON-vl.spec @ 5743

Revision 5743, 6.6 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-JSON
2Summary:        Parse and convert to JSON (JavaScript Object Notation)
3Version:        2.53
4Release:        1%{?_dist_release}
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7Source0:        http://search.cpan.org/CPAN/authors/id/M/MA/MAKAMAKA/JSON-%{version}.tar.gz
8URL:            http://search.cpan.org/dist/JSON/
9Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
10BuildArch:      noarch
11
12BuildRequires:  perl(CGI)
13BuildRequires:  perl(ExtUtils::MakeMaker)
14BuildRequires:  perl(HTTP::Daemon)
15BuildRequires:  perl(LWP::UserAgent)
16BuildRequires:  perl(Scalar::Util)
17BuildRequires:  perl(Test::More)
18BuildRequires:  perl(Test::Pod)
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22Packager:       shaolin
23
24%description
25This module converts between JSON (JavaScript Object Notation) and Perl
26data structure into each other. For JSON, see http://www.crockford.com/JSON/.
27
28%prep
29%setup -q -n JSON-%{version}
30
31# make rpmlint happy...
32find .  -type f -exec chmod -c -x {} +
33find t/ -type f -exec perl -pi -e 's|^#! perl|#!%{__perl}|' {} +
34sed -i 's/\r//' README t/*
35
36%if %{_dist_release} > "vl6"
37%{?perl_default_filter:
38%filter_from_provides /^perl(JSON::\(Backend::PP\|backportPP::Boolean\|Boolean\|PP\|PP::IncrParser\))/d
39%filter_from_requires /^perl(JSON::backportPP)$/d
40%perl_default_filter}
41%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}perl\\(JSON::(Backend::PP|backportPP::Boolean|Boolean|PP|PP::IncrParser)\\)
42%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(JSON::backportPP\\)
43
44%{?perl_default_subpackage_tests}
45
46%else
47cat << \EOF > %{name}-prov
48#!/bin/sh
49%{__perl_provides} $* |\
50sed -e '/perl(JSON::\(Backend::PP\|backportPP::Boolean\|Boolean\|PP\|PP::IncrParser\)/d'
51EOF
52
53%global __perl_provides %{_builddir}/JSON-%{version}/%{name}-prov
54chmod +x %{__perl_provides}
55
56
57cat << \EOF > %{name}-req
58#!/bin/sh
59%{__perl_requires} $* |\
60sed -e '/perl(JSON::backportPP)/d'
61EOF
62
63%global __perl_requires %{_builddir}/JSON-%{version}/%{name}-req
64chmod +x %{__perl_requires}
65%endif
66
67%build
68%{__perl} Makefile.PL
69make %{?_smp_mflags}
70
71%install
72make pure_install DESTDIR=%{buildroot}
73
74find %{buildroot} -type f -name .packlist -exec rm -f {} +
75find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
76
77%{_fixperms} %{buildroot}/*
78
79%check
80make test
81
82%files
83%defattr(-,root,root,-)
84%doc Changes README
85%{perl_sitelib}/*
86%{_mandir}/man3/*
87
88%changelog
89* Thu Feb 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.53-1
90- initial build for Vine Linux
91
92* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.53-4
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
94
95* Wed Jul 20 2011 Iain Arnell <iarnell@gmail.com> 2.53-3
96- update filtering macros for rpm 4.9
97
98* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 2.53-2
99- Perl mass rebuild
100
101* Sun May 22 2011 Paul Howarth <paul@city-fan.org> 2.53-1
102- update to 2.53
103  - fixed to_json (CPAN RT#68359)
104  - backport JSON::PP 2.27200 (fixed incr_parse decoding string more correctly
105    - CPAN RT#68032)
106  - made Makefile.PL skip an installing XS question when set $ENV{PERL_ONLY} or
107    $ENV{NO_XS} (CPAN RT#66820)
108
109* Tue Mar  8 2011 Paul Howarth <paul@city-fan.org> 2.51-1
110- update to 2.51 (#683052)
111  - import JSON::PP 2.27105 as BackportPP
112  - fix documentation (CPAN RT#64738)
113
114* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.50-2
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
116
117* Thu Jan 27 2011 Paul Howarth <paul@city-fan.org> 2.50-1
118- update to 2.50 (#665621)
119  - JSON::PP split off into separate distribution and replaced with
120    JSON::backportPP instead for internal use
121- BR: perl(Test::Pod)
122- drop t/ from %%doc as the tests are in the -tests subpackage
123- filter private module perl(JSON::backportPP) from requires
124- filter private module perl(JSON::backportPP::Boolean) from provides
125- filter private module perl(JSON::Backend::PP) from provides
126- filter private module perl(JSON::Boolean) from provides
127- filter private module perl(JSON::PP) from provides (really JSON::backportPP)
128- filter private module perl(JSON::PP::IncrParser) from provides
129
130* Sun Nov 21 2010 Iain Arnell <iarnell@gmail.com> 2.27-1
131- update to latest upstream version
132- clean up spec for modern rpmbuild
133
134* Sun May 02 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.17-2
135- Mass rebuild with perl-5.12.0
136
137* Sun Feb 28 2010 Chris Weyl <cweyl@alumni.drew.edu> 2.17-1
138- update by Fedora::App::MaintainerTools 0.004
139- PERL_INSTALL_ROOT => DESTDIR
140- dropped old BR on perl(HTTP::Request)
141- dropped old BR on perl(HTTP::Response)
142- dropped old requires on perl(HTTP::Daemon)
143- dropped old requires on perl(LWP::UserAgent)
144- dropped old requires on perl(Scalar::Util)
145
146* Wed Sep 02 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.15-5
147- adjust filtering so we don't drop the versioned perl(JSON:PP) prov
148
149* Tue Sep 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.15-4
150- bump
151
152* Mon Aug 31 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.15-3
153- update filtering
154
155* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.15-2
156- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
157
158* Mon Jun 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.15-1
159- auto-update to 2.15 (by cpan-spec-update 0.01)
160
161* Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 2.14-1
162- update to 2.14
163
164* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-3
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
166
167* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.12-2
168- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
169
170* Sun Oct 12 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.12-1
171- update to 2.12
172
173* Wed Jun 25 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.11-1
174- update to 2.11
175
176* Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.09-1
177- update to 2.09
178
179* Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 2.07-1
180- update to 2.x series before F9
181
182* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.15-2
183- rebuild for new perl
184
185* Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.15-1
186- update to 1.15
187
188* Sun May 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.14-1
189- update to 1.14
190
191* Wed May 09 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.13-1
192- update to 1.13
193
194* Fri May 04 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.12-1
195- update to 1.12
196- add t/ to %%doc
197
198* Wed Apr 25 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.11-2
199- bump
200
201* Tue Apr 24 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.11-1
202- update to 1.11
203
204* Wed Apr 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 1.10-1
205- Specfile autogenerated by cpanspec 1.69.1.
Note: See TracBrowser for help on using the repository browser.